Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Hudson » Hudson doesn't start on Oracle linux
Hudson doesn't start on Oracle linux [message #1013027] Fri, 22 February 2013 16:16 Go to next message
muhammed soyer is currently offline muhammed soyerFriend
Messages: 1
Registered: February 2013
Junior Member
Hi
I downloaded hudson-3.0.0-1.1.noarch.rpm and installed it on an Oracle linux. But when I restart the server I see that it is holding while starting Hudson.

When I try from command line same happens ..

What might be wrong ? I says Starting Hudson and doesn't move ..

/etc/init.d/hudson start
Starting Hudson
Re: Hudson doesn't start on Oracle linux [message #1013052 is a reply to message #1013027] Fri, 22 February 2013 17:16 Go to previous message
Winston Prakash is currently offline Winston PrakashFriend
Messages: 449
Registered: August 2011
Location: Fremont, CA USA
Senior Member
An issue was found and it is discussed in the thread http://www.eclipse.org/forums/index.php/t/446623/

Please edit /etc/init.d/hudson

and change

daemon --user "$HUDSON_USER" --pidfile "$HUDSON_PID_FILE" $JAVA_CMD $PARAMS > /dev/null

to

daemon --user "$HUDSON_USER" --pidfile "$HUDSON_PID_FILE" $JAVA_CMD $PARAMS &> /var/tmp/hudson.log &

After this any log message can be found at /var/tmp/hudson.log


Winston Prakash
Eclipse Hudson team
Previous Topic:SVN externals no longer trigger SCM Polling builds
Next Topic:Migration to 3.0 - thinBackup problem
Goto Forum:
  


Current Time: Sun Dec 21 06:22:00 GMT 2014

Powered by FUDForum. Page generated in 0.01994 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software