Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » EMF 2.9 and RAP 1.5
EMF 2.9 and RAP 1.5 [message #1012480] Thu, 21 February 2013 16:32 Go to next message
Lothar Werzinger is currently offline Lothar WerzingerFriend
Messages: 153
Registered: July 2009
Location: Bay Area
Senior Member
I have a RAP 1.5 application and I tried to create a target platform based on the latest Kepler milestone to get a newer version of CDO and EMF.
As I don't want to make the transition to RAP 2.0 immediately I created the target platform with RAP 1.5 instead of RAP 2.0.

Everything in my application compiles fine, but when I try to build the product it fails, as the EMF RAP plugins (org.eclipse.emf.rap.common.ui and org.eclipse.emf.rap.edit.ui) depend on RAP 2.0 as the minimum plugin version.

This dependency is the only thing that prevents me currently from using CDO 4.2 and EMF 2.9 with my RAP 1.5 based application.

Is RAP 2.0 really required as the minimum plugin version or could the plugins work with RAP 1.X as well? If the plugins don't need 2.0, can the version range be changed, so that one can build RAP 1.5 Applications with EMF 2.9?

Thanks in advance!
Re: EMF 2.9 and RAP 1.5 [message #1012695 is a reply to message #1012480] Fri, 22 February 2013 03:39 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 26283
Registered: July 2009
Senior Member
Lothar,

I think the changes we made should allow it to continue to work with 1.5

http://git.eclipse.org/c/emf/org.eclipse.emf.git/commit/?id=6246af91070f7f0520dfa831ad5c37dc8b8bbbbe
http://git.eclipse.org/c/emf/org.eclipse.emf.git/commit/?id=942c099f3f5aa8e6ef6d9d1bc4d752fbd74894ca

But I'm not sure if Dennis is building against 2.0 or against 1.5

https://bugs.eclipse.org/bugs/show_bug.cgi?id=387180

The build inserts the bounds, so it sounds like he's building against
2.0 if that's what you're seeing as the lower bound.

In general, because RAP has broken APIs, you should expect that
frameworks using it will similarly need to make incompatible changes,
although that's not the case for EMF's RAP support.


On 21/02/2013 5:32 PM, Lothar Werzinger wrote:
> I have a RAP 1.5 application and I tried to create a target platform
> based on the latest Kepler milestone to get a newer version of CDO and
> EMF.
> As I don't want to make the transition to RAP 2.0 immediately I
> created the target platform with RAP 1.5 instead of RAP 2.0.
>
> Everything in my application compiles fine, but when I try to build
> the product it fails, as the EMF RAP plugins
> (org.eclipse.emf.rap.common.ui and org.eclipse.emf.rap.edit.ui) depend
> on RAP 2.0 as the minimum plugin version.
>
> This dependency is the only thing that prevents me currently from
> using CDO 4.2 and EMF 2.9 with my RAP 1.5 based application.
>
> Is RAP 2.0 really required as the minimum plugin version or could the
> plugins work with RAP 1.X as well? If the plugins don't need 2.0, can
> the version range be changed, so that one can build RAP 1.5
> Applications with EMF 2.9?
>
> Thanks in advance!
Previous Topic:[Teneo] Errors when deploying teneo 2.0.1 + hibernate 4 in JBoss 7
Next Topic:[CDO] Problems with XML Import
Goto Forum:
  


Current Time: Fri Dec 19 22:59:39 GMT 2014

Powered by FUDForum. Page generated in 0.08487 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software