Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Diagram not navigable in Kepler
Diagram not navigable in Kepler [message #1012338] Thu, 21 February 2013 06:26 Go to next message
Eclipse User
Hi Team,

just gave a fist test on Kepler M5 and Papyrus Nightly (19th February).

I was not able to open a diagram (neither via double-click nor via context
menu) from the ModelExplorer.

I was also not able to navigate from a an element in a diagram to a linked
diagram via the plus button. I could specify the link properply, but the
diagram was not opened.

There was even no error trace logged!

Regards,
Marc-Florian
Re: Diagram not navigable in Kepler [message #1012349 is a reply to message #1012338] Thu, 21 February 2013 06:48 Go to previous messageGo to next message
Ed Willink is currently offline Ed Willink
Messages: 3840
Registered: July 2009
Senior Member
Hi

Have checked carefully? I've found that the editor is opened but is not
made the active editor, so you may need to rummage in the available
editor tabs top find it! Not yet got round to raising a Bugzilla; since
the platform has been making significant adjustments to view activation,
I wasn't sure whether this was really a Papyrus bug.

Regards

Ed Willink

On 21/02/2013 11:26, Florian Wendland wrote:
> Hi Team,
>
> just gave a fist test on Kepler M5 and Papyrus Nightly (19th February).
>
> I was not able to open a diagram (neither via double-click nor via
> context menu) from the ModelExplorer.
>
> I was also not able to navigate from a an element in a diagram to a
> linked diagram via the plus button. I could specify the link
> properply, but the diagram was not opened.
>
> There was even no error trace logged!
>
> Regards,
> Marc-Florian
Re: Diagram not navigable in Kepler [message #1012358 is a reply to message #1012349] Thu, 21 February 2013 07:08 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille Letavernier
Messages: 399
Registered: February 2011
Senior Member
Hello Marc-Florian and Ed,


I'm currently working on the major Papyrus-page issues. Current status is, on the nightly build:

- Creating, opening, navigating, deleting, ... pages works correctly
- Deleting an element which "contains" an opened diagram still leads to model corruption. See Bug 401109
- Programmatically changing the "active page" (i.e. active tab) does not work yet. See Bug 401107. Consequently, it is not possible to navigate an hyperlink to a page which is already opened (In the previous versions of Papyrus, it used to re-open the page)

So... I'm actually quite surprised that you cannot perform these actions. The only thing that could still cause this issue would be a partially-corrupted model (e.g. you're trying to open a diagram which is not in the list of "available pages" in the DI model... This should not happen anymore, but it might be the case for diagrams created in previous versions of Papyrus).


Regards,
Camille
Re: Diagram not navigable in Kepler [message #1013115 is a reply to message #1012358] Fri, 22 February 2013 15:17 Go to previous message
Eclipse User
Hi Camille,

yes, thanks for pointing this out. In fact, I did not tried if a diagram
that is not open will be opened and get the focus. So, this scenario works
nice. If a diagram is closed, it will be opened and be activated.

As you said, switching to an already opened diagram does not work, neither
from the ModelExplorer nor from the hyperlink.

I WILL NOT file a bug, since it is already filed and such a fundamental
thing, I guess this will be fixed soon.

Regards,
Marc-Florian

"Camille Letavernier" schrieb im Newsbeitrag
news:kg52nd$l9f$1@xxxxxxxxe.org...

Hello Marc-Florian and Ed,


I'm currently working on the major Papyrus-page issues. Current status is,
on the nightly build:

- Creating, opening, navigating, deleting, ... pages works correctly
- Deleting an element which "contains" an opened diagram still leads to
model corruption. See https://bugs.eclipse.org/bugs/show_bug.cgi?id=401109
- Programmatically changing the "active page" (i.e. active tab) does not
work yet. See https://bugs.eclipse.org/bugs/show_bug.cgi?id=401107.
Consequently, it is not possible to navigate an hyperlink to a page which is
already opened (In the previous versions of Papyrus, it used to re-open the
page)

So... I'm actually quite surprised that you cannot perform these actions.
The only thing that could still cause this issue would be a
partially-corrupted model (e.g. you're trying to open a diagram which is not
in the list of "available pages" in the DI model... This should not happen
anymore, but it might be the case for diagrams created in previous versions
of Papyrus).


Regards,
Camille
Previous Topic:import registered package
Next Topic:Problem installing palette
Goto Forum:
  


Current Time: Wed Apr 16 09:35:16 EDT 2014

Powered by FUDForum. Page generated in 0.03906 seconds