Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » SWTBot » Where to get the SWTBot version for juno?
Where to get the SWTBot version for juno? [message #1012047] Wed, 20 February 2013 14:32 Go to next message
Steven Chamberlin is currently offline Steven Chamberlin
Messages: 30
Registered: July 2009
Member
So, 205 continues to be the latest version of SWTBot, without official support for juno, correct?

As I understand from reading on this forum, there has been a development build that hasn't been officially released / marked as completed, that we can try , that has some bug fixes for juno? I haven't been able to find this. 205 still seems to be the latest from the official update site.

In another thread, Mickael Istria pointed to the following location:

http://download.eclipse.org/technology/swtbot/snapshots/

but it seems this URL is not working at the moment.

Can anyone please help?

Also, is there a running issue of the known issues with juno being tracked / kept somewhere?

Thanks.
Re: Where to get the SWTBot version for juno? [message #1012175 is a reply to message #1012047] Wed, 20 February 2013 21:54 Go to previous messageGo to next message
Steven Chamberlin is currently offline Steven Chamberlin
Messages: 30
Registered: July 2009
Member
Nevermind; I think the problem is that I need to do that from Eclipse rather than clicking on the web link as I was doing.
Re: Where to get the SWTBot version for juno? [message #1012869 is a reply to message #1012047] Fri, 22 February 2013 06:05 Go to previous message
Mickael Istria is currently offline Mickael Istria
Messages: 741
Registered: July 2009
Location: Grenoble, France
Senior Member
On 02/20/2013 08:32 PM, Steven Chamberlin wrote:
> So, 205 continues to be the latest version of SWTBot, without official
> support for juno, correct?

Just to be clear, even with the future 2.1.0, there is no "official"
support for Juno. SWTBot in a community project, so you'll get support
for what the community is OK to support...
Which use-case could you not get to work with 2.0.5 on Juno? If you
found a bug, make sure it's reported

> As I understand from reading on this forum, there has been a development
> build that hasn't been officially released / marked as completed, that
> we can try , that has some bug fixes for juno?

Yes, there is a continuous integration build which runs on both 3.8 and
4.2, with some minor issues still there for 4.2.
This snapshot build is the always latest available, but is not the release.
The release of 2.1.0 should happen soon (I started the process of
releasing, but since I'm a newbie at doing it and Hudson.eclipse.org is
down takes me some time...)

> http://download.eclipse.org/technology/swtbot/snapshots/
> but it seems this URL is not working at the moment.

I just gave a try, and it works for me. Eclipse.org has some IT issues
yesterday, can you retry now?
>

> Also, is there a running issue of the known issues with juno being
> tracked / kept somewhere?
https://bugs.eclipse.org/bugs/show_bug.cgi?id=385527

HTH

--
Mickael Istria
JBoss, by Red Hat
My blog: http://mickaelistria.wordpress.com
My Tweets: http://twitter.com/mickaelistria
Previous Topic:SWTBot for eclipse Juno
Next Topic:Error/Exception handling using SWTBot .
Goto Forum:
  


Current Time: Fri Aug 22 23:37:22 EDT 2014

Powered by FUDForum. Page generated in 0.01589 seconds