Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Difficulties getting started with RAP 2.0
Difficulties getting started with RAP 2.0 [message #1011843] Wed, 20 February 2013 10:51 Go to next message
Hansjörg Schmauder is currently offline Hansjörg SchmauderFriend
Messages: 2
Registered: February 2013
Junior Member
Hello everyone,

with no experience on former versions of RAP, OSGi, Equinox, RCP etc., I tried to get a RAP 2.0 application running. After a short while, I could start my "Hello World" application on Eclipse's Jetty server. My next goal was to get it running on an Apache Tomcat 7 server, which I've been trying for half a week now and I'm getting more frustrated every day.

From the RAP Tools 2.0, I used the org.eclipse.rap.demo project as seen in RAP developer guide. As far as I could see, this already includes the Equinox servlet bridge required to run the RAP application, so I created the .warproduct file, strictly following the tutorial, and deployed the rapdemo.war on my Tomcat. I can get the following status using the OSGi ss command:

osgi> ss
"Framework is launched."


id      State       Bundle
0       ACTIVE      org.eclipse.osgi_3.8.1.v20120830-144521
                    Fragments=35
1       ACTIVE      com.ibm.icu.base_4.4.2.v20110831
2       ACTIVE      org.apache.felix.gogo.command_0.8.0.v201108120515
3       ACTIVE      org.apache.felix.gogo.runtime_0.8.0.v201108120515
4       ACTIVE      org.apache.felix.gogo.shell_0.8.0.v201110170705
5       ACTIVE      org.eclipse.core.commands_3.6.1.v20120814-150512
6       ACTIVE      org.eclipse.core.contenttype_3.4.200.v20120523-2004
7       ACTIVE      org.eclipse.core.databinding_1.4.1.v20120521-2329
8       ACTIVE      org.eclipse.core.databinding.beans_1.2.200.v20120523-1955
9       ACTIVE      org.eclipse.core.databinding.observable_1.4.1.v20120521-2329
10      ACTIVE      org.eclipse.core.databinding.property_1.4.100.v20120523-1955
11      ACTIVE      org.eclipse.core.expressions_3.4.401.v20120627-124442
12      ACTIVE      org.eclipse.core.jobs_3.5.300.v20120622-204750
13      ACTIVE      org.eclipse.core.runtime_3.8.0.v20120521-2346
14      ACTIVE      org.eclipse.equinox.app_1.3.100.v20120522-1841
15      ACTIVE      org.eclipse.equinox.common_3.6.100.v20120522-1841
16      ACTIVE      org.eclipse.equinox.console_1.0.0.v20120522-1841
17      ACTIVE      org.eclipse.equinox.http.registry_1.1.200.v20120522-2049
18      ACTIVE      org.eclipse.equinox.http.servlet_1.1.300.v20120522-1841
19      ACTIVE      org.eclipse.equinox.http.servletbridge_1.0.300.v20120522-2049
20      ACTIVE      org.eclipse.equinox.preferences_3.5.0.v20120522-1841
21      ACTIVE      org.eclipse.equinox.registry_3.5.200.v20120522-1841
22      ACTIVE      org.eclipse.equinox.servletbridge_1.2.200.v20120522-2049
23      ACTIVE      org.eclipse.help_3.6.0.v20120521-2344
24      ACTIVE      org.eclipse.osgi.services_3.3.100.v20120522-1822
25      ACTIVE      org.eclipse.rap.demo_2.0.0.20130124-1720
26      ACTIVE      org.eclipse.rap.design.example_2.0.0.20130110-2246
27      ACTIVE      org.eclipse.rap.jface_2.0.0.20130107-0921
28      ACTIVE      org.eclipse.rap.jface.databinding_2.0.0.20121031-1050
29      ACTIVE      org.eclipse.rap.rwt_2.0.0.20130205-1612
30      ACTIVE      org.eclipse.rap.rwt.osgi_2.0.0.20130110-2216
31      ACTIVE      org.eclipse.rap.ui_2.0.0.20121230-1109
32      ACTIVE      org.eclipse.rap.ui.forms_2.0.0.20130111-1314
33      ACTIVE      org.eclipse.rap.ui.views_2.0.0.20130111-1314
34      ACTIVE      org.eclipse.rap.ui.workbench_2.0.0.20130107-1035
35      RESOLVED    org.eclipse.equinox.servletbridge.extensionbundle_1.2.100.v20120522-2049
                    Master=0


How do I run the application? Am I maybe just missing the right URL? I tried localhost:8080/rapdemo/rap, but I always only get 404 errors. Any help desperately appreciated!

Best regards
Hansjörg
Re: Difficulties getting started with RAP 2.0 [message #1011963 is a reply to message #1011843] Wed, 20 February 2013 15:47 Go to previous messageGo to next message
Hansjörg Schmauder is currently offline Hansjörg SchmauderFriend
Messages: 2
Registered: February 2013
Junior Member
Hey,

I could already solve the problem and it really was the URL. The correct address was: localhost:8080/rapdemo/app
It really took me some days to find this though in the change log from RAP 1.5 to 2.0. Not the first place I was looking as a beginner...

Best regards
Hansjörg
Re: Difficulties getting started with RAP 2.0 [message #1014150 is a reply to message #1011963] Mon, 25 February 2013 09:05 Go to previous messageGo to next message
Ralf Sternberg is currently offline Ralf SternbergFriend
Messages: 1295
Registered: July 2009
Senior Member

Where would you have expected this information?

Reagrds,
Ralf

--
Ralf Sternberg

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: Difficulties getting started with RAP 2.0 [message #1015742 is a reply to message #1014150] Sat, 02 March 2013 02:06 Go to previous message
Charles Tubbs is currently offline Charles TubbsFriend
Messages: 35
Registered: March 2012
Member
The RAP Developer Guide seems like a nice place.
Previous Topic:How to have single sourcing ?
Next Topic:Graphic glitches on IE9 on RAP 2.0
Goto Forum:
  


Current Time: Sat Nov 29 06:39:29 GMT 2014

Powered by FUDForum. Page generated in 0.02438 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software