Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Some SWT tree nodes are not selected with Select Node by...(This problem appears only with a class extending eclipse Viewpart class)
Some SWT tree nodes are not selected with Select Node by... [message #1011325] Tue, 19 February 2013 10:26 Go to next message
Andre Renard is currently offline Andre RenardFriend
Messages: 20
Registered: February 2013
Junior Member
In my application I have two types of SWT trees. One type extend Viewpart, the other extends a home-class extending Viewpart (but not overriding any of its methods). I have no problem using 'Select Node by...' with the first type. But some items are not selected in the second type. They are not selected but the mouse goes over them and the test succeeds. The decoration of the selectable items differs (it 'replaces') from the non-selectable ones (it 'overlays'), but it is also the case within the type 1 trees.

What can I do to solve this problem?
Re: Some SWT tree nodes are not selected with Select Node by... [message #1011333 is a reply to message #1011325] Tue, 19 February 2013 10:42 Go to previous messageGo to next message
Andre Renard is currently offline Andre RenardFriend
Messages: 20
Registered: February 2013
Junior Member
But the Check Existence of Node by... succeeds (true).
Re: Some SWT tree nodes are not selected with Select Node by... [message #1011339 is a reply to message #1011333] Tue, 19 February 2013 10:55 Go to previous messageGo to next message
Andre Renard is currently offline Andre RenardFriend
Messages: 20
Registered: February 2013
Junior Member
Expand Node by... also works. So it is just the selection that does not work.
Re: Some SWT tree nodes are not selected with Select Node by... [message #1011373 is a reply to message #1011339] Tue, 19 February 2013 12:41 Go to previous messageGo to next message
Andre Renard is currently offline Andre RenardFriend
Messages: 20
Registered: February 2013
Junior Member
Removing the decoration does not solve the problem.

[Updated on: Tue, 19 February 2013 12:41]

Report message to a moderator

Re: Some SWT tree nodes are not selected with Select Node by... [message #1012771 is a reply to message #1011373] Fri, 22 February 2013 07:55 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1169
Registered: July 2009
Senior Member
Hi Andre,

Are there any logs produced (RC logs for the toollkit), and can you provide a snippet of the code?
What OS are you on?
Are you performing 0 clicks by accident (silly question, but worth checking Wink )
What happens if you perform e.g. 2 clicks?

Best regards,
Alex
Re: Some SWT tree nodes are not selected with Select Node by... [message #1014815 is a reply to message #1012771] Tue, 26 February 2013 14:17 Go to previous messageGo to next message
Andre Renard is currently offline Andre RenardFriend
Messages: 20
Registered: February 2013
Junior Member
Alexandra Schladebeck wrote on Fri, 22 February 2013 02:55
Hi Andre,

Are there any logs produced (RC logs for the toollkit), and can you provide a snippet of the code?

No error in the log

Alexandra Schladebeck wrote on Fri, 22 February 2013 02:55

What OS are you on?

Windows 7

Alexandra Schladebeck wrote on Fri, 22 February 2013 02:55

Are you performing 0 clicks by accident (silly question, but worth checking Wink )
What happens if you perform e.g. 2 clicks?

Was really one click. Tried 2 clicks (is supposed to be equivalent in our application to selecting the folder and renaming it; sing the recorder, Jubula recorded only 1 click) and left click with no improvement...
Re: Some SWT tree nodes are not selected with Select Node by... [message #1015007 is a reply to message #1014815] Wed, 27 February 2013 07:56 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1169
Registered: July 2009
Senior Member
Hm. Interesting - any chance of providing a snippet or (even better) a small example AUT that could be attached to a ticket?
Re: Some SWT tree nodes are not selected with Select Node by... [message #1015011 is a reply to message #1015007] Wed, 27 February 2013 08:06 Go to previous messageGo to next message
Andre Renard is currently offline Andre RenardFriend
Messages: 20
Registered: February 2013
Junior Member
Hi Alex,
I will review this with our AUT developers today (I am just a tester) and try to come back to you with some code.
I am currently facing too many problems with Jubula so I am considering to revise my decision to use it.
Best regards
Andre
Re: Some SWT tree nodes are not selected with Select Node by... [message #1015043 is a reply to message #1015011] Wed, 27 February 2013 09:34 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1169
Registered: July 2009
Senior Member
Hi Andre,

Thanks for the feedback, and sorry to hear that you're facing problems. Looking at the ones from the forum, it looks like you have the drag and drop problem in tree tables and this one (one possible workaround that comes to mind is selecting by indexpath - does that work?).

If you have other problems or feedback, then please enter them as bugs, or give more details e.g. here or in another thread. If waiting on answers is too long at the moment, then you might want to consider getting some professional support hours from BREDEX so that your questions get answered more quickly and in more detail.

Best regards,
Alex
Re: Some SWT tree nodes are not selected with Select Node by... [message #1015657 is a reply to message #1015043] Fri, 01 March 2013 14:53 Go to previous messageGo to next message
Andre Renard is currently offline Andre RenardFriend
Messages: 20
Registered: February 2013
Junior Member
Hi Alex,
I made some tests today with a few (SWT) trees and there it works.
My developer will now have a look at her code.
Andre
Re: Some SWT tree nodes are not selected with Select Node by... [message #1015893 is a reply to message #1015657] Mon, 04 March 2013 08:20 Go to previous message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1169
Registered: July 2009
Senior Member
Thanks for the update - keep us posted!
Previous Topic:Jubula Standalone Build
Next Topic:Should I see the dragged node during a dragNdrop?
Goto Forum:
  


Current Time: Fri Nov 28 23:24:34 GMT 2014

Powered by FUDForum. Page generated in 0.03608 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software