Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » Xcore - derived features and reflective feature delegation
Xcore - derived features and reflective feature delegation [message #1009046] Thu, 14 February 2013 10:37 Go to next message
Jan Rosczak is currently offline Jan Rosczak
Messages: 35
Registered: July 2009
Location: Hamburg, Germany
Member
Hi,

I have an Xcore model that has derived features and has the GenModel property "featureDelegation" set to "reflective" (needed for CDO).

In such a scenario the implementation of the derived feature methods completely ignore my code as defined in the Xcore model.

That is not what I would expect. Anything I could do to make derived features work together with reflective feature delegation?

Thanks
Jan
Re: Xcore - derived features and reflective feature delegation [message #1009069 is a reply to message #1009046] Thu, 14 February 2013 11:20 Go to previous messageGo to next message
Ed Merks is currently offline Ed Merks
Messages: 26054
Registered: July 2009
Senior Member
Jan,

Which version of Xcore are you using. (It sounds familiar like
something I've fixed in the 2.9 stream).

On 14/02/2013 11:37 AM, Jan Rosczak wrote:
> Hi,
>
> I have an Xcore model that has derived features and has the GenModel
> property "featureDelegation" set to "reflective" (needed for CDO).
>
> In such a scenario the implementation of the derived feature methods
> completely ignore my code as defined in the Xcore model.
>
> That is not what I would expect. Anything I could do to make derived
> features work together with reflective feature delegation?
>
> Thanks
> Jan
Re: Xcore - derived features and reflective feature delegation [message #1009073 is a reply to message #1009069] Thu, 14 February 2013 11:31 Go to previous messageGo to next message
Jan Rosczak is currently offline Jan Rosczak
Messages: 35
Registered: July 2009
Location: Hamburg, Germany
Member
Hi,

I am using version 1.0.1.

//Jan
Re: Xcore - derived features and reflective feature delegation [message #1009080 is a reply to message #1009073] Thu, 14 February 2013 11:49 Go to previous messageGo to next message
Ed Merks is currently offline Ed Merks
Messages: 26054
Registered: July 2009
Senior Member
<html>
<head>
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type">
</head>
<body text="#000000" bgcolor="#FFFFFF">
Jan,<br>
<br>
That's from the maintenance stream.  The 1.1 version is part of the
EMF 2.9 stream and it has a great many fixes, including what sounds
like your problem:<br>
<blockquote><a class="moz-txt-link-freetext" href="https://bugs.eclipse.org/bugs/show_bug.cgi?id=385634">https://bugs.eclipse.org/bugs/show_bug.cgi?id=385634</a><br>
</blockquote>
So please try that version.   The version in the Kepler repo should
be a good one.<br>
<br>
<br>
<div class="moz-cite-prefix">On 14/02/2013 12:31 PM, Jan Rosczak
wrote:<br>
</div>
<blockquote cite="mid:kfihv2$4m6$1@xxxxxxxxe.org" type="cite">Hi,
<br>
<br>
I am using version 1.0.1.
<br>
<br>
//Jan
<br>
</blockquote>
<br>
</body>
</html>
Re: Xcore - derived features and reflective feature delegation [message #1009544 is a reply to message #1009080] Fri, 15 February 2013 09:48 Go to previous message
Jan Rosczak is currently offline Jan Rosczak
Messages: 35
Registered: July 2009
Location: Hamburg, Germany
Member
Hi Ed,

I installed milestone M5 and it works!

Thanks a lot
Jan
Previous Topic:Empty Combo when EMF databinding to a combo in a table viewer
Next Topic:[CDO] OCL Query and sub types
Goto Forum:
  


Current Time: Mon Sep 22 02:15:42 GMT 2014

Powered by FUDForum. Page generated in 0.01717 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software