Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » Tracking of Audio Files(eGit not recognizing .au files)
Tracking of Audio Files [message #1008771] Wed, 13 February 2013 15:26 Go to next message
Max Bedacht is currently offline Max Bedacht
Messages: 2
Registered: February 2013
Junior Member
I just started using eGit (I put one project under control). Prior to using eGit I was able to import and use audio files in this Java project. From the time of placing the project under eGit I am no longer able to effectively import audio files. The ones that were already in the project when it was put in Git still play, but any new ones imported show a question mark in the lower right corner of their icon and will not play. (The older ones have something that is yellow, but otherwise unrecognizable in the lower right corner.)

Are there any restrictions or special handling required for tracked files under Git (or eGit)? Should I not track these files?

Any help would be greatly appreciated.
Re: Tracking of Audio Files [message #1008793 is a reply to message #1008771] Wed, 13 February 2013 16:29 Go to previous messageGo to next message
Robin Rosenberg is currently offline Robin Rosenberg
Messages: 319
Registered: July 2009
Senior Member
Max Bedacht skrev 2013-02-13 21.32:
> I just started using eGit (I put one project under control). Prior to using eGit I was able to import and use audio files in this Java project. From the time of placing the
> project under eGit I am no longer able to effectively import audio files. The ones that were already in the project when it was put in Git still play, but any new ones
> imported show a question mark in the lower right corner of their icon and will not play. (The older ones have something that is yellow, but otherwise unrecognizable in the
> lower right corner.)
>
> Are there any restrictions or special handling required for tracked files under Git (or eGit)? Should I not track these files?
>
> Any help would be greatly appreciated.

I assume you are on Windows where autocrlf is the default if you have Git installed. The autocrlf feature will try to
autodetect binary files, but it only works if there is a nul byte wiithin the first 8Kib bytes of the file. You can
turn autocrlf off by setting the core.autocrlf config variable to false locally.

The core.safecrlf or gitattributes that would improve the situtation are not implemented yet. safecrlf is in gerrit, but
nobody seems to care :(, so I've left it until gitattributes supoort appears, which is supposed to come soon, but it
appears there is some delay.

Eclipse allows you to set the workspace to use LF only, even on Windows so you should be able to do cross-platform
work even on Windows without enabling autocrlf. If it is a pure Windows-project you can also disable autocrlf, which
is what I do.

-- robin
Re: Tracking of Audio Files [message #1009088 is a reply to message #1008793] Thu, 14 February 2013 07:08 Go to previous message
Max Bedacht is currently offline Max Bedacht
Messages: 2
Registered: February 2013
Junior Member
Robin;

Thanks for you response, which pointed me in the right direction. I have removed the audio and image files from the Git tracking and now everything is OK. I should have realized that this tracking would only be effective for text files anyway. I have put all my media filetypes in the .gitignore file and did not include them in the commit. My misunderstanding of the process led to my misuse of Git(eGit). BTW, I am using Linux, not Windows, no crlf problems.

Max
Previous Topic:Problems Installing EGit
Next Topic:What view is this?
Goto Forum:
  


Current Time: Fri Aug 29 22:39:00 EDT 2014

Powered by FUDForum. Page generated in 0.09411 seconds