Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Epsilon » Epsilon Development Tools on Eclipse 4.3
Epsilon Development Tools on Eclipse 4.3 [message #1008596] Wed, 13 February 2013 09:03 Go to next message
Ralph Gerbig is currently offline Ralph GerbigFriend
Messages: 697
Registered: November 2009
Senior Member
Hi all,

I try to install Epsilon Development Tools on Eclipse 4.3. I get the following dependeny error even though EMF Compare is installed from the 4.3 update site.

Quote:

Cannot complete the install because one or more required items could not be found.
Software being installed: Epsilon Development Tools for EMF 1.0.0.201211082326 (org.eclipse.epsilon.emf.dt.feature.feature.group 1.0.0.201211082326)
Missing requirement: Epsilon Development Tools for EMF 1.0.0.201211082326 (org.eclipse.epsilon.emf.dt.feature.feature.group 1.0.0.201211082326) requires 'org.eclipse.emf.compare.ui 0.0.0' but it could not be found


The update site I use is http://download.eclipse.org/epsilon/updates/. Is there an alternative update site available with a built for Eclipse 4.3?

Ralph
Re: Epsilon Development Tools on Eclipse 4.3 [message #1008628 is a reply to message #1008596] Wed, 13 February 2013 11:03 Go to previous messageGo to next message
Antonio Garcia-Dominguez is currently offline Antonio Garcia-DominguezFriend
Messages: 310
Registered: January 2010
Senior Member
Hi Ralph,

There have been some backwards-incompatible changes in Kepler regarding EMF Compare (Kepler uses 2.x instead of 1.x), so Epsilon 1.0 will not install properly in there.

I think we addressed these issues in our latest interim build. Could you give it a try? Except for the EUnit assertEqualModels assertion, everything should work.

http://download.eclipse.org/epsilon/interim/

-- Antonio
Re: Epsilon Development Tools on Eclipse 4.3 [message #1008631 is a reply to message #1008596] Wed, 13 February 2013 11:05 Go to previous messageGo to next message
Antonio Garcia-Dominguez is currently offline Antonio Garcia-DominguezFriend
Messages: 310
Registered: January 2010
Senior Member
Incidentally, we have some fixes for these assertions as well, but we haven't had time yet to properly integrate the fixes into our build process. We'll probably need to build a Kepler-specific update site sometime soon.

Do you need the assertEqualModels assertions before Kepler is released?
Re: Epsilon Development Tools on Eclipse 4.3 [message #1008640 is a reply to message #1008631] Wed, 13 February 2013 11:42 Go to previous message
Ralph Gerbig is currently offline Ralph GerbigFriend
Messages: 697
Registered: November 2009
Senior Member
Hi,

I only use EVL. This installs fine with the interims update site you mentioned.

Ralph
Previous Topic:Emfatic/Eugenia
Next Topic:Why model in Epsilon?
Goto Forum:
  


Current Time: Mon Dec 22 08:00:29 GMT 2014

Powered by FUDForum. Page generated in 0.02016 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software