Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » [CDO] BufferUnderflowException when trying to connect with Java 7 (64bit)
[CDO] BufferUnderflowException when trying to connect with Java 7 (64bit) [message #1008232] Mon, 11 February 2013 16:17 Go to next message
Stephan Krusche is currently offline Stephan Krusche
Messages: 18
Registered: September 2012
Junior Member
Hi,

I have a CDO Server and CDO Client (using 4.2M5) that can connect to each other without problems when I use Java 6 (either 32bit or 64bit).

When I use Java 7 (which is only available in 64bit for MacOS X) for both, client and server, I get the following exception on CDO Server site, when the client tries to connect.

[ERROR] BufferUnderflowException

!ENTRY org.eclipse.net4j.tcp 4 0 java.nio.BufferUnderflowException
	at java.nio.Buffer.nextGetIndex(Buffer.java:498)
	at java.nio.DirectByteBuffer.getShort(DirectByteBuffer.java:580)
	at org.eclipse.net4j.internal.tcp.ssl.SSLBuffer.startGetting(SSLBuffer.java:84)
	at org.eclipse.net4j.internal.tcp.TCPConnector.handleRead(TCPConnector.java:219)
	at org.eclipse.net4j.internal.tcp.ssl.SSLConnector.handleRead(SSLConnector.java:70)
	at org.eclipse.net4j.internal.tcp.TCPSelector.handleSelection(TCPSelector.java:255)
	at org.eclipse.net4j.internal.tcp.TCPSelector.run(TCPSelector.java:170)
	at java.lang.Thread.run(Thread.java:722)
2013-02-11 17:14:46.462
!MESSAGE BufferUnderflowException
!STACK 0
java.nio.BufferUnderflowException
	at java.nio.Buffer.nextGetIndex(Buffer.java:498)
	at java.nio.DirectByteBuffer.getShort(DirectByteBuffer.java:580)
	at org.eclipse.net4j.internal.tcp.ssl.SSLBuffer.startGetting(SSLBuffer.java:84)
	at org.eclipse.net4j.internal.tcp.TCPConnector.handleRead(TCPConnector.java:219)
	at org.eclipse.net4j.internal.tcp.ssl.SSLConnector.handleRead(SSLConnector.java:70)
	at org.eclipse.net4j.internal.tcp.TCPSelector.handleSelection(TCPSelector.java:255)
	at org.eclipse.net4j.internal.tcp.TCPSelector.run(TCPSelector.java:170)
	at java.lang.Thread.run(Thread.java:722)
[ERROR] BufferUnderflowException
!ENTRY org.eclipse.net4j.tcp 


Any idea why this happens? I am sure that both, server and client, use the same Java version (7u13), both with 64 bit, because I print it to the console at application start.

Thanks for help!
Stephan

[Updated on: Fri, 15 February 2013 07:37]

Report message to a moderator

Re: [CDO] BufferUnderflowException when trying to connect with Java 7 (64bit) [message #1008779 is a reply to message #1008232] Wed, 13 February 2013 20:54 Go to previous messageGo to next message
Stephan Krusche is currently offline Stephan Krusche
Messages: 18
Registered: September 2012
Junior Member
Can anyone reproduce the problem?
Any idea why this BufferUnderflowException happens with jdk7u13 (64bit)?
Could it be a bug or is it more likely that I misconfigured something?

[Updated on: Fri, 15 February 2013 07:38]

Report message to a moderator

Re: [CDO] BufferUnderflowException when trying to connect with 64bit JVM [message #1009487 is a reply to message #1008232] Fri, 15 February 2013 08:17 Go to previous message
Eike Stepper is currently offline Eike Stepper
Messages: 5522
Registered: July 2009
Senior Member
Am 11.02.2013 17:17, schrieb Stephan Krusche:
> Hi,
>
> I have a CDO Server and CDO Client (using 4.2M5) that can connect to each other without problems when I use Java 6
> (either 32bit or 64bit).
And no problems with the 7u13 64 bit JRE and older CDO versions?

>
> When I use Java 7 (which is only available in 64bit for MacOS X) for both, client and server, I get the following
> exception on CDO Server site, when the client tries to connect.
That's bad but interesting because I vaguely remember that this has come up once or twice and we've never had any chance
to reproduce this or even look at it in the context of specific environment constraints. These are some bugs that may be
related:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=299871
https://bugs.eclipse.org/bugs/show_bug.cgi?id=295989
https://bugs.eclipse.org/bugs/show_bug.cgi?id=262875

Yesterday I downloaded JDK 7u13 64 bit and I plan to run the tests with it. Not sure though when I can come to this. Can
you please submit a bugzilla to remind me?

Cheers
/Eike

----
http://www.esc-net.de
http://thegordian.blogspot.com
http://twitter.com/eikestepper


>
>
> [ERROR] BufferUnderflowException
>
> !ENTRY org.eclipse.net4j.tcp 4 0 java.nio.BufferUnderflowException
> at java.nio.Buffer.nextGetIndex(Buffer.java:498)
> at java.nio.DirectByteBuffer.getShort(DirectByteBuffer.java:580)
> at org.eclipse.net4j.internal.tcp.ssl.SSLBuffer.startGetting(SSLBuffer.java:84)
> at org.eclipse.net4j.internal.tcp.TCPConnector.handleRead(TCPConnector.java:219)
> at org.eclipse.net4j.internal.tcp.ssl.SSLConnector.handleRead(SSLConnector.java:70)
> at org.eclipse.net4j.internal.tcp.TCPSelector.handleSelection(TCPSelector.java:255)
> at org.eclipse.net4j.internal.tcp.TCPSelector.run(TCPSelector.java:170)
> at java.lang.Thread.run(Thread.java:722)
> 2013-02-11 17:14:46.462
> !MESSAGE BufferUnderflowException
> !STACK 0
> java.nio.BufferUnderflowException
> at java.nio.Buffer.nextGetIndex(Buffer.java:498)
> at java.nio.DirectByteBuffer.getShort(DirectByteBuffer.java:580)
> at org.eclipse.net4j.internal.tcp.ssl.SSLBuffer.startGetting(SSLBuffer.java:84)
> at org.eclipse.net4j.internal.tcp.TCPConnector.handleRead(TCPConnector.java:219)
> at org.eclipse.net4j.internal.tcp.ssl.SSLConnector.handleRead(SSLConnector.java:70)
> at org.eclipse.net4j.internal.tcp.TCPSelector.handleSelection(TCPSelector.java:255)
> at org.eclipse.net4j.internal.tcp.TCPSelector.run(TCPSelector.java:170)
> at java.lang.Thread.run(Thread.java:722)
> [ERROR] BufferUnderflowException
> !ENTRY org.eclipse.net4j.tcp
>
> Any idea why this happens? I am sure that both, server and client, use the same Java version (7u13), both with 64 bit,
> because I print it to the console at application start.
>
> Thanks for help!
> Stephan
Previous Topic:[Teneo] Not null constraint in JointTable when implementing Interface
Next Topic:[EMF Edit] Accessing attributes of children containment references
Goto Forum:
  


Current Time: Thu Sep 18 01:46:54 GMT 2014

Powered by FUDForum. Page generated in 0.09887 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software