Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Problem with eclipse installation(replaced JRE with JDK; can't get eclipse to run)
Problem with eclipse installation [message #1008207] Mon, 11 February 2013 13:15 Go to next message
Ralph Cook is currently offline Ralph CookFriend
Messages: 8
Registered: July 2009
Junior Member
I had eclipse running just fine, Win7, 64-bit; I had a new project with an Ant script and it said it required a JDK instead of the JRE I was running.

So I downloaded and installed a Win 64-bit JDK. I have since verified that I have a 64-bit eclipse as well.

eclipse would not run when I first tried it -- it could not find a JRE. I edited the system path variable to include the JRE portion of the JDK and rebooted.

Now when I attempt to run eclipse, it gives me its splash screen for what seems like slightly longer than it used to take to start up, then pops up a dialog with:

An error has occurred. See the log file c:\Users\me\etc\.log

eclipse then dies.

The log file has the usual-looking gigantic stack trace, but the first "caused by" line I get is:

Caused by: java.lang.NoClassDefFoundError: javax/crypto/BadPaddingException

There are several other NoClassDefFoundErrors further down.

There were other instructions that I found for having eclipse work with the new JDK, such as copying the entire JRE folder into the eclipse directory or editing eclipse.ini instead of having the jre bin in the system path, but I am hoping someone can tell me what is wrong so that I'm not just wasting time trying different things.

I've uploaded the .log file in case that's interesting to someone.
  • Attachment: .log
    (Size: 424.37KB, Downloaded 102 times)
Re: Problem with eclipse installation [message #1009564 is a reply to message #1008207] Fri, 15 February 2013 10:21 Go to previous messageGo to next message
Stephan Herrmann is currently offline Stephan HerrmannFriend
Messages: 1051
Registered: July 2009
Senior Member
I have no clue what's happening with that class javax/crypto/BadPaddingException.
Given that this class appears to be accessed from equinox, perhaps those folks have an idea:
http://www.eclipse.org/forums/index.php/f/31/
Re: Problem with eclipse installation [message #1009632 is a reply to message #1009564] Fri, 15 February 2013 12:16 Go to previous message
Ralph Cook is currently offline Ralph CookFriend
Messages: 8
Registered: July 2009
Junior Member
After a couple of days where no one said "Oh, I know what that is!" and no chorus of people saying they had seen it as well, I decided it must be installation-specific and that the 'blunt axe' approach would have to do. I downloaded and unpacked a new version of eclipse, and when THAT had the same problem, I went in and uninstalled all my java installations and re-installed the latest version of 6. It's working now. I suspect I had competing versions of java or something, but no good evidence of anything more specific. Thanks to Stephan and anyone who looked at it.
Previous Topic:JUnit Test Runner Fork Mode
Next Topic:How to include xml in Open Type or Open Resources which are placed inside jar
Goto Forum:
  


Current Time: Mon Dec 22 07:20:28 GMT 2014

Powered by FUDForum. Page generated in 0.02801 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software