Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Unable to launch mwe2 workflow
icon4.gif  Unable to launch mwe2 workflow [message #1008202] Mon, 11 February 2013 11:52 Go to next message
Christian Schwarz is currently offline Christian Schwarz
Messages: 31
Registered: July 2009
Member
I have installed XText 2.3.1 via the Updatesite, now i wanted to launch my DSL's mwe2-File. Unforunatly i get this error message: "Please put bundle 'org.eclipse.emf.mwe2.launch' on your project's classpath".
What else must be installed from the updatesite? Why is this bundle not included in the normal XText feature, if it is required?
Re: Unable to launch mwe2 workflow [message #1008205 is a reply to message #1008202] Mon, 11 February 2013 13:06 Go to previous messageGo to next message
Dennis Huebner is currently offline Dennis Huebner
Messages: 213
Registered: July 2009
Senior Member

Hi Christian,
what do you mean with "the normal XText feature"?


Re: Unable to launch mwe2 workflow [message #1008209 is a reply to message #1008205] Mon, 11 February 2013 13:26 Go to previous messageGo to next message
Christian Schwarz is currently offline Christian Schwarz
Messages: 31
Registered: July 2009
Member
Hi Dennis,

Dennis Huebner wrote on Mon, 11 February 2013 08:06

what do you mean with "the normal XText feature"?


i mean the red boxed feature i've selected in the new software dialog. If the bundle "org.eclipse.emf.mwe2.launch" is requird by XText to launch mwe2 it should be included!

index.php/fa/13368/0/
  • Attachment: xtext.png
    (Size: 47.15KB, Downloaded 409 times)

[Updated on: Mon, 11 February 2013 13:29]

Report message to a moderator

Re: Unable to launch mwe2 workflow [message #1008210 is a reply to message #1008205] Mon, 11 February 2013 13:27 Go to previous messageGo to next message
Christian Schwarz is currently offline Christian Schwarz
Messages: 31
Registered: July 2009
Member
duplicate/removed

[Updated on: Mon, 11 February 2013 13:30]

Report message to a moderator

Re: Unable to launch mwe2 workflow [message #1008254 is a reply to message #1008210] Mon, 11 February 2013 18:35 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian Dietrich
Messages: 6395
Registered: July 2009
Senior Member
Hi,

the error message says you have to add a corresponding dependency to the manifest of the project containing the .mwe2 file
Re: Unable to launch mwe2 workflow [message #1008375 is a reply to message #1008209] Tue, 12 February 2013 08:34 Go to previous messageGo to next message
Dennis Huebner is currently offline Dennis Huebner
Messages: 213
Registered: July 2009
Senior Member

Also check your active target platform. Use "Target Platform State" view.
index.php/fa/13375/0/


Re: Unable to launch mwe2 workflow [message #1008387 is a reply to message #1008375] Tue, 12 February 2013 09:37 Go to previous messageGo to next message
Christian Schwarz is currently offline Christian Schwarz
Messages: 31
Registered: July 2009
Member
Thanks for your help!

I added the following features to my target platform:
- org.eclipse.emf.common
- org.eclipse.emf.ecore
- org.eclipse.emf.mwe.core
- org.eclipse.emf.mwe2.language.sdk
- org.eclipse.emf.mwe2.runtime.sdk

The bundle org.eclipse.emf.mwe2.launch and it's dependencys is now part of my target platform and can be resolved. No errors were reported in the "Target Platform State"-View.

I also added the org.eclipse.emf.mwe2.launch to plugin-dependencies of the MANIFEST.MF. (Isn't it referenced indirectly by org.eclipse.xtext either?)
Now i get this, when i try to launch the GenerateMyDsl.mwe2 :

Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/log4j/Logger
	at org.eclipse.emf.mwe2.launch.runtime.Mwe2Launcher.<clinit>(Mwe2Launcher.java:31)
Caused by: java.lang.ClassNotFoundException: org.apache.log4j.Logger
	at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:423)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:356)
	... 1 more


Why do i need the launch - bundle for my plugin, I only want the launch the code-generation from within eclipse, not at runtime? Did I misunderstood something?
Re: Unable to launch mwe2 workflow [message #1008397 is a reply to message #1008387] Tue, 12 February 2013 10:24 Go to previous messageGo to next message
Christian Schwarz is currently offline Christian Schwarz
Messages: 31
Registered: July 2009
Member
Maybe it is related to my problem: The GenerateMyDsl.mwe2 File contains +60 errors. Here are the first 3...

- "Couldn't resolve reference to JvmType 'Generator'."
- "Couldn't resolve reference to JvmIdentifiableElement 'pathRtProject'."
.
- "Couldn't resolve reference to JvmIdentifiableElement 'pathUiProject'."

this is the corresponding part of the code:


  component = Generator {
        pathRtProject = runtimeProject
        pathUiProject = "${runtimeProject}.ui"




Re: Unable to launch mwe2 workflow [message #1027095 is a reply to message #1008397] Tue, 26 March 2013 14:50 Go to previous messageGo to next message
Christian Schwarz is currently offline Christian Schwarz
Messages: 31
Registered: July 2009
Member
The Problem still remains, i have found different ways that didn't work. Dear XText developers can u try the following and tell us how you solve it:

1. Start Eclipse with a new/empty Workspace
2. Create a new XText-Projet using the New-Wizard
3. Create a new empty Target-Platform
4. Add the Features that are needed to the Target-Platform so the XText-Project compiles and run
-> Which Features are needed to be added?

Re: Unable to launch mwe2 workflow [message #1027317 is a reply to message #1027095] Tue, 26 March 2013 21:08 Go to previous messageGo to next message
Lorenzo Bettini is currently offline Lorenzo Bettini
Messages: 1371
Registered: July 2009
Senior Member
On 03/26/2013 03:50 PM, Christian Schwarz wrote:
> The Problem still remains, i have found different ways that didn't work.
> Dear XText developers can u try the following and tell us how you solve it:
>
> 1. Start Eclipse with a new/empty Workspace
> 2. Create a new XText-Projet using the New-Wizard
> 3. Create a new empty Target-Platform
> 4. Add the Features that are needed to the Target-Platform so the
> XText-Project compiles and run
> -> Which Features are needed to be added?
>
>

Concerning the target platform, these two features should be enough

org.eclipse.platform
org.eclipse.xtext.sdk

(provided also the included software is selected).

hope this helps
Lorenzo

--
Lorenzo Bettini, PhD in Computer Science, DI, Univ. Torino
HOME: http://www.lorenzobettini.it
Re: Unable to launch mwe2 workflow [message #1027640 is a reply to message #1027317] Wed, 27 March 2013 08:03 Go to previous messageGo to next message
Christian Schwarz is currently offline Christian Schwarz
Messages: 31
Registered: July 2009
Member
Thanks for your help. I figured out that org.eclipse.platform and org.eclipse.xtext.sdk + its dependencies is not enough. I also added all the mwe stuff and plugins that are not part of any feature like hamcrest and junit. In the end i got 42 features selected in my target platform i guess this are more than 200-Plugins. Here are my results of the sample project:


  • org.xtext.example.mydsl contains no errors and compiles, but when i try to run the GenerateMyDsl.mwe2 i get: java.lang.ClassNotFoundException: org.eclipse.xtend.expression.ExecutionContext
  • org.xtext.example.mydsl.sdk contains no errors and compiles
  • org.xtext.example.mydsl.tests does not resolve the junit packages although it is included as implicit dependency in the target platform
  • org.xtext.example.mydsl.ui does not resolve org.eclipse.ui.ide;bundle-version="3.5.0" because i am running on e4.2, but that okay for now


I think there is no other solution for my current project to chase the complie error i have to leave them. Because we don't need the generated ui plugin of our dsl we can life with that. Whenever we have to change our language we switch our project target platform to ${eclipse-home} were every thing is fine for xtext (but not the rest of our project) and generate the code again. This is not the best solution but i guess it the only workaround on the horiziont.

[Updated on: Wed, 27 March 2013 08:04]

Report message to a moderator

Re: Unable to launch mwe2 workflow [message #1027807 is a reply to message #1027640] Wed, 27 March 2013 12:39 Go to previous message
Lorenzo Bettini is currently offline Lorenzo Bettini
Messages: 1371
Registered: July 2009
Senior Member
Hi

I created a brand new Xtext project (as you did) and created this
juno.target file

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde version="3.8"?>

<target name="juno" sequenceNumber="0">
<locations>
<location includeAllPlatforms="false" includeConfigurePhase="true"
includeMode="planner" includeSource="true" type="InstallableUnit">
<unit id="org.eclipse.platform.feature.group"
version="4.2.1.v20130118-173121-9MF7GHYdG0B5kx4E_SkfZV-1mNjVATf67ZAb7"/>
<unit id="org.eclipse.xtext.sdk.feature.group"
version="2.3.1.v201208210947"/>
<repository location="http://download.eclipse.org/releases/juno"/>
</location>
</locations>
</target>

if I set this as the target platform everything works perfectly, and I
can run the mwe2 workflow without any error...

(hamcrest and junit stuff are dragged in automatically since they are
dependencies)

you were talking about a standard .target definition file, weren't you?

cheers
Lorenzo

On 03/27/2013 09:03 AM, Christian Schwarz wrote:
> Thanks for your help. I figured out that org.eclipse.platform and
> org.eclipse.xtext.sdk + its dependencies is not enough. I also added all
> the mwe stuff and plugins that are not part of any feature like hamcrest
> and junit. In the end i got 42 features selected in my target platform i
> guess this are more than 200-Plugins. Here are my results of the sample
> project:
>
>
> org.xtext.example.mydsl contains no errors and compiles, but when i try
> to run the GenerateMyDsl.mwe2 i get: java.lang.ClassNotFoundException:
> org.eclipse.xtend.expression.ExecutionContext
> org.xtext.example.mydsl.sdk contains no errors and compiles
> org.xtext.example.mydsl.tests does not resolve the junit packages
> although it is included as implicit dependency in the target platform
> org.xtext.example.mydsl.ui does not resolve
> org.eclipse.ui.ide;bundle-version="3.5.0" because i am running on e4.2,
> but that okay for now
>
>
> I think there is no other solution for my current project to chase the
> complie error i have to leave them. Because we don't need the generated
> ui plugin of our dsl we can life with that. Whenever we have to change
> our language we switch our project target platform to ${eclipse-home}
> were every thing is fine for xtext (but not the rest of our project) and
> generate the code again. This is not the best solution but i guess it
> the only workaround on the horiziont.
>


--
Lorenzo Bettini, PhD in Computer Science, DI, Univ. Torino
HOME: http://www.lorenzobettini.it
Previous Topic:Exception: org.eclipse.xtext.junit.serializer.SerializerTester.serialize(SerializerTester.java:234)
Next Topic:Content Assist
Goto Forum:
  


Current Time: Fri Oct 31 05:42:40 GMT 2014

Powered by FUDForum. Page generated in 0.24708 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software