Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Extension with Jubula 1.3.0
Extension with Jubula 1.3.0 [message #1007554] Wed, 06 February 2013 07:48 Go to next message
Alexander Berger is currently offline Alexander Berger
Messages: 11
Registered: January 2013
Junior Member
Hi,

I read this Tutorial(subshell.com/en/subshell/blog/Extending-Jubula-For-Custom-SWT-Controls-In-RCP-Applications100.html) how to extending Jubula.

I copied the "com.subshell.jubula.extension.rcp.aut_1.2.0.201204031506.jar" in the plugin directory of the AUT
and
the "com.subshell.jubula.extension.client_1.2.0.201204031506.jar" in the plugin directory of jubula(jubula_1.3.00071\jubula\plugins.

Next I add the line "com.subshell.jubula.extension.client,1.2.0.201204031506,plugins/com.subshell.jubula.extension.client_1.2.0.201204031506.jar,4,false" to the "<jubula-install-directory>\jubula\configuration\org.eclipse.equinox.simpleconfigurator\bundles.info"

Finally I restart Jubula, but I cant find the new extension...
When I add a new Test Step in the opening dialog I should be able to select the test action "Verify Control Data" for the component type "Control". But there is no "Control" or "Verify Control Data".

Can you tell me what I did wrong?

Thanks.

[Updated on: Wed, 06 February 2013 07:49]

Report message to a moderator

Re: Extension with Jubula 1.3.0 [message #1007907 is a reply to message #1007554] Fri, 08 February 2013 01:47 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1055
Registered: July 2009
Senior Member
Hi,

As I don't write extensions, the help I can offer is to add some links to other places where the topic has been discussed:

http://www.eclipse.org/forums/index.php/t/261926/
https://bugs.eclipse.org/bugs/show_bug.cgi?id=372349
http://www.eclipse.org/forums/index.php/t/323430/
http://www.eclipse.org/forums/index.php/t/318379/

Best regards,
Alex
Re: Extension with Jubula 1.3.0 [message #1008168 is a reply to message #1007554] Mon, 11 February 2013 04:06 Go to previous messageGo to next message
Alexander Berger is currently offline Alexander Berger
Messages: 11
Registered: January 2013
Junior Member
I found my mistake:
The selection for the "Toolkit for Test Specification" was wrong.
I chose "concrete", but the correct Toolkit for this tutorial/plug-in is "rcp".

Re: Extension with Jubula 1.3.0 [message #1008367 is a reply to message #1008168] Tue, 12 February 2013 03:10 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1055
Registered: July 2009
Senior Member
Thanks for posting the solution!
Re: Extension with Jubula 1.3.0 [message #1234954 is a reply to message #1008367] Thu, 23 January 2014 03:04 Go to previous message
ye ye is currently offline ye ye
Messages: 3
Registered: January 2014
Junior Member
Alexandra Schladebeck wrote on Tue, 12 February 2013 03:10
Thanks for posting the solution!

I tried you said step-to-step,Jubula can work and hanvn't any errors,but I cann't map the ImageHyperlink Component.
I hope Someone can help me. Sad
Previous Topic:Error 5009 : Start AUT failed
Next Topic:Extend Jubula for ImageHyperlink
Goto Forum:
  


Current Time: Thu Apr 17 23:37:06 EDT 2014

Powered by FUDForum. Page generated in 0.02612 seconds