Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » p2 repository problems
p2 repository problems [message #1007070] Mon, 04 February 2013 10:45 Go to next message
Mark Walters is currently offline Mark Walters
Messages: 25
Registered: June 2011
Junior Member
Hi,
I'm using Helios 3.6.2 and I have a plugin built with maven (no errors) that 2 weeks ago installed fine, now I see this when I try to install:

No repository found containing: osgi.bundle,org.eclipse.net4j.jms.api,3.0.0.v20110215-1551

I'm no expert on the build process but I cannot find a direct reference to net4j in any of our pom files.

I also notice that other plugins from the Helios update site have similar problems, such as EMF 2.6.1.

My plugin also fails to install into 3.7 Indigo with the same error.

I have deleted my maven repository, rebuilt again, and tried to install into a fresh 3.6.2 and always get the same issue.

Any help would be very welcome.

Thanks,
Mark.
Re: p2 repository problems [message #1007753 is a reply to message #1007070] Thu, 07 February 2013 12:17 Go to previous message
Mark Walters is currently offline Mark Walters
Messages: 25
Registered: June 2011
Junior Member
I found my problem was the version of Java in my path and JAVA_HOME setting. I downloaded the latest java 6 to work with Eclipse 3.6.2 and now all is well.

Ta,
Mark.
Previous Topic:eclipse heap out of memory while pasting
Next Topic:Java Build Path Libraries disappear
Goto Forum:
  


Current Time: Mon Sep 22 12:22:03 GMT 2014

Powered by FUDForum. Page generated in 0.01495 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software