Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » scout » Problem creating webservice Provider
Problem creating webservice Provider [message #1006965] Sun, 03 February 2013 09:55 Go to next message
Bertin Kiekebosch is currently offline Bertin Kiekebosch
Messages: 306
Registered: August 2011
Senior Member
Hi,

I am using Scout Juno SR1. Its the first time I am generating a WebService provider.

When I create a webservice provider (using the tutorial on that topic) I get an error as soon as I finish the wizard. I think all the files are generated but my webService (See below )has no methods generated. I get an Error on my source but I don't know how to fix it.

package ScoutExamples.server.services.ws.provider;

import javax.jws.WebService;

import org.eclipse.scout.jaxws.annotation.ScoutWebService;

@ScoutWebService
@WebService
public class OefeningenWebService {
}


the error:
The webservice implementation 'OefeningenWebService' must implement the webservice port type interface	OefeningenWebService.java	/ScoutExamples.server/src/ScoutExamples/server/services/ws/provider	Unknown	implementation


So did I make a mistake or how can I fix this.

Regards Bertin
Re: Problem creating webservice Provider [message #1006966 is a reply to message #1006965] Sun, 03 February 2013 10:30 Go to previous message
Bertin Kiekebosch is currently offline Bertin Kiekebosch
Messages: 306
Registered: August 2011
Senior Member
Already Fixed, Eclipse IDE was not properly configured
Previous Topic:Problems refreshing a form-on-a-page
Next Topic:Building Eclipse Scout
Goto Forum:
  


Current Time: Thu Oct 23 11:54:05 GMT 2014

Powered by FUDForum. Page generated in 0.03045 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software