Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » [CDO] Installation of CDO 4.2 failed
[CDO] Installation of CDO 4.2 failed [message #1006630] Fri, 01 February 2013 09:25 Go to next message
Ricky de Klerck is currently offline Ricky de Klerck
Messages: 295
Registered: January 2011
Senior Member
Hi,

I'm trying to do a new installation of Eclipse with CDO 4.2M4, but it keeps failing! I tried it with Indigo and Juno, but both gives me the same error.

An error occurred while collecting items to be installed
session context was:(profile=epp.package.rcp, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Problems downloading artifact: osgi.bundle,org.eclipse.emf.cdo.server.objectivity.stub,4.2.0.v20120910-0839.
File has invalid content:C:\Users\RDEKL_~1\AppData\Local\Temp\signatureFile2874864405182047497.jar
Invalid content:oojava_epl.jar
The file "oojava_epl.jar" in the jar "C:\Users\RDEKL_~1\AppData\Local\Temp\signatureFile2874864405182047497.jar" has been tampered!


What am I doing wrong here?

This is what I installed so far..

Apache Commons Logging 1.1.1
Apache Log4j 1.2.16
Dom4j 1.6.1
Eclipse for RCP and RAP Developers
EMF SDK 2.8.1
EMF Compare Core 2.1.0
EMF Compare IDE UI 2.1.0
Hibernate 4.1.1
Javax Persistence 2.0.1

[Updated on: Fri, 01 February 2013 09:26]

Report message to a moderator

Re: Installation of CDO 4.2 failed [message #1006657 is a reply to message #1006630] Fri, 01 February 2013 10:40 Go to previous messageGo to next message
Eike Stepper is currently offline Eike Stepper
Messages: 5538
Registered: July 2009
Senior Member
Am 01.02.2013 10:25, schrieb Ricky de Klerck:
> Hi,
>
> I'm trying to do a new installation of Eclipse with CDO 4.2M4, but it keeps failing! I tried it with Indigo and Juno,
> but both gives me the same error.
>
> An error occurred while collecting items to be installed
> session context was:(profile=epp.package.rcp, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=,
> action=).
> Problems downloading artifact: osgi.bundle,org.eclipse.emf.cdo.server.objectivity.stub,4.2.0.v20120910-0839.
> File has invalid content:C:\Users\RDEKL_~1\AppData\Local\Temp\signatureFile2874864405182047497.jar
> Invalid content:oojava_epl.jar
> The file "oojava_epl.jar" in the jar "C:\Users\RDEKL_~1\AppData\Local\Temp\signatureFile2874864405182047497.jar" has
> been tampered!
Infrequently I have similar problems when using a wrong JRE for the installation process. Can't remember exactly what
versions are problematic. What version are you using?

Your problem may be similar to https://bugs.eclipse.org/bugs/show_bug.cgi?id=361628 , so not a CDO problem.

Cheers
/Eike

----
http://www.esc-net.de
http://thegordian.blogspot.com
http://twitter.com/eikestepper


>
> What am I doing wrong here?
>
> This is what I installed so far..
>
> Apache Commons Logging 1.1.1
> Apache Log4j 1.2.16
> Dom4j 1.6.1
> Eclipse for RCP and RAP Developers
> EMF SDK 2.8.1
> EMF Compare Core 2.1.0
> EMF Compare IDE UI 2.1.0
> Hibernate 4.1.1
> Javax Persistence 2.0.1
>
>
Re: Installation of CDO 4.2 failed [message #1006684 is a reply to message #1006657] Fri, 01 February 2013 12:29 Go to previous message
Ricky de Klerck is currently offline Ricky de Klerck
Messages: 295
Registered: January 2011
Senior Member
I was indeed using Java 7! With Java 6 everything works fine, thanks for pointing it out!
Previous Topic:Utility to copy CDOObject data only
Next Topic:[CDO] CDOAdapter vs CDOViewInvalidationEvent
Goto Forum:
  


Current Time: Thu Oct 23 13:17:35 GMT 2014

Powered by FUDForum. Page generated in 0.03159 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software