Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » How do I stop Builder Settings adding a -k to the Makefile command
How do I stop Builder Settings adding a -k to the Makefile command [message #1006579] Thu, 31 January 2013 21:41 Go to next message
Gareth Morgan is currently offline Gareth Morgan
Messages: 1
Registered: January 2013
Junior Member
I have a makefile project where the target is specified with the BUILD variable. e.g.:
make BUILD=release

However whenever I add this to the Build Command box in the Builder Settings properties it automatically appends a -k, so I end up with (for the "all" target)
make BUILD=release -k all

This fails with a "No rule to make target `all'" error

How do I stop it (or make specify the target using the BUILD option instead of -k).

Any ideas?

Thanks
Re: How do I stop Builder Settings adding a -k to the Makefile command [message #1006736 is a reply to message #1006579] Fri, 01 February 2013 16:17 Go to previous message
Axel Mueller is currently offline Axel Mueller
Messages: 1959
Registered: July 2009
Senior Member
Open Project Properties_>C/C++ Build and select tab "Behavior"
Enable "Stop on first build error" => this will remove -k

At the bottom you can define your make target.


Before you ask
- search this forum
- see the FAQ http://wiki.eclipse.org/CDT/User/FAQ
- google
Previous Topic:Eclipse always returns 0 references found
Next Topic:How can the declaration of an unused variable affect behavior?
Goto Forum:
  


Current Time: Wed Oct 01 14:21:53 GMT 2014

Powered by FUDForum. Page generated in 0.01969 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software