Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Installing Eclipse Indigo SR1 on my OS X Mountain Lion(Missing Java 6 )
Installing Eclipse Indigo SR1 on my OS X Mountain Lion [message #1006070] Tue, 29 January 2013 17:27 Go to next message
Frederick Pina is currently offline Frederick PinaFriend
Messages: 2
Registered: January 2013
Junior Member
Hello fellow Coders,

I'm new to the Eclipse Community and I'm new to programming. I'm looking to teach myself Java programming, and wanted to start off with the latest Java (Version 7). However, I delete the previous version (Version 6) and downloaded the new Eclipse Indigo SR1, that's stated to support Java 7. Still, after the packages are downloaded and I try to install it the softwares asks me to re-insteall Java 6.

Is there anyway to install Eclipse Indigo SR1 while only having Java 7 on Mountain Lion ? I'm confused. If Eclipse Indigo SR1 fully supports Java 7, why does it requires Java 6. Isn't it less secure, as all those security updates were recently issued by Oracle.

What's going on here ? Can anyone help me solve this issue ?

Thanks a million.

- Frederick
Re: Installing Eclipse Indigo SR1 on my OS X Mountain Lion [message #1006121 is a reply to message #1006070] Wed, 30 January 2013 02:51 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 2341
Registered: July 2009
Senior Member
I'm not that familiar with Mountain Lion's Java and how it might be prompting you to install a runtime, but as with most software, what Eclipse states it requires is considered the minimum version. If you want to stay on Indigo rather than running what is current, Juno SR1, please at least try it with Indigo SR2.

---
Nitin Dahyabhai
Eclipse WTP, IBM
Re: Installing Eclipse Indigo SR1 on my OS X Mountain Lion [message #1007389 is a reply to message #1006121] Tue, 05 February 2013 17:21 Go to previous message
Frederick Pina is currently offline Frederick PinaFriend
Messages: 2
Registered: January 2013
Junior Member

Hi Nitin,

Again. I'm basically a newbie. Please bare with me if I appear wet behind the ears, but logic dictating my own presumption, I downloaded Eclipse 4.3.0 Stable Build 4.3M2 into my OS X Mountain Lion. I deleted Java 6, because I wanted to learn with the latest version of Java (Version 7). I don't understand why the IDE keeps asking for Java 6.

Isn't this going backwards, isn't the latest software, generally speaking the best method to use for newbies, such as myself ? Is there anyway possible to install this particular Eclipse (or any other) without re-installing Java 6, and sticking solely with Java 7.

Thanks !
Previous Topic:JUNO Eclipse.exe
Next Topic:Connect to Microsoft Access via Data Explorer in IDE
Goto Forum:
  


Current Time: Fri Dec 19 18:22:04 GMT 2014

Powered by FUDForum. Page generated in 0.07029 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software