Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster » Refresh Buckminster Metadata
Refresh Buckminster Metadata [message #1005971] Tue, 29 January 2013 07:48 Go to next message
Christoph Keimel is currently offline Christoph Keimel
Messages: 297
Registered: December 2010
Location: Germany
Senior Member
Hello

during the execution of the site.p2 action inside the IDE I always get the following error:

org.eclipse.core.runtime.CoreException: Basedir D:\GosaEntwicklung\WorkspaceGit\de.emsw.gosa.feature.etisch.app does not exist
Basedir D:\GosaEntwicklung\WorkspaceGit\de.emsw.gosa.feature.etisch.app does not exist


The problem with the feature de.emsw.gosa.feature.etisch.app is that it has been moved to a new location on the local drive. I have tried everything I can think of to get buckminster to refresh its metadata:
- Delete and reimport the project
- Execute Preferences -> Buckminster -> Refresh Meta-data
- Restart Eclipse
- Project -> Clean
In different combinations ... but with no effect Sad.

How can I get buckminster to refresh its meta-data?

Any ideas are very welcome Smile

Greetings
Christoph
Re: Refresh Buckminster Metadata [message #1005989 is a reply to message #1005971] Tue, 29 January 2013 08:38 Go to previous messageGo to next message
Lorenzo Bettini is currently offline Lorenzo Bettini
Messages: 1260
Registered: July 2009
Senior Member
On 01/29/2013 01:48 PM, Christoph Keimel wrote:
> Hello
>
> during the execution of the site.p2 action inside the IDE I always get
> the following error:
>
> org.eclipse.core.runtime.CoreException: Basedir
> D:\GosaEntwicklung\WorkspaceGit\de.emsw.gosa.feature.etisch.app does not
> exist
> Basedir D:\GosaEntwicklung\WorkspaceGit\de.emsw.gosa.feature.etisch.app
> does not exist
>
> The problem with the feature de.emsw.gosa.feature.etisch.app is that it
> has been moved to a new location on the local drive. I have tried
> everything I can think of to get buckminster to refresh its metadata:
> - Delete and reimport the project
> - Execute Preferences -> Buckminster -> Refresh Meta-data
> - Restart Eclipse
> - Project -> Clean
> In different combinations ... but with no effect :(.
>
> How can I get buckminster to refresh its meta-data?
>
> Any ideas are very welcome :)

The following steps usually work for me (note the place of restart step):

- Delete the project from the workspace (but not physically ;)
- Restart Eclipse
- Reimport the project

hope this helps
Lorenzo


--
Lorenzo Bettini, PhD in Computer Science, DI, Univ. Torino
HOME: http://www.lorenzobettini.it
Re: Refresh Buckminster Metadata [message #1007954 is a reply to message #1005989] Fri, 08 February 2013 08:22 Go to previous message
Christoph Keimel is currently offline Christoph Keimel
Messages: 297
Registered: December 2010
Location: Germany
Senior Member
Hi Lorenzo,

thanks for your input. The method you describe works most of the time. If that fails, it seems to be possible to deleted \.metadata\.plugins\org.eclipse.buckminster.core from the workspace folder which did the trick.

Smile,
Christoph
Previous Topic:Eclipse-SourceReferences incomplete when scm type is git
Next Topic:A question about Buckminster Documentation...
Goto Forum:
  


Current Time: Sun Apr 20 15:55:56 EDT 2014

Powered by FUDForum. Page generated in 0.01563 seconds