Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » How to get most recent php version - Eclipse Indigo/PDT windows vista
How to get most recent php version - Eclipse Indigo/PDT windows vista [message #1005326] Thu, 24 January 2013 21:47
Colin Goldberg is currently offline Colin GoldbergFriend
Messages: 2
Registered: October 2012
Junior Member
Hi,

When I installed Eclipse PDT All-in-one from Zend last year it did not provide a new version of php - it used one already there from an older Eclipse install. Two php versions were available - under 'php5' (actually php5.2) and 'php53'. I have been using 'php5' without major issues for some time.

Now, because I suspect that libcurl and related files are missing needed fixes, I would like to ensure that I am running the most recent php AND libraries such as curl (libcurl...).

How do I go about upgrading these? I tried replacing copies of individual library files such as libcurl.dll but this did not work. Accessing Help -> Install New Software -> http://download.eclipse.org/tools/pdt/updates/release has nothing new that I don't already have.

Plugin: org.zend.php.debug.debugger.win32.x86_5.3.18.v20100603

From phpinfo():

'PHP5' Version: 5.2.13
cURL Information => libcurl/7.20.0 OpenSSL/0.9.8n zlib/1.2.3

'PHP53' Version: 5.3.2
cURL Information => 7.20.0
Host => i386-pc-win32
SSL Version => OpenSSL/0.9.8n
ZLib Version => 1.2.3


Can anyone help?

Colin G

Previous Topic:content assist triggers on ";"
Next Topic:moving from netbeans to eclipse
Goto Forum:
  


Current Time: Mon Dec 22 01:27:09 GMT 2014

Powered by FUDForum. Page generated in 0.02944 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software