Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » scout » Rayo & rap support with Scout 3.9.0 Milestone 4
Rayo & rap support with Scout 3.9.0 Milestone 4 [message #1004964] Thu, 24 January 2013 03:10 Go to next message
Urs Beeli is currently offline Urs Beeli
Messages: 324
Registered: October 2012
Location: Bern, Switzerland
Senior Member
I've added a target definition for Scout 3.9.0 Milestone 4 to my project. This has solved a number of issues we've had and is the platform we are aiming for when deploying.

However, I've been unable to find corresponding versions for the Swing Rayo L&F as well as the RAP runtimes. Anything I found for those two things still has dependencies for Scout 3.8.1.

Did I look in the wrong places or is this something that is just not yet ready for 3.9.0?
Re: Rayo & rap support with Scout 3.9.0 Milestone 4 [message #1005031 is a reply to message #1004964] Thu, 24 January 2013 05:57 Go to previous messageGo to next message
Stephan Leicht Vogt is currently offline Stephan Leicht Vogt
Messages: 102
Registered: February 2010
Location: Baden Switzerland
Senior Member

Hi Urs

These dependencies are minimum dependencies. The bundles should work with Scout 3.9 M4. If they do not work, please open a bug.

Greetings
Stephan
Re: Rayo & rap support with Scout 3.9.0 Milestone 4 [message #1005890 is a reply to message #1005031] Tue, 29 January 2013 03:50 Go to previous message
Urs Beeli is currently offline Urs Beeli
Messages: 324
Registered: October 2012
Location: Bern, Switzerland
Senior Member
Hi Stephan

Thanks for your input. It took some heavy trial and error but I've got both RAP and Rayo working now. In case anyone else wants to do this I am posting my target definition file so they don't have to repeat all the work Smile
<?xml version="1.0" encoding="UTF-8"?><?pde version="3.8"?><target name="minicrm" sequenceNumber="29">
<locations>
<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
<unit id="org.eclipse.scout.rt.source.feature.group" version="3.9.0.20121218-1038"/>
<unit id="org.eclipse.scout.rt.testing.source.feature.group" version="3.9.0.20121219-1012"/>
<repository location="http://download.eclipse.org/releases/kepler/"/>
</location>
<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
<unit id="org.eclipse.platform.ide" version="3.8.1.M20120914-1540"/>
<unit id="org.eclipse.rcp.feature.group" version="3.8.1.v20120814-105048-92BmGJlFw3Ez0WZ9TxCqgcSVAE"/>
<unit id="org.eclipse.equinox.sdk.feature.group" version="3.8.0.v20120522-1841-7M7fA78g5_y-eQjtHxcd47Zm7mDQ"/>
<repository location="http://download.eclipse.org/eclipse/updates/3.8"/>
</location>
<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
<unit id="com.bsiag.scout.rt.ui.swing.laf.rayo.feature.feature.group" version="3.8.1.201209051219"/>
<repository location="http://tools.bsiag.com/marketplace/rayo"/>
</location>
<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
<unit id="org.eclipse.rap.runtime.requirements.feature.group" version="1.5.1.20120917-1130"/>
<unit id="org.eclipse.rap.runtime.feature.group" version="1.5.1.20120917-1130"/>
<unit id="org.eclipse.scout.rt.rap.feature.feature.group" version="3.8.1.201209171521"/>
<repository location="http://download.eclipse.org/releases/juno/"/>
</location>
<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
<unit id="org.w3c.dom.svg" version="1.1.0.v201011041433"/>
<unit id="org.w3c.css.sac" version="1.3.1.v200903091627"/>
<unit id="org.w3c.dom.events" version="3.0.0.draft20060413_v201105210656"/>
<unit id="org.w3c.dom.smil" version="1.0.1.v200903091627"/>
<unit id="javax.servlet" version="2.5.0.v201103041518"/>
<unit id="org.apache.batik.css" version="1.6.0.v201011041432"/>
<unit id="org.apache.batik.util.gui" version="1.6.0.v201011041432"/>
<unit id="org.apache.batik.util" version="1.6.0.v201011041432"/>
<repository location="http://download.eclipse.org/tools/orbit/downloads/drops/R20120526062928/repository"/>
</location>
</locations>
</target>


Note: I had to downgrade the batik packages to 1.6.0 as the latest version (1.7.0) was not accepted.

[Updated on: Tue, 29 January 2013 03:55]

Report message to a moderator

Previous Topic:extension point for custom columns
Next Topic:File Chooser and Upload for RAP UI
Goto Forum:
  


Current Time: Wed Aug 27 23:25:47 EDT 2014

Powered by FUDForum. Page generated in 0.09990 seconds