Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster dev » [buckminster-dev] RE: buckminster-dev Digest, Vol 32, Issue 20
[buckminster-dev] RE: buckminster-dev Digest, Vol 32, Issue 20 [message #13588] Mon, 31 March 2008 08:13 Go to next message
Eclipse UserFriend
Originally posted by: ikalboussi.ilog.fr

Good morning,

Here's my quickstart.cquery:

?xml version="1.0" encoding="UTF-8"?>
<cq:componentQuery
xmlns:cq="http://www.eclipse.org/buckminster/CQuery-1.0"
resourceMap="path/to quickstart.rmap ">
<cq:rootRequest
name="org.eclipse.buckminster.maven.sample.quickstart" />
</cq:componentQuery>


And this is my quickstart.rmap:

<?xml version="1.0" encoding="UTF-8"?>
<rmap
xmlns="http://www.eclipse.org/buckminster/RMap-1.0"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:bc="http://www.eclipse.org/buckminster/Common-1.0"
xmlns:mp="http://www.eclipse.org/buckminster/MavenProvider-1.0">

<searchPath name="maven">
<provider xsi:type="mp:MavenProvider" readerType="maven2"
componentType="maven" mutable="false" source="false">
<uri format="http://repo1.maven.org/maven2"/>
</provider>
</searchPath>

<searchPath name="samples">
<provider readerType="svn" componentTypes="maven" mutable="true"
source="true">
<uri
format=" svn://dev.eclipse.org/svnroot/technology/org.eclipse.buckmin ster
/trunk/testbench/{0}">
<bc:propertyRef key="buckminster.component"/>
</uri>
</provider>
</searchPath>

<locator searchPathRef="samples" pattern=".*\.sample\..*" />
<locator searchPathRef="maven" pattern=".*" />

</rmap>

And this is the message error:


Unable to resolve: org.eclipse.buckminster.maven.sample.quickstart

Thanks


-----Original Message-----
From: buckminster-dev-bounces@eclipse.org
[mailto:buckminster-dev-bounces@eclipse.org] On Behalf Of
buckminster-dev-request@eclipse.org
Sent: dimanche 30 mars 2008 18:00
To: buckminster-dev@eclipse.org
Subject: buckminster-dev Digest, Vol 32, Issue 20

Send buckminster-dev mailing list submissions to
buckminster-dev@eclipse.org

To subscribe or unsubscribe via the World Wide Web, visit
https://dev.eclipse.org/mailman/listinfo/buckminster-dev
or, via email, send a message with subject or body 'help' to
buckminster-dev-request@eclipse.org

You can reach the person managing the list at
buckminster-dev-owner@eclipse.org

When replying, please edit your Subject line so it is more specific
than "Re: Contents of buckminster-dev digest..."


Today's Topics:

1. RE: (no subject) (Matt Hollingsworth)


------------------------------------------------------------ ----------

Message: 1
Date: Sat, 29 Mar 2008 20:50:16 -0500
From: Matt Hollingsworth <hollings@cern.ch>
Subject: RE: [buckminster-dev] (no subject)
To: 'Buckminster developer discussions' <buckminster-dev@eclipse.org>
Message-ID: <027001c89208$6802b260$960ea8c0@home.msh>
Keywords: CERN SpamKiller Note: 0 Charset: west-latin
Content-Type: text/plain; charset="us-ascii"

Imen,



Are you able to resolve the RMAP that is referred to in the CQUERY?
I.e.,
is your internet access "normal," or is it behind some corporate
firewall?
I wouldn't imagine that the resolving step would fail unless the CQUERY
couldn't find the RMAP for some reason.



-Matt



_____

From: buckminster-dev-bounces@eclipse.org
[mailto:buckminster-dev-bounces@eclipse.org] On Behalf Of Imen Kalboussi
Sent: Friday, March 28, 2008 4:49 AM
To: buckminster-dev@eclipse.org
Subject: [buckminster-dev] (no subject)



Hi Matt,



Thanks for your help.



I've followed the instructions that you gave to me and this error
message
was generated:



Unable to resolve: org.eclipse.buckminster



What shall I do?





Thanks,

-------------- next part --------------
An HTML attachment was scrubbed...
URL:
https://dev.eclipse.org/mailman/private/buckminster-dev/atta chments/2008
0329/5dd16104/attachment.html

------------------------------

_______________________________________________
buckminster-dev mailing list
buckminster-dev@eclipse.org
https://dev.eclipse.org/mailman/listinfo/buckminster-dev


End of buckminster-dev Digest, Vol 32, Issue 20
***********************************************
Re: [buckminster-dev] RE: buckminster-dev Digest, Vol 32, Issue 20 [message #13609 is a reply to message #13588] Mon, 31 March 2008 08:54 Go to previous message
Filip Hrbek is currently offline Filip HrbekFriend
Messages: 233
Registered: July 2009
Senior Member
Hi Imen,

the only problem you have right now is that the Buckminster project has
moved from "technology" to "tools" in the beginning of February (see
http://www.eclipse.org/buckminster/, section "News").

It means that the uri provided in your rmap is obsolete and you have to
update it:

....
<uri
format=" svn://dev.eclipse.org/svnroot/tools/org.eclipse.buckminster/ trunk/testbench/{0}">
....

It will fix your problem.

kind regards
Filip Hrbek



Imen Kalboussi napsal(a):
> Good morning,
>
> Here's my quickstart.cquery:
>
> ?xml version="1.0" encoding="UTF-8"?>
> <cq:componentQuery
> xmlns:cq="http://www.eclipse.org/buckminster/CQuery-1.0"
> resourceMap="path/to quickstart.rmap ">
> <cq:rootRequest
> name="org.eclipse.buckminster.maven.sample.quickstart" />
> </cq:componentQuery>
>
>
> And this is my quickstart.rmap:
>
> <?xml version="1.0" encoding="UTF-8"?>
> <rmap
> xmlns="http://www.eclipse.org/buckminster/RMap-1.0"
> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> xmlns:bc="http://www.eclipse.org/buckminster/Common-1.0"
> xmlns:mp="http://www.eclipse.org/buckminster/MavenProvider-1.0">
>
> <searchPath name="maven">
> <provider xsi:type="mp:MavenProvider" readerType="maven2"
> componentType="maven" mutable="false" source="false">
> <uri format="http://repo1.maven.org/maven2"/>
> </provider>
> </searchPath>
>
> <searchPath name="samples">
> <provider readerType="svn" componentTypes="maven" mutable="true"
> source="true">
> <uri
> format=" svn://dev.eclipse.org/svnroot/technology/org.eclipse.buckmin ster
> /trunk/testbench/{0}">
> <bc:propertyRef key="buckminster.component"/>
> </uri>
> </provider>
> </searchPath>
>
> <locator searchPathRef="samples" pattern=".*\.sample\..*" />
> <locator searchPathRef="maven" pattern=".*" />
>
> </rmap>
>
> And this is the message error:
>
>
> Unable to resolve: org.eclipse.buckminster.maven.sample.quickstart
>
> Thanks
>
>
> -----Original Message-----
> From: buckminster-dev-bounces@eclipse.org
> [mailto:buckminster-dev-bounces@eclipse.org] On Behalf Of
> buckminster-dev-request@eclipse.org
> Sent: dimanche 30 mars 2008 18:00
> To: buckminster-dev@eclipse.org
> Subject: buckminster-dev Digest, Vol 32, Issue 20
>
> Send buckminster-dev mailing list submissions to
> buckminster-dev@eclipse.org
>
> To subscribe or unsubscribe via the World Wide Web, visit
> https://dev.eclipse.org/mailman/listinfo/buckminster-dev
> or, via email, send a message with subject or body 'help' to
> buckminster-dev-request@eclipse.org
>
> You can reach the person managing the list at
> buckminster-dev-owner@eclipse.org
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of buckminster-dev digest..."
>
>
> Today's Topics:
>
> 1. RE: (no subject) (Matt Hollingsworth)
>
>
> ------------------------------------------------------------ ----------
>
> Message: 1
> Date: Sat, 29 Mar 2008 20:50:16 -0500
> From: Matt Hollingsworth <hollings@cern.ch>
> Subject: RE: [buckminster-dev] (no subject)
> To: 'Buckminster developer discussions' <buckminster-dev@eclipse.org>
> Message-ID: <027001c89208$6802b260$960ea8c0@home.msh>
> Keywords: CERN SpamKiller Note: 0 Charset: west-latin
> Content-Type: text/plain; charset="us-ascii"
>
> Imen,
>
>
>
> Are you able to resolve the RMAP that is referred to in the CQUERY?
> I.e.,
> is your internet access "normal," or is it behind some corporate
> firewall?
> I wouldn't imagine that the resolving step would fail unless the CQUERY
> couldn't find the RMAP for some reason.
>
>
>
> -Matt
>
>
>
> _____
>
> From: buckminster-dev-bounces@eclipse.org
> [mailto:buckminster-dev-bounces@eclipse.org] On Behalf Of Imen Kalboussi
> Sent: Friday, March 28, 2008 4:49 AM
> To: buckminster-dev@eclipse.org
> Subject: [buckminster-dev] (no subject)
>
>
>
> Hi Matt,
>
>
>
> Thanks for your help.
>
>
>
> I've followed the instructions that you gave to me and this error
> message
> was generated:
>
>
>
> Unable to resolve: org.eclipse.buckminster
>
>
>
> What shall I do?
>
>
>
>
>
> Thanks,
>
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL:
> https://dev.eclipse.org/mailman/private/buckminster-dev/atta chments/2008
> 0329/5dd16104/attachment.html
>
> ------------------------------
>
> _______________________________________________
> buckminster-dev mailing list
> buckminster-dev@eclipse.org
> https://dev.eclipse.org/mailman/listinfo/buckminster-dev
>
>
> End of buckminster-dev Digest, Vol 32, Issue 20
> ***********************************************
Previous Topic:RE: [buckminster-dev] (no subject)
Next Topic:[buckminster-dev] How buckminster compile a plugin which depends on other plugins?
Goto Forum:
  


Current Time: Mon Nov 24 16:45:52 GMT 2014

Powered by FUDForum. Page generated in 0.02399 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software