Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » IsSafeRunnable Error(XWT/SWT windows have errors.)
icon5.gif  IsSafeRunnable Error [message #1002794] Sat, 19 January 2013 12:53 Go to next message
Brian Austin is currently offline Brian AustinFriend
Messages: 6
Registered: January 2013
Junior Member
I'm not exactly sure that I'm posting this in the right place, but I have been having an error with an XWT application that uses SWT packages. The error is:
Exception in thread "main" java.lang.NoClassDefFoundError: org/eclipse/core/runtime/ISafeRunnable
	at org.eclipse.jface.databinding.swt.SWTObservables.getRealm(SWTObservables.java:58)
	at org.eclipse.e4.xwt.XWTLoader.<init>(XWTLoader.java:176)
	at org.eclipse.e4.xwt.XWTLoaderManager.<clinit>(XWTLoaderManager.java:19)
	at org.eclipse.e4.xwt.XWT.load(XWT.java:379)
	at MainForm.main(MainForm.java:18)
Caused by: java.lang.ClassNotFoundException: org.eclipse.core.runtime.ISafeRunnable
	at java.net.URLClassLoader$1.run(Unknown Source)
	at java.net.URLClassLoader$1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)

Why is this happening?
Re: IsSafeRunnable Error [message #1004780 is a reply to message #1002794] Wed, 23 January 2013 21:29 Go to previous messageGo to next message
Grant Gayed is currently offline Grant GayedFriend
Messages: 2151
Registered: July 2009
Senior Member
It looks like it's failing to find at least one of
org.eclipse.jface.databinding's dependencies at runtime. To see a list
of the dependent jars that need to be found do the following in Eclipse:

- File > Import...
- select Plug-in Development > Plug-ins and Fragments > Next
- next
- select org.eclipse.jface.databinding, press "Add->"
- press "Required Plug-ins->", and the list on the right will show
what's needed

If you have further questions then the eclipse.platform forum would be
more appropriate.

Grant


On 1/21/2013 8:23 AM, Brian Austin wrote:
> I'm not exactly sure that I'm posting this in the right place, but I
> have been having an error with an XWT application that uses SWT
> packages. The error is:
>
> Exception in thread "main" java.lang.NoClassDefFoundError:
> org/eclipse/core/runtime/ISafeRunnable
> at
> org.eclipse.jface.databinding.swt.SWTObservables.getRealm(SWTObservables.java:58)
>
> at org.eclipse.e4.xwt.XWTLoader.<init>(XWTLoader.java:176)
> at
> org.eclipse.e4.xwt.XWTLoaderManager.<clinit>(XWTLoaderManager.java:19)
> at org.eclipse.e4.xwt.XWT.load(XWT.java:379)
> at MainForm.main(MainForm.java:18)
> Caused by: java.lang.ClassNotFoundException:
> org.eclipse.core.runtime.ISafeRunnable
> at java.net.URLClassLoader$1.run(Unknown Source)
> at java.net.URLClassLoader$1.run(Unknown Source)
> at java.security.AccessController.doPrivileged(Native Method)
> at java.net.URLClassLoader.findClass(Unknown Source)
> at java.lang.ClassLoader.loadClass(Unknown Source)
> at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
> at java.lang.ClassLoader.loadClass(Unknown Source)
>
> Why is this happening?
Re: IsSafeRunnable Error [message #1005593 is a reply to message #1004780] Sat, 26 January 2013 21:54 Go to previous messageGo to next message
Brian Austin is currently offline Brian AustinFriend
Messages: 6
Registered: January 2013
Junior Member
I have had errors when trying to create JFace projects as well. Where should I get the jar that has org.eclipse.jface?
Re: IsSafeRunnable Error [message #1006284 is a reply to message #1005593] Wed, 30 January 2013 16:59 Go to previous message
Grant Gayed is currently offline Grant GayedFriend
Messages: 2151
Registered: July 2009
Senior Member
Look in your eclipse's "plugins" directory.

Grant


On 1/26/2013 4:54 PM, Brian Austin wrote:
> I have had errors when trying to create JFace projects as well. Where
> should I get the jar that has org.eclipse.jface?
Previous Topic:SWT, XULrunner, OS X and hover events not working
Next Topic:snippet of context menu in a Mozilla Browser not work with swt 4.2 and xulrunner 10
Goto Forum:
  


Current Time: Wed Nov 26 06:54:40 GMT 2014

Powered by FUDForum. Page generated in 0.18681 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software