Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » Problem with Gemini DBAccess / JPA and Virgo 3.6(My plan constantly starts/stops when trying to deploy a persistence unit bundle)
Problem with Gemini DBAccess / JPA and Virgo 3.6 [message #1001941] Thu, 17 January 2013 10:34 Go to next message
Simon Watson is currently offline Simon Watson
Messages: 30
Registered: September 2011
Member
I'm trying to modify my application to use Gemini DBAccess / JPA (with MySQL). I'm using Virgo 3.6 and I'm seeing a strange problem when I deploy a simple plan with the required Gemini bundles and a test bundle with a persistence unit. Virgo goes into a loop, starting and stopping my plan hundreds of times.

Any pointers to help debug this would be much appreciated...

[2013-01-17 14:33:48.481] startup-tracker              <KE0001I> Kernel starting. 
[2013-01-17 14:33:50.207] startup-tracker              <KE0002I> Kernel started. 
[2013-01-17 14:33:50.402] system-artifacts             <DE0000I> Installing plan 'org.eclipse.virgo.kernel.userregion.blueprint' version '3.6.0'. 
[2013-01-17 14:33:50.524] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.gemini.blueprint.core' version '1.0.2.RELEASE'. 
[2013-01-17 14:33:50.555] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.gemini.blueprint.extender' version '1.0.2.RELEASE'. 
[2013-01-17 14:33:50.570] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.gemini.blueprint.io' version '1.0.2.RELEASE'. 
[2013-01-17 14:33:50.589] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.virgo.kernel.agent.dm' version '3.6.0.RELEASE'. 
[2013-01-17 14:33:50.595] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.virgo.kernel.deployer.dm' version '3.6.0.RELEASE'. 
[2013-01-17 14:33:50.616] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.equinox.ds' version '1.4.0.v20120112-1400'. 
[2013-01-17 14:33:50.637] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.equinox.util' version '1.0.300.v20111010-1614'. 
[2013-01-17 14:33:50.640] system-artifacts             <DE0000I> Installing configuration 'osgi.console' version '0.0.0'. 
[2013-01-17 14:33:51.764] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.gemini.blueprint.core' version '1.0.2.RELEASE'. 
[2013-01-17 14:33:51.766] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.gemini.blueprint.extender' version '1.0.2.RELEASE'. 
[2013-01-17 14:33:51.767] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.gemini.blueprint.io' version '1.0.2.RELEASE'. 
[2013-01-17 14:33:51.767] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.virgo.kernel.agent.dm' version '3.6.0.RELEASE'. 
[2013-01-17 14:33:51.768] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.virgo.kernel.deployer.dm' version '3.6.0.RELEASE'. 
[2013-01-17 14:33:51.769] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.equinox.ds' version '1.4.0.v20120112-1400'. 
[2013-01-17 14:33:51.771] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.equinox.util' version '1.0.300.v20111010-1614'. 
[2013-01-17 14:33:51.771] system-artifacts             <DE0001I> Installed configuration 'osgi.console' version '0.0.0'. 
[2013-01-17 14:33:51.772] system-artifacts             <DE0001I> Installed plan 'org.eclipse.virgo.kernel.userregion.blueprint' version '3.6.0'. 
[2013-01-17 14:33:51.798] system-artifacts             <DE0004I> Starting plan 'org.eclipse.virgo.kernel.userregion.blueprint' version '3.6.0'. 
[2013-01-17 14:33:51.804] system-artifacts             <DE0004I> Starting bundle 'org.eclipse.gemini.blueprint.core' version '1.0.2.RELEASE'. 
[2013-01-17 14:33:51.808] start-signalling-1           <DE0005I> Started bundle 'org.eclipse.gemini.blueprint.core' version '1.0.2.RELEASE'. 
[2013-01-17 14:33:51.809] system-artifacts             <DE0004I> Starting bundle 'org.eclipse.gemini.blueprint.extender' version '1.0.2.RELEASE'. 
[2013-01-17 14:33:52.459] system-artifacts             <DE0004I> Starting bundle 'org.eclipse.gemini.blueprint.io' version '1.0.2.RELEASE'. 
[2013-01-17 14:33:52.464] system-artifacts             <DE0004I> Starting bundle 'org.eclipse.virgo.kernel.agent.dm' version '3.6.0.RELEASE'. 
[2013-01-17 14:33:52.470] start-signalling-2           <DE0005I> Started bundle 'org.eclipse.gemini.blueprint.io' version '1.0.2.RELEASE'. 
[2013-01-17 14:33:52.472] system-artifacts             <DE0004I> Starting bundle 'org.eclipse.virgo.kernel.deployer.dm' version '3.6.0.RELEASE'. 
[2013-01-17 14:33:52.474] start-signalling-1           <DE0005I> Started bundle 'org.eclipse.gemini.blueprint.extender' version '1.0.2.RELEASE'. 
[2013-01-17 14:33:52.477] start-signalling-3           <DE0005I> Started bundle 'org.eclipse.virgo.kernel.agent.dm' version '3.6.0.RELEASE'. 
[2013-01-17 14:33:52.480] system-artifacts             <DE0004I> Starting bundle 'org.eclipse.equinox.ds' version '1.4.0.v20120112-1400'. 
[2013-01-17 14:33:52.626] start-signalling-3           <DE0005I> Started bundle 'org.eclipse.equinox.ds' version '1.4.0.v20120112-1400'. 
[2013-01-17 14:33:52.635] system-artifacts             <DE0004I> Starting bundle 'org.eclipse.equinox.util' version '1.0.300.v20111010-1614'. 
[2013-01-17 14:33:52.682] system-artifacts             <DE0004I> Starting configuration 'osgi.console' version '0.0.0'. 
[2013-01-17 14:33:52.693] start-signalling-3           <DE0005I> Started bundle 'org.eclipse.equinox.util' version '1.0.300.v20111010-1614'. 
[2013-01-17 14:33:52.700] system-artifacts             <DE0005I> Started configuration 'osgi.console' version '0.0.0'. 
[2013-01-17 14:33:52.735] start-signalling-3           <DE0005I> Started bundle 'org.eclipse.virgo.kernel.deployer.dm' version '3.6.0.RELEASE'. 
[2013-01-17 14:33:52.737] start-signalling-3           <DE0005I> Started plan 'org.eclipse.virgo.kernel.userregion.blueprint' version '3.6.0'. 
[2013-01-17 14:33:52.884] system-artifacts             <DE0000I> Installing plan 'org.eclipse.virgo.web.tomcat' version '3.6.0'. 
[2013-01-17 14:33:52.886] system-artifacts             <DE0000I> Installing configuration 'org.eclipse.virgo.web' version '0.0.0'. 
[2013-01-17 14:33:52.893] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.virgo.web.spring.integration' version '3.6.0.RELEASE'. 
[2013-01-17 14:33:52.922] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.gemini.web.core' version '2.2.0.RELEASE'. 
[2013-01-17 14:33:52.963] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.gemini.web.tomcat' version '2.2.0.RELEASE'. 
[2013-01-17 14:33:52.974] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.virgo.web.core' version '3.6.0.RELEASE'. 
[2013-01-17 14:33:52.979] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.virgo.web.dm' version '3.6.0.RELEASE'. 
[2013-01-17 14:33:52.987] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.virgo.web.tomcat.support' version '3.6.0.RELEASE'. 
[2013-01-17 14:33:52.991] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.virgo.web.servlet.adapter' version '3.6.0.RELEASE'. 
[2013-01-17 14:33:53.585] system-artifacts             <DE0001I> Installed configuration 'org.eclipse.virgo.web' version '0.0.0'. 
[2013-01-17 14:33:53.586] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.virgo.web.spring.integration' version '3.6.0.RELEASE'. 
[2013-01-17 14:33:53.587] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.gemini.web.core' version '2.2.0.RELEASE'. 
[2013-01-17 14:33:53.588] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.gemini.web.tomcat' version '2.2.0.RELEASE'. 
[2013-01-17 14:33:53.589] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.virgo.web.core' version '3.6.0.RELEASE'. 
[2013-01-17 14:33:53.590] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.virgo.web.dm' version '3.6.0.RELEASE'. 
[2013-01-17 14:33:53.591] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.virgo.web.tomcat.support' version '3.6.0.RELEASE'. 
[2013-01-17 14:33:53.592] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.virgo.web.servlet.adapter' version '3.6.0.RELEASE'. 
[2013-01-17 14:33:53.593] system-artifacts             <DE0001I> Installed plan 'org.eclipse.virgo.web.tomcat' version '3.6.0'. 
[2013-01-17 14:33:53.606] system-artifacts             <DE0004I> Starting plan 'org.eclipse.virgo.web.tomcat' version '3.6.0'. 
[2013-01-17 14:33:53.606] system-artifacts             <DE0004I> Starting configuration 'org.eclipse.virgo.web' version '0.0.0'. 
[2013-01-17 14:33:53.609] system-artifacts             <DE0005I> Started configuration 'org.eclipse.virgo.web' version '0.0.0'. 
[2013-01-17 14:33:53.611] system-artifacts             <DE0005I> Started bundle 'org.eclipse.virgo.web.spring.integration' version '3.6.0.RELEASE'. 
[2013-01-17 14:33:53.613] system-artifacts             <DE0004I> Starting bundle 'org.eclipse.gemini.web.core' version '2.2.0.RELEASE'. 
[2013-01-17 14:33:53.627] start-signalling-3           <DE0005I> Started bundle 'org.eclipse.gemini.web.core' version '2.2.0.RELEASE'. 
[2013-01-17 14:33:53.628] system-artifacts             <DE0004I> Starting bundle 'org.eclipse.gemini.web.tomcat' version '2.2.0.RELEASE'. 
[2013-01-17 14:33:54.444] system-artifacts             <TC0000I> Starting Tomcat. 
[2013-01-17 14:33:54.490] system-artifacts             <TC0010I> Creating HTTP/1.1 connector with scheme http on port 8080. 
[2013-01-17 14:33:54.508] system-artifacts             <TC0010I> Creating HTTP/1.1 connector with scheme https on port 8443. 
[2013-01-17 14:33:54.516] system-artifacts             <TC0010I> Creating AJP/1.3 connector with scheme http on port 8009. 
[2013-01-17 14:33:54.519] system-artifacts             <TC0001I> Started Tomcat. 
[2013-01-17 14:33:54.544] system-artifacts             <DE0004I> Starting bundle 'org.eclipse.virgo.web.core' version '3.6.0.RELEASE'. 
[2013-01-17 14:33:54.566] system-artifacts             <DE0004I> Starting bundle 'org.eclipse.virgo.web.dm' version '3.6.0.RELEASE'. 
[2013-01-17 14:33:54.572] system-artifacts             <DE0005I> Started bundle 'org.eclipse.virgo.web.tomcat.support' version '3.6.0.RELEASE'. 
[2013-01-17 14:33:54.574] system-artifacts             <DE0004I> Starting bundle 'org.eclipse.virgo.web.servlet.adapter' version '3.6.0.RELEASE'. 
[2013-01-17 14:33:54.577] start-signalling-3           <DE0005I> Started bundle 'org.eclipse.virgo.web.dm' version '3.6.0.RELEASE'. 
[2013-01-17 14:33:54.578] start-signalling-1           <DE0005I> Started bundle 'org.eclipse.virgo.web.servlet.adapter' version '3.6.0.RELEASE'. 
[2013-01-17 14:33:54.696] start-signalling-1           <DE0005I> Started bundle 'org.eclipse.gemini.web.tomcat' version '2.2.0.RELEASE'. 
[2013-01-17 14:33:54.718] start-signalling-1           <DE0005I> Started bundle 'org.eclipse.virgo.web.core' version '3.6.0.RELEASE'. 
[2013-01-17 14:33:54.720] start-signalling-1           <DE0005I> Started plan 'org.eclipse.virgo.web.tomcat' version '3.6.0'. 
[2013-01-17 14:33:54.788] system-artifacts             <DE0000I> Installing configuration 'org.eclipse.virgo.apps.repository' version '0.0.0'. 
[2013-01-17 14:33:54.802] system-artifacts             <DE0001I> Installed configuration 'org.eclipse.virgo.apps.repository' version '0.0.0'. 
[2013-01-17 14:33:54.806] system-artifacts             <DE0004I> Starting configuration 'org.eclipse.virgo.apps.repository' version '0.0.0'. 
[2013-01-17 14:33:54.810] system-artifacts             <DE0005I> Started configuration 'org.eclipse.virgo.apps.repository' version '0.0.0'. 
[2013-01-17 14:33:54.889] system-artifacts             <DE0000I> Installing plan 'org.eclipse.virgo.management' version '3.6.0'. 
[2013-01-17 14:33:54.958] system-artifacts             <DE0000I> Installing bundle 'osgi.enterprise' version '4.2.0.v201108120515'. 
[2013-01-17 14:33:54.981] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.gemini.management' version '1.0.5.RELEASE'. 
[2013-01-17 14:33:54.988] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.virgo.management.fragment' version '3.6.0.RELEASE'. 
[2013-01-17 14:33:55.079] system-artifacts             <DE0001I> Installed bundle 'osgi.enterprise' version '4.2.0.v201108120515'. 
[2013-01-17 14:33:55.081] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.gemini.management' version '1.0.5.RELEASE'. 
[2013-01-17 14:33:55.083] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.virgo.management.fragment' version '3.6.0.RELEASE'. 
[2013-01-17 14:33:55.085] system-artifacts             <DE0001I> Installed plan 'org.eclipse.virgo.management' version '3.6.0'. 
[2013-01-17 14:33:55.098] system-artifacts             <DE0004I> Starting plan 'org.eclipse.virgo.management' version '3.6.0'. 
[2013-01-17 14:33:55.101] system-artifacts             <DE0004I> Starting bundle 'osgi.enterprise' version '4.2.0.v201108120515'. 
[2013-01-17 14:33:55.103] start-signalling-1           <DE0005I> Started bundle 'osgi.enterprise' version '4.2.0.v201108120515'. 
[2013-01-17 14:33:55.105] system-artifacts             <DE0004I> Starting bundle 'org.eclipse.gemini.management' version '1.0.5.RELEASE'. 
[2013-01-17 14:33:55.123] start-signalling-1           <DE0005I> Started bundle 'org.eclipse.gemini.management' version '1.0.5.RELEASE'. 
[2013-01-17 14:33:55.126] system-artifacts             <DE0005I> Started bundle 'org.eclipse.virgo.management.fragment' version '3.6.0.RELEASE'. 
[2013-01-17 14:33:55.128] system-artifacts             <DE0005I> Started plan 'org.eclipse.virgo.management' version '3.6.0'. 
[2013-01-17 14:33:55.131] sync Event Dispatcher Thread <UR0001I> User region ready. 
[2013-01-17 14:33:55.134] startup-readiness            <KE0007I> Virgo ready. Started for 8.406s. 
[2013-01-17 14:33:56.136] fs-watcher                   <HD0001I> Hot deployer processing 'INITIAL' event for file 'demo.plan'. 
[2013-01-17 14:33:56.200] fs-watcher                   <DE0000I> Installing plan 'my-test.plan' version '1.0.0'. 
[2013-01-17 14:33:56.278] fs-watcher                   <DE0000I> Installing bundle 'my-test.plan-1-com.springsource.com.mysql.jdbc' version '5.1.6'. 
[2013-01-17 14:33:56.287] fs-watcher                   <DE0000I> Installing bundle 'my-test.plan-1-org.eclipse.gemini.dbaccess.mysql' version '1.1.0.RC1'. 
[2013-01-17 14:33:56.313] fs-watcher                   <DE0000I> Installing bundle 'my-test.plan-1-org.eclipse.gemini.jpa' version '1.1.0.RELEASE'. 
[2013-01-17 14:33:56.319] fs-watcher                   <DE0000I> Installing bundle 'my-test.plan-1-foo.test.pu' version '1.0.1'. 
[2013-01-17 14:33:56.465] fs-watcher                   <DE0001I> Installed bundle 'my-test.plan-1-com.springsource.com.mysql.jdbc' version '5.1.6'. 
[2013-01-17 14:33:56.466] fs-watcher                   <DE0001I> Installed bundle 'my-test.plan-1-org.eclipse.gemini.dbaccess.mysql' version '1.1.0.RC1'. 
[2013-01-17 14:33:56.471] fs-watcher                   <DE0001I> Installed bundle 'my-test.plan-1-org.eclipse.gemini.jpa' version '1.1.0.RELEASE'. 
[2013-01-17 14:33:56.476] fs-watcher                   <DE0001I> Installed bundle 'my-test.plan-1-foo.test.pu' version '1.0.1'. 
[2013-01-17 14:33:56.478] fs-watcher                   <DE0001I> Installed bundle 'my-test.plan-1-synthetic.context' version '1.0.0'. 
[2013-01-17 14:33:56.480] fs-watcher                   <DE0001I> Installed plan 'my-test.plan' version '1.0.0'. 
[2013-01-17 14:33:56.498] fs-watcher                   <DE0004I> Starting plan 'my-test.plan' version '1.0.0'. 
[2013-01-17 14:33:56.502] fs-watcher                   <DE0004I> Starting bundle 'my-test.plan-1-com.springsource.com.mysql.jdbc' version '5.1.6'. 
[2013-01-17 14:33:56.505] start-signalling-1           <DE0005I> Started bundle 'my-test.plan-1-com.springsource.com.mysql.jdbc' version '5.1.6'. 
[2013-01-17 14:33:56.510] fs-watcher                   <DE0004I> Starting bundle 'my-test.plan-1-org.eclipse.gemini.dbaccess.mysql' version '1.1.0.RC1'. 
[2013-01-17 14:33:56.521] start-signalling-1           <DE0005I> Started bundle 'my-test.plan-1-org.eclipse.gemini.dbaccess.mysql' version '1.1.0.RC1'. 
[2013-01-17 14:33:56.521] fs-watcher                   <DE0004I> Starting bundle 'my-test.plan-1-org.eclipse.gemini.jpa' version '1.1.0.RELEASE'. 
[2013-01-17 14:33:56.565] start-signalling-1           <DE0005I> Started bundle 'my-test.plan-1-org.eclipse.gemini.jpa' version '1.1.0.RELEASE'. 
[2013-01-17 14:33:56.577] fs-watcher                   <DE0004I> Starting bundle 'my-test.plan-1-foo.test.pu' version '1.0.1'. 
[2013-01-17 14:33:56.587] Refresh Packages             <DE0010I> Stopping bundle 'my-test.plan-1-foo.test.pu' version '1.0.1'. 
[2013-01-17 14:33:56.589] start-signalling-1           <DE0005I> Started bundle 'my-test.plan-1-foo.test.pu' version '1.0.1'. 
[2013-01-17 14:33:56.590] Refresh Packages             <DE0010I> Stopping plan 'my-test.plan' version '1.0.0'. 
[2013-01-17 14:33:56.593] Refresh Packages             <DE0010I> Stopping bundle 'my-test.plan-1-com.springsource.com.mysql.jdbc' version '5.1.6'. 
[2013-01-17 14:33:56.594] Refresh Packages             <DE0011I> Stopped bundle 'my-test.plan-1-com.springsource.com.mysql.jdbc' version '5.1.6'. 
[2013-01-17 14:33:56.597] Refresh Packages             <DE0010I> Stopping bundle 'my-test.plan-1-org.eclipse.gemini.dbaccess.mysql' version '1.1.0.RC1'. 
[2013-01-17 14:33:56.599] Refresh Packages             <DE0011I> Stopped bundle 'my-test.plan-1-org.eclipse.gemini.dbaccess.mysql' version '1.1.0.RC1'. 
[2013-01-17 14:33:56.602] Refresh Packages             <DE0010I> Stopping bundle 'my-test.plan-1-org.eclipse.gemini.jpa' version '1.1.0.RELEASE'. 
[2013-01-17 14:33:56.607] Refresh Packages             <DE0011I> Stopped bundle 'my-test.plan-1-org.eclipse.gemini.jpa' version '1.1.0.RELEASE'. 
[2013-01-17 14:33:56.609] Refresh Packages             <DE0011I> Stopped plan 'my-test.plan' version '1.0.0'. 
[2013-01-17 14:33:56.610] Refresh Packages             <DE0011I> Stopped bundle 'my-test.plan-1-foo.test.pu' version '1.0.1'. 
[2013-01-17 14:33:56.618] Refresh Packages             <DE0004I> Starting bundle 'my-test.plan-1-foo.test.pu' version '1.0.1'. 
[2013-01-17 14:33:56.623] start-signalling-1           <DE0005I> Started bundle 'my-test.plan-1-foo.test.pu' version '1.0.1'. 
[2013-01-17 14:33:56.626] fs-watcher                   <DE0004I> Starting plan 'my-test.plan' version '1.0.0'. 
[2013-01-17 14:33:56.629] fs-watcher                   <DE0004I> Starting bundle 'my-test.plan-1-com.springsource.com.mysql.jdbc' version '5.1.6'. 
[2013-01-17 14:33:56.637] start-signalling-1           <DE0005I> Started bundle 'my-test.plan-1-com.springsource.com.mysql.jdbc' version '5.1.6'. 
[2013-01-17 14:33:56.647] fs-watcher                   <DE0004I> Starting bundle 'my-test.plan-1-org.eclipse.gemini.dbaccess.mysql' version '1.1.0.RC1'. 
[2013-01-17 14:33:56.650] start-signalling-1           <DE0005I> Started bundle 'my-test.plan-1-org.eclipse.gemini.dbaccess.mysql' version '1.1.0.RC1'. 
[2013-01-17 14:33:56.653] fs-watcher                   <DE0004I> Starting bundle 'my-test.plan-1-org.eclipse.gemini.jpa' version '1.1.0.RELEASE'. 
[2013-01-17 14:33:56.665] start-signalling-1           <DE0005I> Started bundle 'my-test.plan-1-org.eclipse.gemini.jpa' version '1.1.0.RELEASE'. 
[2013-01-17 14:33:56.669] fs-watcher                   <DE0004I> Starting bundle 'my-test.plan-1-synthetic.context' version '1.0.0'. 
[2013-01-17 14:33:56.672] Refresh Packages             <DE0010I> Stopping bundle 'my-test.plan-1-synthetic.context' version '1.0.0'. 
[2013-01-17 14:33:56.674] fs-watcher                   <HD0001I> Hot deployer processing 'INITIAL' event for file 'org.eclipse.virgo.apps.repository_3.6.0.RELEASE.par'. 
[2013-01-17 14:33:56.674] start-signalling-3           <DE0005I> Started bundle 'my-test.plan-1-synthetic.context' version '1.0.0'. 
[2013-01-17 14:33:56.677] start-signalling-1           <DE0005I> Started bundle 'my-test.plan-1-synthetic.context' version '1.0.0'. 
[2013-01-17 14:33:56.677] Refresh Packages             <DE0010I> Stopping plan 'my-test.plan' version '1.0.0'. 
[2013-01-17 14:33:56.678] start-signalling-1           <DE0005I> Started plan 'my-test.plan' version '1.0.0'. 
[2013-01-17 14:33:56.679] Refresh Packages             <DE0010I> Stopping bundle 'my-test.plan-1-com.springsource.com.mysql.jdbc' version '5.1.6'. 
[2013-01-17 14:33:56.681] Refresh Packages             <DE0010I> Stopping plan 'my-test.plan' version '1.0.0'. 
[2013-01-17 14:33:56.684] Refresh Packages             <DE0010I> Stopping bundle 'my-test.plan-1-org.eclipse.gemini.dbaccess.mysql' version '1.1.0.RC1'. 
[2013-01-17 14:33:56.694] Refresh Packages             <DE0011I> Stopped bundle 'my-test.plan-1-org.eclipse.gemini.dbaccess.mysql' version '1.1.0.RC1'. 
[2013-01-17 14:33:56.696] Refresh Packages             <DE0010I> Stopping bundle 'my-test.plan-1-org.eclipse.gemini.jpa' version '1.1.0.RELEASE'. 
[2013-01-17 14:33:56.700] Refresh Packages             <DE0011I> Stopped bundle 'my-test.plan-1-org.eclipse.gemini.jpa' version '1.1.0.RELEASE'. 
[2013-01-17 14:33:56.702] Refresh Packages             <DE0010I> Stopping bundle 'my-test.plan-1-foo.test.pu' version '1.0.1'. 
[2013-01-17 14:33:56.704] Refresh Packages             <DE0011I> Stopped bundle 'my-test.plan-1-foo.test.pu' version '1.0.1'. 
[2013-01-17 14:33:56.706] Refresh Packages             <DE0011I> Stopped plan 'my-test.plan' version '1.0.0'. 
[2013-01-17 14:33:56.707] Refresh Packages             <DE0011I> Stopped bundle 'my-test.plan-1-com.springsource.com.mysql.jdbc' version '5.1.6'. 
[2013-01-17 14:33:56.708] Refresh Packages             <DE0011I> Stopped bundle 'my-test.plan-1-synthetic.context' version '1.0.0'. 


My plan is:

<?xml version="1.0" encoding="UTF-8"?>
<plan name="my-test.plan" version="1.0.0" scoped="true" atomic="true"
        xmlns="http://www.eclipse.org/virgo/schema/plan"
		xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
		xsi:schemaLocation="
		        http://www.eclipse.org/virgo/schema/plan
		        http://www.eclipse.org/virgo/schema/plan/eclipse-virgo-plan.xsd">

    <artifact type="bundle" name="com.springsource.com.mysql.jdbc" />
    <artifact type="bundle" name="org.eclipse.gemini.dbaccess.mysql" />
    <artifact type="bundle" name="org.eclipse.gemini.jpa" />
     
     <artifact type="bundle" name="foo.test.pu" />
</plan> 



My test PU bundle manifest:

Manifest-Version: 1.0
Bundle-Version: 1.0.1
Bundle-Name: PayLiquid Domain Model
Bundle-ManifestVersion: 2
Bundle-SymbolicName: foo.test.pu
Meta-Persistence: 
Export-Package: model.configadmin;version="1.1.0"
Import-Package: javax.persistence;version="[2.0.4,2.0.4]";jpa="2.0",
 javax.persistence.criteria;version="[2.0.4,2.0.4]";jpa="2.0",
 javax.persistence.metamodel;version="[2.0.4,2.0.4]";jpa="2.0",
 org.osgi.framework;version="[1.7.0,1.7.0]",
 org.osgi.service.jpa;version="[1.0.0,1.0.0]"


and persistence.xml (based on org.eclipse.gemini.jpa.sample.configadmin.pu-1.1.0.RELEASE):

<?xml version="1.0" encoding="UTF-8"?>
<persistence version="1.0" 
    xmlns="http://java.sun.com/xml/ns/persistence"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="http://java.sun.com/xml/ns/persistence http://java.sun.com/xml/ns/persistence/persistence_1_0.xsd">

    <persistence-unit name="Library" transaction-type="RESOURCE_LOCAL">
        <provider>org.eclipse.persistence.jpa.PersistenceProvider</provider>

        <class>model.configadmin.Library</class>
        <class>model.configadmin.Book</class>

        <exclude-unlisted-classes>true</exclude-unlisted-classes>
        <properties>
			<property name="eclipselink.weaving" value="static"/>
			<property name="javax.persistence.jdbc.driver" value="com.mysql.jdbc.Driver" />
			<property name="javax.persistence.jdbc.url" value="jdbc:mysql://localhost:3306/test" />
			<property name="javax.persistence.jdbc.user" value="test" />
			<property name="javax.persistence.jdbc.password" value="test" />
		</properties>
    </persistence-unit>
</persistence>
Re: Problem with Gemini DBAccess / JPA and Virgo 3.6 [message #1002094 is a reply to message #1001941] Thu, 17 January 2013 18:11 Go to previous messageGo to next message
Simon Watson is currently offline Simon Watson
Messages: 30
Registered: September 2011
Member
I disabled Gemini JPA's bundle refresh feature and it fixed the problem (but not really the cause). More details here: http://www.eclipse.org/forums/index.php/m/1002087/#msg_1002087
Re: Problem with Gemini DBAccess / JPA and Virgo 3.6 [message #1002203 is a reply to message #1002094] Fri, 18 January 2013 01:54 Go to previous messageGo to next message
Lazar Kirchev is currently offline Lazar Kirchev
Messages: 28
Registered: July 2009
Location: Sofia, Bulgaria
Junior Member
There is a bug in Gemini JPA component regarding this refresh - https://bugs.eclipse.org/bugs/show_bug.cgi?id=394392.
Re: Problem with Gemini DBAccess / JPA and Virgo 3.6 [message #1002300 is a reply to message #1002203] Fri, 18 January 2013 05:58 Go to previous message
Simon Watson is currently offline Simon Watson
Messages: 30
Registered: September 2011
Member
Interesting, but this bug refers to a PU being packed into a web app bundle. In my case, I see the problem without any of my own WABs being loaded. The PU bundle which causes the behaviour is as minimal as it can be.

I wonder if it's related to Virgo plans and the synthetic context it creates for them.
Previous Topic:Virgo Community Survey including fun quiz
Next Topic:Doubts regarding ManagedServiceFactory
Goto Forum:
  


Current Time: Sat Apr 19 16:14:40 EDT 2014

Powered by FUDForum. Page generated in 0.03621 seconds