Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMF (Graphical Modeling Framework) » [EVL] Quick Fix not found when working in project with white space(White spaces in projects seem to inhibit finding quick fixes)
[EVL] Quick Fix not found when working in project with white space [message #1001447] Wed, 16 January 2013 13:18 Go to next message
Stephen Slaboda is currently offline Stephen Slaboda
Messages: 8
Registered: November 2012
Junior Member
Hi all,

I have been writing EVL for my GMF model in Eclipse Indigo, and I believe that having white space in the project the model is stored in causes quick fixes to not be found properly.

For instance, I have two files
<workspace-directory>/Blah Blah Blah/sample.mymodel_diagram
and
<workspace-directory>/BlahBlahBlah/sample.mymodel_diagram

These files are created programmatically and contain both the model and diagram. They are equivalent (only differences are the xmi:id attributes)

When I try to perform a quick fix on the "Blah Blah Blah" diagram, I only get Ignore as a fix option. When I try to perform a quick fix on the "BlahBlahBlah" diagram, it works just fine and shows me the expected quick fix in addition to Ignore.

I read through this post and found someone else talking about whitespace in their workspace path.

So my questions are this:
Is this a real bug, and if so has it already been reported?
Has this behavior changed since the latest Indigo-based release of GMF?
Is there some workaround that I could implement to fix this?

Thanks,
-Stephen
Re: [EVL] Quick Fix not found when working in project with white space [message #1001522 is a reply to message #1001447] Wed, 16 January 2013 16:34 Go to previous message
Stephen Slaboda is currently offline Stephen Slaboda
Messages: 8
Registered: November 2012
Junior Member
I just realized that the Epsilon forum is a better place for this question, so if a moderator could move this over there I'd appreciate it.

Thanks
Previous Topic:Apply changes in editor
Next Topic:Change domain model when diagram was opened
Goto Forum:
  


Current Time: Tue Sep 02 10:10:37 EDT 2014

Powered by FUDForum. Page generated in 0.03318 seconds