Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » appearance of association ends
appearance of association ends [message #1001236] Wed, 16 January 2013 09:45 Go to next message
Bruce L. is currently offline Bruce L.Friend
Messages: 75
Registered: June 2011
Member
Hi

once I customize the appearance of an association-end, by hiding everything, the association-end label is obviously not visible anymore.
But the problem is that afterwards I cannot access it anymore to change the appearance again, if I change my mind.

If I click on the association-end element in the model explorer, the 'appearance' tab in the properties panel is not shown! (why???) - so I cannot solve my problem this way.
This is annoying also in the first place, since to get to the appearance properties of the association-end I first need to select the association, then appearance, and then click again on the label of the association-end

Any suggestion?
Thank you
Re: appearance of association ends [message #1001338 is a reply to message #1001236] Wed, 16 January 2013 14:10 Go to previous messageGo to next message
Christian W. Damus is currently offline Christian W. DamusFriend
Messages: 831
Registered: July 2009
Senior Member
Hi, Bruce,

Have you tried the "All Connector Labels" and "Manage Connector Labels"
actions in the Filter menu?

BTW, elements in the Model Explorer can be visualized in more than one
diagram. Editing appearance properties there would be confusing: which
diagram view of the element is to be updated?

HTH,

Christian


On 2013-01-16 09:45:59 +0000, Bruce L. said:

> Hi
>
> once I customize the appearance of an association-end, by hiding
> everything, the association-end label is obviously not visible anymore.
> But the problem is that afterwards I cannot access it anymore to change
> the appearance again, if I change my mind.
>
> If I click on the association-end element in the model explorer, the
> 'appearance' tab in the properties panel is not shown! (why???) - so I
> cannot solve my problem this way.
> This is annoying also in the first place, since to get to the
> appearance properties of the association-end I first need to select the
> association, then appearance, and then click again on the label of the
> association-end
>
> Any suggestion?
> Thank you
Re: appearance of association ends [message #1001383 is a reply to message #1001338] Wed, 16 January 2013 15:51 Go to previous message
Bruce L. is currently offline Bruce L.Friend
Messages: 75
Registered: June 2011
Member
Thanks for the reply
I understand why the 'appearance' options are not available from the Model Explorer, it makes total sense.

The 'all connector labels' does not help. The problem is not really showing a label, but get back to the panel where you can select which items of the label to show (name, multiplicity, ecc). If one association-end appearance is configured not to show anything, nothing will be displayed even when I choose 'all connector labels'; basically it does show it, but it is blank! so you cannot really click on it.

Well, I managed to do it (clicking on it) by randomly clicking on the white area around the association where the label is supposed to be, getting a tiny selection area (the blank label).

So the issue is really that you cannot get conveniently to the appearance options of an association-end, when you don't see its label

thanks

Previous Topic:representing self (or this) in a Lifeline
Next Topic:Best way to extend papyrus to add free string for multiplicity
Goto Forum:
  


Current Time: Sat Nov 29 08:59:51 GMT 2014

Powered by FUDForum. Page generated in 0.01759 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software