Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » NatTable » NatTable Developing(Error on set up your development environment.)
NatTable Developing [message #998736] Thu, 10 January 2013 15:34 Go to next message
Yossi Cohen is currently offline Yossi CohenFriend
Messages: 2
Registered: January 2013
Junior Member
Hi all,
I launched the example:"NatTableExamples.jnlp" of NatTable and wanted to play with it more in order to use it.
the problem is:
after I followed the instructions in the getting started site under "Developer" from the begining till the 'Set as Target Platform' part
and the project does not compile.

there are some "imports" missing i.e.:


import ca.odell.glazedlists.FilterList;
import ca.odell.glazedlists.matchers.CompositeMatcherEditor;
import ca.odell.glazedlists.EventList;
import ca.odell.glazedlists.GlazedLists;
import ca.odell.glazedlists.TreeList;
import ca.odell.glazedlists.TreeList.Node;

import org.apache.poi.ss.usermodel.Cell;
import org.apache.poi.ss.usermodel.CellStyle;
import org.apache.poi.ss.usermodel.Font;
import org.apache.poi.ss.usermodel.Row;
import org.apache.poi.ss.usermodel.Sheet;
import org.apache.poi.ss.usermodel.Workbook;
import org.apache.poi.ss.util.CellRangeAddress;

import org.apache.poi.hssf.usermodel.HSSFPalette;
import org.apache.poi.hssf.usermodel.HSSFWorkbook;

Where can I get the missing files?
is there a specific version needed?

is there a way to download the whole package of NatTable without the need for mvn to bring the dependencies?

am I missing something?

Thanks in advance,
Yossi Cohen
Re: NatTable Developing [message #1000183 is a reply to message #998736] Mon, 14 January 2013 07:56 Go to previous messageGo to next message
Dirk Fauth is currently offline Dirk FauthFriend
Messages: 1431
Registered: July 2012
Senior Member
Hi and sorry for the late reply on this,

no there is no way for downloading the whole package for development. You need to use the mvn task for getting the needed third party libraries.

What is missing is the Glazedlists and the Apache POI bundles. You can get them via the mvn copy dependencies task described in the documentation.

The cause for this is, that for Glazedlists and Apache POI there are no OSGi packages in a p2 Update Site yet. We have addressed this a while ago and there is work done on that. Until this isn't solved, we are not able to change that.

The correct solution should be to point to the p2 Update Site for Glazedlists and Apache POI in our PDE target definition. Then we are able to remove the mvn copy dependencies task and then we are also able to provide a complete p2 Update Site for the NatTable.

So, there is work done on that, and AFAIK there is also some progress I heard of. So stay tuned for a clean solution.

Greez,
Dirk
Re: NatTable Developing [message #1005887 is a reply to message #1000183] Tue, 29 January 2013 08:38 Go to previous message
Yossi Cohen is currently offline Yossi CohenFriend
Messages: 2
Registered: January 2013
Junior Member
Thanks Dirk!
Previous Topic:Active cell editor issue
Next Topic:The ICellEditor is never triggered?
Goto Forum:
  


Current Time: Thu Dec 18 20:27:34 GMT 2014

Powered by FUDForum. Page generated in 0.01895 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software