Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » #include <thread> not recognized
#include <thread> not recognized [message #997334] Sun, 06 January 2013 08:58 Go to next message
Roger Gilliar is currently offline Roger GilliarFriend
Messages: 40
Registered: March 2010
Member
HI,

I would like to use the new threading lib from C++11. It seems that I have to use -stdlib=libc++ to make this work (using clang 4.1 on Mac OS X 10.8 ). But CDT doesn't recognize #include <thread> and therefore offers no code completion.

Is it possible to configure CDT to recognize this include ?

Regards
Roger

[Updated on: Sun, 06 January 2013 09:09]

Report message to a moderator

Re: #include <thread> not recognized [message #997336 is a reply to message #997334] Sun, 06 January 2013 11:31 Go to previous message
Roger Gilliar is currently offline Roger GilliarFriend
Messages: 40
Registered: March 2010
Member
I added /usr/bin/../lib/clang/4.1/include and /usr/bin/../lib/c++/v1 to Path and Symbols/Include and its working now.

Regards
Roger

[Updated on: Sun, 06 January 2013 11:32]

Report message to a moderator

Previous Topic:Symbol 'cout' could not be resolved
Next Topic:How to enable code completion for tuple
Goto Forum:
  


Current Time: Sun Dec 21 16:48:49 GMT 2014

Powered by FUDForum. Page generated in 0.11250 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software