Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Libra » Current status for "/libra/milestones/" update site directory(juno's org.eclipse.osgi bundles artifacts.xml and content.xml contains missing update site urls.)
icon9.gif  Current status for "/libra/milestones/" update site directory [message #997309] Sat, 05 January 2013 10:01 Go to next message
Masahiko Sakamoto is currently offline Masahiko Sakamoto
Messages: 2
Registered: January 2013
Junior Member
With eclipse-jee-juno-SR1-win32-x86_64, "configuration/org.eclipse.osgi/bundles/318/data/-868940355/artifacts.xml" (and "content.xml") contains following line:

...
<repository name='update site: http://download.eclipse.org/libra/milestones/S-0.2.0M1-201108160923/' ...
...

BUT this url returns 404 not found.

For example, http://(some mirrors)/eclipse/libra/milestones/S-0.2.0M1-201108160923/ returns 404 not found also.
But http://(some mirrors)/eclipse/libra/milestones/S-0.3.0M4-201212132137/ returns valid contents.

Current Version of "libra" project (http://www.eclipse.org/libra/) is 0.2, isn't it ?

Is this problem belongs to osgi configuration ? Or, miss-operation (miss-deleting S-0.2.0M1-xxxx directory) at libra project side ?
Re: Current status for "/libra/milestones/" update site directory [message #997432 is a reply to message #997309] Mon, 07 January 2013 08:39 Go to previous messageGo to next message
Kaloyan Raev is currently offline Kaloyan Raev
Messages: 185
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
The S-0.2.0M1-xxx version is the Juno M1 milestone release of Libra. I am not quite sure why and how this version got listed under the configuration of Juno SR1.

And yes, recently I pruned all Juno milestone releases from the download site, because they are obsolete and the official Juno releases should be used instead of these milestones.
icon7.gif  Re: Current status for "/libra/milestones/" update site directory [message #997514 is a reply to message #997432] Mon, 07 January 2013 18:17 Go to previous message
Masahiko Sakamoto is currently offline Masahiko Sakamoto
Messages: 2
Registered: January 2013
Junior Member
Thanks to Kaloyan. I understood that "/libra/milestones/S-0.3.0xxx" is now correct directory and "S-0.2.0xxx" was deleted.
I've posted this problem as packaging problem : https://bugs.eclipse.org/bugs/show_bug.cgi?id=397495
Fixing org.eclipse.osgi configuration xml seems good.
Previous Topic:WAR Validate Null Pointer Exception
Next Topic:Libra on Juno
Goto Forum:
  


Current Time: Tue Jul 29 23:01:50 EDT 2014

Powered by FUDForum. Page generated in 0.02466 seconds