Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Tigerstripe » Blanks in package names after import
Blanks in package names after import [message #13406] Fri, 30 January 2009 09:52 Go to next message
Marc FLAUW is currently offline Marc FLAUW
Messages: 100
Registered: July 2009
Senior Member
Hello,

Still on the import of the SID from RSM.

The SID is structured in UML packages, that do include blanks.

The top package is "Logical View" , then "Common Business Entities
Domain", then "Problem ABE" in my case.

So in the java classes of Tigerstripe, the package statement becomes:
package Logical View.Common Business Entities Domain.Problem ABE;

This gives tons of errors in Tigerstripe.

This raises a few questions:

1) why the import of Tigerstripe allows blanks in packages as this is
causing errors?

2) the generatd package name "Logical View.Common Business Entities
Domain.Problem ABE" is natural for an Information Model, but seems very
strange at implementation level. It would be more natural to have
something like org.tmforum.interfaces.cbe.problem. I cannot change the
information model, but is there a way to indicate a package mapping to
have a more useful package name?

Thanks,

Marc
Re: Blanks in package names after import [message #14434 is a reply to message #13406] Mon, 02 February 2009 15:11 Go to previous message
Marc FLAUW is currently offline Marc FLAUW
Messages: 100
Registered: July 2009
Senior Member
Dear all,

I got the SID import plug-in that suppresses these blanks, but the base
import should still remove those blanks.

Best regards,

Marc
Re: Blanks in package names after import [message #564318 is a reply to message #13406] Mon, 02 February 2009 15:11 Go to previous message
Marc FLAUW is currently offline Marc FLAUW
Messages: 100
Registered: July 2009
Senior Member
Dear all,

I got the SID import plug-in that suppresses these blanks, but the base
import should still remove those blanks.

Best regards,

Marc
Previous Topic:Refactoring works only partially
Next Topic:UML Import
Goto Forum:
  


Current Time: Sun Sep 21 18:12:48 GMT 2014

Powered by FUDForum. Page generated in 0.02496 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software