Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Egit error upon install of Eclipse(Cannot set Egit to locate git in my system to use Eclipse )
icon5.gif  Egit error upon install of Eclipse [message #993957] Tue, 25 December 2012 20:54 Go to next message
Zachariah Lloyd is currently offline Zachariah Lloyd
Messages: 2
Registered: December 2012
Location: Virginia
Junior Member
I downloaded and installed Eclipse IDE for Java Developers version 1.5.1.20120920-0737, but when I open it I get this error every time,
"EGit does not require Git to function, but there may be important settings in the installation directory the EGit needs to know in order to be compatible with Git."?? There is some more written after this, but that is the crux of what is wrong....
I have tried going to a new project, and selecting Team>Share Project>Git, but what opens up I do not understand truthfully, I am completely new to Eclipse and know nothing yet really. Embarrassed
I click Create, and enter a repository folder name, but I am not sure if I am supposed to put anything in the field that asks for Path within Repository or not?? Confused
Any advice would be greatly appreciated and thanks in advance!! Surprised


Zachariah A Lloyd
Re: Egit error upon install of Eclipse [message #994065 is a reply to message #993957] Wed, 26 December 2012 04:45 Go to previous messageGo to next message
Ed Merks is currently offline Ed Merks
Messages: 25744
Registered: July 2009
Senior Member
Better to ask on the eclipse.egit forum. You're no doubt best off to
install the command line version of git so you have a fallback if
there's something you can't do in the IDE.


On 26/12/2012 2:54 AM, Zachariah Lloyd wrote:
> I downloaded and installed Eclipse IDE for Java Developers version
> 1.5.1.20120920-0737, but when I open it I get this error every time,
> "EGit does not require Git to function, but there may be important
> settings in the installation directory the EGit needs to know in order
> to be compatible with Git."?? There is some more written after this,
> but that is the crux of what is wrong....
> I have tried going to a new project, and selecting Team>Share
> Project>Git, but what opens up I do not understand truthfully, I am
> completely new to Eclipse and know nothing yet really. :blush: I click
> Create, and enter a repository folder name, but I am not sure if I am
> supposed to put anything in the field that asks for Path within
> Repository or not?? :? Any advice would be greatly appreciated and
> thanks in advance!! :o
Re: Egit error upon install of Eclipse [message #994179 is a reply to message #994065] Wed, 26 December 2012 11:24 Go to previous message
David Wegener is currently offline David Wegener
Messages: 1299
Registered: July 2009
Senior Member
This isn't an error, it is a notification message telling you that if you use git, there may be settings that the egit implementation in Eclipse interprets differently then a native git install on your system. If you don't have git installed and don't want to use git, you can ignore the message. If you use git, then you should check that the egit repository settings match what you expect on your system. I believe the settings in question regard line endings and possibly file encodings.
Previous Topic:keywords pop-upz
Next Topic:Emulsifier
Goto Forum:
  


Current Time: Fri Apr 18 04:14:16 EDT 2014

Powered by FUDForum. Page generated in 0.01774 seconds