Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Problem with the color themes
Problem with the color themes [message #993858] Tue, 25 December 2012 18:43 Go to next message
Victor De los Santos is currently offline Victor De los SantosFriend
Messages: 2
Registered: December 2012
Junior Member
So, I am having problems with the colours in the text editor of Eclipse for java. Basically, even if I restore to default colours, there are colours that don´t change. I´ve tried to redownload it several times and deleting it each time but it doesn´t want to change the colours, even if in the options appear as a different colour. Here a picture of how it looks like and how it should look like. Any idea???


I run it under Win 8.
  • Attachment: eclipse.jpg
    (Size: 242.42KB, Downloaded 80 times)
Re: Problem with the color themes [message #997410 is a reply to message #993858] Mon, 07 January 2013 10:52 Go to previous messageGo to next message
Stephane Begaudeau is currently offline Stephane BegaudeauFriend
Messages: 413
Registered: April 2010
Location: Nantes (France)
Senior Member

Hi,

The settings of your editor should be saved in the settings of your workspace (if I am not mistaken) so it would be normal to have the same setting if you try to use a new Eclipse (on the same existing workspace). If you have changed back the settings of the Java editor to the default setting, as your screenshot is suggesting it, could you go to the "General -> Editors -> Text Editors" section of the same window (the Window -> Preferences menu) to see what is the currently selected background color for your text editors.

https://lh4.googleusercontent.com/-xlB5xj9YN-I/UOqosatuzAI/AAAAAAAAM2A/BqqK64TXRIQ/s813/Text+editor+background.png

It the setting is the "System default" then what is happening in a new workspace? If it's still dark, then it must be something in the settings of Windows.

Regards,

Stephane Begaudeau, Obeo

--
Twitter: @sbegaudeau
Google+: +stephane.begaudeau
Blog: http://stephanebegaudeau.tumblr.com | Eclipse Java Development Tools Tips and Tricks



Re: Problem with the color themes [message #1002815 is a reply to message #997410] Sat, 19 January 2013 14:19 Go to previous message
Victor De los Santos is currently offline Victor De los SantosFriend
Messages: 2
Registered: December 2012
Junior Member
Even the default colors don't displayThe background is correct, the problem is that even though the colours in the setting appear to be set as something, in the editor they don't appear as so. It is pretty annoying actually. It happens in two different computers, both with Windows 8, with separate downloads of Eclipse.

Any idea please? this is very annoying, as all the code almost look the same, and having different colors is CRUCIAL. Even the default colors don't display properly. Please, some help with this. Maybe is something about win 8 but i have no idea what it can be.

Previous Topic:Eclipse Juno classic and FTP
Next Topic:Two different views of same (Epic) file
Goto Forum:
  


Current Time: Fri Nov 28 03:25:11 GMT 2014

Powered by FUDForum. Page generated in 0.01630 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software