Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Missing packages during export
Missing packages during export [message #993061] Sun, 23 December 2012 03:41 Go to next message
Axel Guckelsberger is currently offline Axel Guckelsberger
Messages: 219
Registered: July 2009
Senior Member
Hi all,

when I try to export a product I get the following error:

Processing inclusion from feature org.eclipse.e4.rcp: Bundle org.apache.felix.gogo.command_0.8.0.v201108120515 failed to resolve.:
	Unsatisfied import package org.apache.felix.bundlerepository_0.0.0.
	Unsatisfied import package org.apache.felix.bundlerepository.*_0.0.0.
	Unsatisfied import package org.apache.felix.service.command_0.8.0.


I've looked at the content section of my target definition in order to activate them, but these bundles are not available. Can you please tell me which feature I have to add to let them become part of my target platform?

Thanks in advance,
Axel
Re: Missing packages during export [message #993435 is a reply to message #993061] Mon, 24 December 2012 06:34 Go to previous messageGo to next message
Sopot Cela is currently offline Sopot Cela
Messages: 597
Registered: December 2010
Senior Member

Have you clicked Add required features? Are you using a milestone or 4.2.1?
Re: Missing packages during export [message #993448 is a reply to message #993435] Mon, 24 December 2012 07:22 Go to previous message
Axel Guckelsberger is currently offline Axel Guckelsberger
Messages: 219
Registered: July 2009
Senior Member
Sopot Cela
Are you using a milestone or 4.2.1?


Version: 4.2.1
Build id: M20120914-1800

But I doubt that the IDE version is related to what is contained in the Juno P2 repository and the target definition.

Sopot Cela
Have you clicked Add required features?

Where is that function? When I have the target definition editor open and edit the location pointing to the Juno update site I can only enable a checkbox additional required software. I've tried to enable that, but the required plug-ins (org.apache.felix.*) are still not appearing in the content tab of the target definition.

Merry Christmas!

Axel
Previous Topic:Rounded Tabs
Next Topic:e4 IDE setup error
Goto Forum:
  


Current Time: Tue Sep 02 15:18:41 EDT 2014

Powered by FUDForum. Page generated in 0.02945 seconds