Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » g++ not found in PATH (g++)
g++ not found in PATH [message #992798] Sat, 22 December 2012 17:26 Go to next message
Lee Whitfield is currently offline Lee Whitfield
Messages: 1
Registered: December 2012
Junior Member
After choosing the default "Hello World" project I am getting an ERROR g++ not found in path.

$ which g++
/usr/bin/g++

after googling I added /usr/bin/g++ to "Project -> Properties -> C/C++ Build -> Settings -> Path"

Linux Mint 13
Eclipse IDE for C/C++ Developers

Version: Juno Service Release 1
Build id: 20120920-0800

Re: g++ not found in PATH [message #994097 is a reply to message #992798] Wed, 26 December 2012 11:34 Go to previous messageGo to next message
Klaus Mr is currently offline Klaus Mr
Messages: 117
Registered: November 2011
Senior Member
Hello,

open the package manager tool and Install the G++ package (Gnu C++ compiler).

Or, in a terminal try:
sudo apt-get install g++


regards,
Klaus


Re: g++ not found in PATH [message #1043884 is a reply to message #994097] Thu, 18 April 2013 08:21 Go to previous messageGo to next message
brichun brichun is currently offline brichun brichun
Messages: 1
Registered: April 2013
Junior Member
I have the same issue and i can´t resolve it.

I can´t find neither the f**l package manager nor the Terminal in which i can type the expression.

Re: g++ not found in PATH [message #1067926 is a reply to message #1043884] Thu, 11 July 2013 09:27 Go to previous messageGo to next message
Sandy G is currently offline Sandy G
Messages: 1
Registered: July 2013
Junior Member
I also had the same problem. But the following worked for me.

Note that I have following environment:

OS:
Windows XP SP3

Eclipse:
Eclipse IDE for C/C++ Developers
Version: Kepler Release
Build id: 20130614-0229

C/C++ compiler:
MinGW GCC

Setup environment variable PATH to include "<MINGW_HOME>/bin" where <MINGW_HOME> is the MinGW installed directory that you have chosen in the previous step.

Now to install the g++ package:

1. Start > Run > cmd
2. At the command prompt, type the following
mingw-get install g++
Re: g++ not found in PATH [message #1070632 is a reply to message #992798] Thu, 18 July 2013 11:02 Go to previous messageGo to next message
David C is currently offline David C
Messages: 1
Registered: July 2013
Junior Member
This is the solution that works for me in Ubuntu Linux.eclipse-cpp-kepler-R-linux-gtk.tar.gz

1) Remove the directory of eclipse installation. For example: rm -rf eclipse
2) If g++ was not installed yet, then install it: sudo apt-get install g++
3) Reinstall the eclipse. For example: tar zxvf eclipse-cpp-kepler-R-linux-gtk.tar.gz
4) Run the eclipse for the first time with this command: ./eclipse -initialize
5) After the initialization was done, run it as normal: ./eclipse
Re: g++ not found in PATH [message #1243465 is a reply to message #1067926] Tue, 11 February 2014 02:25 Go to previous messageGo to next message
Vishnu Mising name is currently offline Vishnu Mising name
Messages: 1
Registered: February 2014
Junior Member
This did not work for me. I followed the exact steps but I still continue to get the same error.


Re: g++ not found in PATH [message #1276584 is a reply to message #1243465] Mon, 24 March 2014 19:21 Go to previous messageGo to next message
s cl is currently offline s cl
Messages: 4
Registered: March 2014
Junior Member
Hi,

this helped for me:

1. Edit the project's environments settings (Properties/ C/C++ Build / Environment). If the PATH variable doesn't appear here or is not printed boldly, then cancel that dialog and edit them in Window / Preferences / C/C++ Build / Environment).
2. Make sure your PATH variable setting contains the string ':${PATH}'. It must have the curly braces around it! If the variable is already there and isn't resolved anyway, then get its value from your operating system and replace ${PATH} with that value.

(from the GIMP developer wiki)
Re: g++ not found in PATH [message #1404394 is a reply to message #1070632] Thu, 31 July 2014 23:10 Go to previous message
Andreas Hollweck is currently offline Andreas Hollweck
Messages: 1
Registered: July 2014
Junior Member
David C wrote on Thu, 18 July 2013 07:02
This is the solution that works for me in Ubuntu Linux.eclipse-cpp-kepler-R-linux-gtk.tar.gz

1) Remove the directory of eclipse installation. For example: rm -rf eclipse
2) If g++ was not installed yet, then install it: sudo apt-get install g++
3) Reinstall the eclipse. For example: tar zxvf eclipse-cpp-kepler-R-linux-gtk.tar.gz
4) Run the eclipse for the first time with this command: ./eclipse -initialize
5) After the initialization was done, run it as normal: ./eclipse


Point number four has worked for me, I didn't even had to reinstall eclipse just ran that command. Thank you
Previous Topic:Index and AST connection
Next Topic:Eclipse Luna, MinGW-w64 -- C++11 <random>
Goto Forum:
  


Current Time: Fri Oct 31 17:18:51 GMT 2014

Powered by FUDForum. Page generated in 0.07112 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software