Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Report items from library is not shown(Report items from library is not shown)
Report items from library is not shown [message #991866] Thu, 20 December 2012 11:26 Go to next message
aca Missing name is currently offline aca Missing name
Messages: 35
Registered: March 2011
Member
Hi,
I use BIRT 2.6.2 for several reports, where the end result is in pdf:s.
As I want to reuse some of the items (for example the footer) I have created a library to store report items in.
My problem is that I can't see the actual result of inserted report items in the pdf:s.

I have created a library, and added a report item with only a static text. No data source or data set is included at the moment, although I will need it later on.
I have an existing report in which I've added the library, and I have also added the report item via the Resource Explorer tab into my report. I can see the correct text in the layout, but when I test the report the text isn't shown!

Do you have any tip of what the problem is?

I have attached the rptlibrary.

Thank you in advance!
//Aca
Re: Report items from library is not shown [message #992043 is a reply to message #991866] Thu, 20 December 2012 18:49 Go to previous messageGo to next message
Michael Williams is currently offline Michael Williams
Messages: 1595
Registered: July 2009
Senior Member

I didn't have a problem seeing the element from your library, in my report. Can you attach your report design?

Michael

Add interactivity, scheduling, sharing, live Excel export, and JS integration to your BIRT app with the new, free BIRT server, BIRT iHub F-Type.
Re: Report items from library is not shown [message #992354 is a reply to message #992043] Fri, 21 December 2012 12:30 Go to previous messageGo to next message
aca Missing name is currently offline aca Missing name
Messages: 35
Registered: March 2011
Member
I can't attach the original report, as it has several dependencies to java objects, but I have reproduced the problem in a test report which reads data from the BIRT test database. The test report is attached.

You mentioned the element in your reply which makes me wonder if we look for the text at the same place/in the same view... I have therefore attached some pictures showing the visibility/invisibility of the text element in different views.
Re: Report items from library is not shown [message #992415 is a reply to message #991866] Fri, 21 December 2012 15:32 Go to previous messageGo to next message
Michael Williams is currently offline Michael Williams
Messages: 1595
Registered: July 2009
Senior Member

Here is what I get in my outputs:

  • Attachment: ShowMe.docx
    (Size: 58.99KB, Downloaded 52 times)


Michael

Add interactivity, scheduling, sharing, live Excel export, and JS integration to your BIRT app with the new, free BIRT server, BIRT iHub F-Type.
Re: Report items from library is not shown [message #997399 is a reply to message #992415] Mon, 07 January 2013 10:19 Go to previous messageGo to next message
aca Missing name is currently offline aca Missing name
Messages: 35
Registered: March 2011
Member
Ok, I see now that we have the same view of the problem, even though you are able to get the correct viewing in every output while I am still missing it in the pdf. I'm guessing my problem has something to do with generating of the actual pdf. I will do some more testing to see if I can narrow it down more.
Thanks though for helping!
Re: Report items from library is not shown [message #997509 is a reply to message #997399] Mon, 07 January 2013 21:38 Go to previous message
Michael Williams is currently offline Michael Williams
Messages: 1595
Registered: July 2009
Senior Member

Let me know if you continue to have issues and cannot figure it out. You might try re-installing BIRT, if nothing else works.

Michael

Add interactivity, scheduling, sharing, live Excel export, and JS integration to your BIRT app with the new, free BIRT server, BIRT iHub F-Type.
Previous Topic:Line height property not working in pdf with value under 4mm
Next Topic:set dataset parameters in runtime
Goto Forum:
  


Current Time: Thu Sep 18 21:52:31 GMT 2014

Powered by FUDForum. Page generated in 0.02690 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software