Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Debugger won't stop at breakpoints
Debugger won't stop at breakpoints [message #991751] Thu, 20 December 2012 00:36 Go to next message
Stormey legend is currently offline Stormey legend
Messages: 8
Registered: December 2012
Junior Member
Hi guys.

im trying to make the dubbuger stop at a specific breakpoints.
i set a breakpoint (by clicking on the left panel and marking the line with a blue dot), hit debug, and the debugger starts debugging from the first line, instead of running the program and stopping at the breakpoint.

how can i make it run the program and start debugging at a specific line?
im using:
Eclipse IDE for C/C++ Developers

Version: Juno Service Release 1
Build id: 20120920-0800

Thanks in advanced!

originally posted here.
Re: Debugger won't stop at breakpoints [message #991935 is a reply to message #991751] Thu, 20 December 2012 09:03 Go to previous messageGo to next message
Marc Khouzam is currently offline Marc Khouzam
Messages: 274
Registered: July 2009
Senior Member
The original answer you got was correct.
http://www.eclipse.org/forums/index.php/mv/msg/441590/991159/#msg_991159

Got to Run->Debug configurations... and select your launch.
Got to the Debugger sub-tab, and at the top you will see "Stop at startup at:"

Marc
Re: Debugger won't stop at breakpoints [message #991945 is a reply to message #991935] Thu, 20 December 2012 09:22 Go to previous message
Marc Khouzam is currently offline Marc Khouzam
Messages: 274
Registered: July 2009
Senior Member
I added an entry in the FAQ for this question:
http://wiki.eclipse.org/CDT/User/FAQ#How_do_I_prevent_the_debugger_from_stopping_on_the_first_line.3F
Previous Topic:code syntax formatter no indent after __init
Next Topic:GDB (DSF) Manual Remote Launch - execute commands before launch?
Goto Forum:
  


Current Time: Wed Aug 20 01:11:27 EDT 2014

Powered by FUDForum. Page generated in 0.17472 seconds