Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Cannot deploy extended codan.checkers plug-in(Custom codan.checkers plug-in installation issue)
Cannot deploy extended codan.checkers plug-in [message #991238] Tue, 18 December 2012 00:01 Go to next message
Tamas Kleiber is currently offline Tamas KleiberFriend
Messages: 20
Registered: December 2010
Junior Member
Hello,

I have implemented a new checker within the org.eclipse.cdt.codan.checkers plug-in project. The new checker is working perfectly, at least according to my needs, within my eclipse PDE IDE setup. I can execute and debug this custom codan.checkers plug-in and everything.

Most unfortunately when I export the org.eclipse.cdt.codan.checkers plug-in with the Deployable plug-ins and fragments option as Directory or as Archive file the resulting jar file or directory cannot be installed into another eclipse distribution. I have tried a lot of things without success. The only export which actually worked is the Install into host. Repository: option. But that is not a feasible solution.

The plug-in is not a feature so I think I cannot export it with the Deployable features option.
I tried to install the exported jar file by placing it into the targeted eclipse distribution's root/plugins or root/dropins folders. If eclipse is started with "eclipse -clean -console -consoleLog -debug .options" from the command prompt I get the following log messages when the jar file was in the dropins folder:

Install location:
    file:/o:/dev/baseline/eclipse/
Configuration file:
    file:/o:/dev/baseline/eclipse/configuration/config.ini loaded
Configuration location:
    file:/o:/dev/baseline/eclipse/configuration/
Framework located:
    file:/o:/dev/baseline/eclipse/plugins/org.eclipse.osgi_3.8.1.v20120830-144521.jar
Framework classpath:
    file:/o:/dev/baseline/eclipse/plugins/org.eclipse.osgi_3.8.1.v20120830-144521.jar
Splash location:
    O:\dev\baseline\eclipse\\plugins\org.eclipse.platform_4.2.1.v201209141800\splash.bmp
Debug options:
    file:/o:/dev/baseline/eclipse/.options loaded
Time to load bundles: 24
[p2] Mon Dec 17 23:51:56 CET 2012 - [Start Level Event Dispatcher] [reconciler]
Cached timestamp file empty.
[p2] Mon Dec 17 23:51:56 CET 2012 - [Start Level Event Dispatcher] [reconciler]
Performing reconciliation.
[p2] Mon Dec 17 23:51:57 CET 2012 - [Start Level Event Dispatcher] [reconciler]
[dropins] Interesting feature or bundle added: O:\dev\baseline\eclipse\dropins\org.eclipse.cdt.codan.checkers_1.1.0.201212172336.jar
[p2] Mon Dec 17 23:51:58 CET 2012 - [Start Level Event Dispatcher] [reconciler]
Timestamp file does not exist.
[p2] Mon Dec 17 23:51:58 CET 2012 - [Start Level Event Dispatcher] [reconciler]
Performing reconciliation.
[p2] Mon Dec 17 23:51:58 CET 2012 - [Start Level Event Dispatcher] [reconciler]
Profile timestamp not found in cache.
[p2] Mon Dec 17 23:51:58 CET 2012 - [Start Level Event Dispatcher] [reconciler]
Performing reconciliation.
[p2] Mon Dec 17 23:51:58 CET 2012 - [Start Level Event Dispatcher] [reconciler]
Adding IU: org.eclipse.cdt.codan.checkers 1.1.0.201212172336
[p2] Mon Dec 17 23:51:58 CET 2012 - [Start Level Event Dispatcher] [reconciler]
Adding IU property: org.eclipse.cdt.codan.checkers 1.1.0.201212172336->{org.eclipse.equinox.p2.type.lock=1, org.eclipse.equinox.p2.internal.inclusion.rules=OPTIONAL, org.eclipse.equinox.p2.reconciler.dropins=true}
[p2] Mon Dec 17 23:51:58 CET 2012 - [Start Level Event Dispatcher] [reconciler]
No installable units to remove.
[p2] Mon Dec 17 23:51:58 CET 2012 - [Start Level Event Dispatcher] [reconciler]
No IU properties to remove.
[p2] Mon Dec 17 23:51:58 CET 2012 - [Start Level Event Dispatcher] [reconciler]
No installable units to move.
[p2] Mon Dec 17 23:51:58 CET 2012 - [Start Level Event Dispatcher] [reconciler]
No extra requirements.
[p2] Mon Dec 17 23:51:58 CET 2012 - [Start Level Event Dispatcher] [reconciler]
[plan] Some units will not be installed, because they are already installed or there are dependency issues:
[p2] Mon Dec 17 23:51:58 CET 2012 - [Start Level Event Dispatcher] [reconciler]
[plan] org.eclipse.cdt.codan.checkers 1.1.0.201212172336
[p2] Mon Dec 17 23:51:59 CET 2012 - [Start Level Event Dispatcher] [reconciler]



So according to the logs, my updated plug-in has the following issue: "Some units will not be installed, because they are already installed or there are dependency issues". But plug-ins cannot be uninstalled in eclipse and even if I exported the plug-in with all dependencies re-exported the installation failed the same way. So it seems to me that I cannot do anything against this error message... probably the fact that this checkers plug-in is a singleton has something to do with this already installed error but what can I do against it?

If I export the checkers project itself and import it to another eclipse PDE IDE setup where I do not have any other projects in the workspace except for the org.eclipse.cdt.codan.checkers plug-in I could still execute and debug the plug-in so there are possibly no unresolvable dependencies as the two PDE IDEs are the same.

I also tried to increment the version number of the project to differ from the already installed version with no success. I also tried to create an Update site project but again it turned out that only Features can be added to it, simple plug-ins are not accepted.


I am using eclipse 4.2.1 (Build id: M20120914-1800) with CDT 8.1.1.201209170703.
My CDT baseline is cloned from git repository branch cdt_8_1. The original checkers plug-in version is this: org.eclipse.cdt.codan.checkers_1.1.0.201209170703.jar

I have attached the modified org.eclipse.cdt.codan.checkers project to this forum entry for further reference.


Could somebody help me find a workaround or solution for this issue? What else could I try to get more details on the source of the problem?

Is it possible to force an update to my jar file using eclipse's osgi command prompt?

I tried to perform the update command but could not figure out what parameters the interface required :/

Did anybody else experienced same or similar issues?
Re: Cannot deploy extended codan.checkers plug-in [message #991261 is a reply to message #991238] Tue, 18 December 2012 07:58 Go to previous message
Tamas Kleiber is currently offline Tamas KleiberFriend
Messages: 20
Registered: December 2010
Junior Member
I solved the issue by creating a new plug-in project for my own checkers. But nevertheless if there is a solution to the above problem I would like to know it.

Thank you in advance for your kind support.
Previous Topic:undesirable includes
Next Topic:[Juno] No automatic Error clear in Error Recourse
Goto Forum:
  


Current Time: Thu Nov 27 23:43:55 GMT 2014

Powered by FUDForum. Page generated in 0.02895 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software