Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » SDM Error 127 Starting Parallel Debugger
SDM Error 127 Starting Parallel Debugger [message #990967] Sat, 15 December 2012 17:12 Go to next message
Corey Henderson is currently offline Corey HendersonFriend
Messages: 2
Registered: December 2012
Junior Member
Hello,

I am new to OpenMPI in PTP and Eclipse, so bear with me if I'm not providing enough information please.

I am trying to debug in parallel an OpenMPI application I am writing in C in Eclipse.

Linux version: Ubuntu 12.04.1 LTS (64-bit)
Eclipse version: Version: 3.7.2 Build id: I20110613-1736
PTP version: 5.0.5.201202152003
SDM version: 4.0.6.201102161000
OpenMPI version: 1.4.5

I have compiled (sh BUILD) the "fragment" for SDM in the Linux directory here:
plugins/org.eclipse.ptp.linux.x86_64_4.0.6.201102161000/bin/sdm

I have created the OpenMPI Resource manager in the Parallel Runtime perspective and it starts properly. I can 'run' my compiled application and it appears to work with my desired number of processes (5).

I have created the Debug Configuration in the Parallel Debug perspective and pointed it at the SDM binary. Everything I'm trying to do at this point is local.

When I try to debug, I get a pop-up saying "Writing Routing File" and about 3 seconds later an error "sdm master process finished with exit code 127."

The pop-up remains on the screen indefinitely. When I cancel it I get another error message saying "Error completing debug job launch" and "Cannot connect to debugger".

In the Parallel Debug console I then see this:

<stderr>--------------------------------------------------------------------------
</stderr>
<stderr>Could not execute the executable "/usr/lib/eclipse/plugins/org.eclipse.ptp.linux.x86_64_4.0.6.201102161000/bin": Permission denied
</stderr>
<stderr>
</stderr>
<stderr>This could mean that your PATH or executable name is wrong, or that you do not
</stderr>
<stderr>have the necessary permissions. Please ensure that the executable is able to be
</stderr>
<stderr>found and executed.
</stderr>
<stderr>
</stderr>
<stderr>--------------------------------------------------------------------------
</stderr>

Which is repeated four times.

When I browse to the SDM executable on disk, the "execute bit" seems to be set correctly.

I have Googled the SDM error 127 with no results. I can't find a list of error codes for SDM anywhere.

I do not know how to fix this permission problem. Can someone please offer suggestions?

Thank you!

Corey

(No... really... I'm very new to this, so if this is a dumb mistake I won't be surprised. I'm trying to learn.)
Re: SDM Error 127 Starting Parallel Debugger [message #991524 is a reply to message #990967] Wed, 19 December 2012 16:37 Go to previous message
Corey Henderson is currently offline Corey HendersonFriend
Messages: 2
Registered: December 2012
Junior Member
Well, over 1000 views but no replies. Either everyone saw my mistake or I'm really in never-never land.

Anyway... to be complete I thought I'd post and share that I found my error.

The path in my Debug Configuration was wrong. I had pasted in the path to the SDM fragment's bin directory, but didn't notice that it wasn't complete. I needed to have the path be to the actual sdm executable.

When I corrected this everything worked.

Still not sure how I can look up the error codes from SDM, but if anyone Googles 127 now maybe they'll see this post.

Cheers!

[Updated on: Wed, 19 December 2012 16:38]

Report message to a moderator

Previous Topic:[Juno] No automatic Error clear in Error Recourse
Next Topic:Eclipe/GDB disable breakpoint after enable
Goto Forum:
  


Current Time: Thu Nov 27 16:40:22 GMT 2014

Powered by FUDForum. Page generated in 0.08392 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software