Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Target Management » Remote Shell Commands Not Executing(Pressing [Enter] does not execute commands)
Remote Shell Commands Not Executing [message #990904] Fri, 14 December 2012 13:57 Go to next message
Peter McCann is currently offline Peter McCann
Messages: 2
Registered: December 2012
Junior Member
Hi,

I can open a Remote Shell to both local and remote targets.
However, I cannot execute commands. I can type the command,
but when I press [Enter], the focus shifts to output window
and nothing happens.


My installation is Eclipse Juno SR1 (build ID 20121004-1855)
running on Windows 7 with the following additional packages:

Eclipse IDE for Java Developers
1.5.1.20121004-1506
epp.package.java

Remote System Explorer End-User Runtime
3.4.1.201209191030-7L7IFBY83omx__z0RFpKdWB-r5MS
org.eclipse.rse.feature.group
Eclipse TM Project

Remote System Explorer User Actions
1.1.400.201209191030-31FBV773573L5L5393
org.eclipse.rse.useractions.feature.group
Eclipse TM Project

Any idea what I'm doing wrong? Any way I can debug what the
problem is?

-Pete
Re: Remote Shell Commands Not Executing [message #991058 is a reply to message #990904] Mon, 17 December 2012 03:53 Go to previous messageGo to next message
Martin Oberhuber is currently offline Martin Oberhuber
Messages: 982
Registered: July 2009
Senior Member
What connection type are you using ?
- If using SSH, please try the Terminals subsystem rather than remote shell.
Re: Remote Shell Commands Not Executing [message #991144 is a reply to message #991058] Mon, 17 December 2012 08:51 Go to previous messageGo to next message
Peter McCann is currently offline Peter McCann
Messages: 2
Registered: December 2012
Junior Member
The problem happens when I am using a Local Shell or a
Dstore connection to a remote machine. I have not used
the SSH connection type yet.

-Pete
Re: Remote Shell Commands Not Executing [message #991175 is a reply to message #991144] Mon, 17 December 2012 10:34 Go to previous message
David McKnight is currently offline David McKnight
Messages: 244
Registered: July 2009
Senior Member
I think in the most recent builds of Eclipse, the key events have changed.
It used to be that up key events would contain the "enter" key but now it
seems to have changed to the down key events.

I've opened the following bugzilla for this:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=396766


"Peter McCann" <forums-noreply@xxxxxxxx> wrote in message
news:kan813$rsg$1@xxxxxxxxe.org...
> The problem happens when I am using a Local Shell or a
> Dstore connection to a remote machine. I have not used
> the SSH connection type yet.
>
> -Pete
>
Previous Topic:Analyzing core dumps
Next Topic:locally updated image file not updated on remote site
Goto Forum:
  


Current Time: Tue Jul 29 04:41:31 EDT 2014

Powered by FUDForum. Page generated in 0.02454 seconds