Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Object remapping following a change in the GUI (HTML-AUT)(Is there an easy and effective way to remap a lot of objects in a test project?)
Object remapping following a change in the GUI (HTML-AUT) [message #990578] Thu, 13 December 2012 04:36 Go to next message
Thomas Schreckenbach is currently offline Thomas Schreckenbach
Messages: 5
Registered: September 2012
Junior Member
We are using Jubula to test HTML AUTs (web application).

Problem
A developer has changed a central GUI template. This template is part of more or less all pages of the web application.
As a consequence, approximately 2/3 of the object mappings in our Jubula test project for this application are no longer correct. See screenshots - object mapping before / after.
before: index.php/fa/12692/0/ and after: index.php/fa/12693/0/

Solutions
Manual reassignment ==> slow, error-prone.

Question
Is there a quick and effective (elegant) way to map the new objects?

Ideas?
* Find / replace in a previously exported XML file?
* Using regular expressions / XPath expressions would make object mapping more independent of such GUI changes (as described above)...

[Updated on: Thu, 13 December 2012 04:36]

Report message to a moderator

Re: Object remapping following a change in the GUI (HTML-AUT) [message #990820 is a reply to message #990578] Fri, 14 December 2012 05:57 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1052
Registered: July 2009
Senior Member
Hi,

At the moment, there is no other way to map components than to do it manually I'm afraid. I certainly wouldn't recommend making changes in the XML file. It is, however, possible to name components using a tag that is declared in the AUT configuration. Do you use that already?

Best regards,
Alex
Re: Object remapping following a change in the GUI (HTML-AUT) [message #990991 is a reply to message #990820] Sun, 16 December 2012 08:22 Go to previous message
Thomas Schreckenbach is currently offline Thomas Schreckenbach
Messages: 5
Registered: September 2012
Junior Member
Hi!

Thanks for the answer.

We do not use the option to set an "id attribute name" in the AUT configuration. Because - only a single argument is possible. Therefore, we didi not see a practical use... And on the web, there is, unfortunately, no example for this parameter.
Previous Topic:Install Jubula via update site Eclipse 3.7 (Indigo) problem
Next Topic:Event handler does not refresh retry count
Goto Forum:
  


Current Time: Thu Apr 17 00:05:46 EDT 2014

Powered by FUDForum. Page generated in 0.01625 seconds