Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » P2 » Building Update Site Problem(Can't successfully build an update site anymore)
Building Update Site Problem [message #990555] Thu, 13 December 2012 06:45
Phillip Drew is currently offline Phillip DrewFriend
Messages: 77
Registered: October 2012
Member
So when I try and build my update site I get the following error

C:\Users\phillip\Documents\MOUSEWHEEL\Workspace\.metadata\.plugins\org.eclipse.pde.core\temp\org.eclipse.pde.container.feature\assemble.org.eclipse.pde.container.feature.group.group.group.xml:88: The following error occurred while executing this line:
C:\Users\phillip\Documents\MOUSEWHEEL\Workspace\.metadata\.plugins\org.eclipse.pde.core\temp\org.eclipse.pde.container.feature\assemble.org.eclipse.pde.container.feature.group.group.group.xml:179: Messages while mirroring artifact descriptors.
An error occurred copying file C:\Users\phillip\Documents\MOUSEWHEEL\Workspace\.metadata\.plugins\org.eclipse.pde.core\tempp2metadata\plugins\com.themousewheel.sandbox.jet2.multistage_1.0.0.201212131601.jar.
The following error occurred while executing this line:
C:\Users\phillip\Documents\MOUSEWHEEL\Workspace\.metadata\.plugins\org.eclipse.pde.core\temp\org.eclipse.pde.container.feature\assemble.org.eclipse.pde.container.feature.group.group.group.xml:179: Messages while mirroring artifact descriptors.
An error occurred copying file C:\Users\phillip\Documents\MOUSEWHEEL\Workspace\.metadata\.plugins\org.eclipse.pde.core\tempp2metadata\plugins\com.themousewheel.sandbox.jet2.multistage_1.0.0.201212131601.jar.


and it appears to be because it's trying to copy .jar files that aren't being generated any more because the qualifier has moved on. When I check in the mentioned directory there is a .jar file with a different qualifier. The context.xml references multiple .jar files with different qualifiers none of which are still being generated (but I'm not sure if that's the problem).

I've tried deleting the tempp2metadata directory but it just recreates it incorrectly again. I can't figure out how to stop it trying to copy the old jar files!

I can't find anywhere that they're still referenced and I have no idea where to look to find them.

Need any help I can get - it's driving me up the wall.
Previous Topic:The copies of profile epp.package.jee are not in sync.
Next Topic:How to clean unused plugins from shared bundle pool
Goto Forum:
  


Current Time: Thu Nov 27 01:51:11 GMT 2014

Powered by FUDForum. Page generated in 0.02999 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software