Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » Egit well installed, but no GIT menu(I can't use EGit whatever I want to do (no team, no preferences item))
Egit well installed, but no GIT menu [message #990171] Tue, 11 December 2012 09:37 Go to next message
GWENN BOURREE is currently offline GWENN BOURREE
Messages: 4
Registered: December 2012
Junior Member
Hi All,

I would like to use EGit in my project configuration management.
I am currently using the GIT command line interface, but I am sure I will be more efficient by using this plugin.

In Eclipse, the Egit plugin seems to be well installed (according to the Eclipse diagnostic), but whatever the menu I select to configure Egit or my project to be managed with Egit, I can't find any EGit menu item.
In Project/Team/Share project: Only CVS is present
In Project/Import: Only CVS is possible
In Preferences, in Team synchronizing menus, always CVS and no GIT.

Could you help me, please ?

Gwenn
Re: Egit well installed, but no GIT menu [message #990277 is a reply to message #990171] Tue, 11 December 2012 17:03 Go to previous messageGo to next message
Matthias Sohn is currently offline Matthias Sohn
Messages: 588
Registered: July 2009
Senior Member
Click "About Eclipse > Installation Details > Plug-ins" and check if the jgit and egit bundles are installed,
you should have at least:

org.eclipse.egit
org.eclipse.egit.core
org.eclipse.egit.ui
org.eclipse.jgit

all these plugins should come from the same release.

Also you may check the error log for errors mentioning egit or jgit.
Re: Egit well installed, but no GIT menu [message #990562 is a reply to message #990277] Thu, 13 December 2012 07:58 Go to previous messageGo to next message
GWENN BOURREE is currently offline GWENN BOURREE
Messages: 4
Registered: December 2012
Junior Member
Hi Matthias

I have checked what you mentioned and all are ok (I didn't installed the JGit, because I don't use Java.)
The version is
Eclipse EGit 2.1.0.201209190230-r org.eclipse.egit.feature.group Eclipse EGit

For the error logs, where I can get them ?

Gwenn
Re: Egit well installed, but no GIT menu [message #990565 is a reply to message #990562] Thu, 13 December 2012 08:28 Go to previous messageGo to next message
Matthias Sohn is currently offline Matthias Sohn
Messages: 588
Registered: July 2009
Senior Member
EGit can't work without JGit, JGit is a Java library implementing git and EGit is using that to provide a UI and integrate it with the Eclipse Team framework.
Re: Egit well installed, but no GIT menu [message #990762 is a reply to message #990565] Fri, 14 December 2012 07:42 Go to previous messageGo to next message
GWENN BOURREE is currently offline GWENN BOURREE
Messages: 4
Registered: December 2012
Junior Member
Hi,

Same behavior: I can't see any EGit menu whereever they could be

Gwenn
Re: Egit well installed, but no GIT menu [message #992261 is a reply to message #990762] Fri, 21 December 2012 08:28 Go to previous message
GWENN BOURREE is currently offline GWENN BOURREE
Messages: 4
Registered: December 2012
Junior Member
Hi Every body!

After an update request for Egit and a new installation of these plugins, all works fine.

Thanks for your support
Regards
Gwenn
Previous Topic:How to untrack already tracked files
Next Topic:Delete Added Line fails to delete LF at end of file
Goto Forum:
  


Current Time: Thu Oct 23 22:09:11 GMT 2014

Powered by FUDForum. Page generated in 0.02095 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software