Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » ATL » missing metdamodel
missing metdamodel [message #989457] Thu, 06 December 2012 10:03 Go to next message
Taimo Maier is currently offline Taimo Maier
Messages: 14
Registered: October 2012
Junior Member
Hello everybody,

I'm very new to the topic ATL and so I have a more or less basic problem.
I try to run the standard ATL example but I'm just getting a error. I imported the example over New -> Example -> ATL -> public to private. When I try to run the example I get the following error:
Error loading http://www.eclipse.org/uml2/2.1.0/UML: java.io.FileNotFoundException: http://www.eclipse.org/uml2/2.1.0/UML

It's clear. When I go to "Run Configurations..." is the link "http://www.eclipse.org/uml2/2.1.0/UML" listed as Metamodel: "uri:http://www.eclipse.org/uml2/2.1.0/UML". When I try to open the link manually in the browser the url is dead so it's clear that eclipse can't download the metamodel.

What do I have to specify as a metamodel that the example works?

Thanks a lot
Re: missing metdamodel [message #989494 is a reply to message #989457] Thu, 06 December 2012 13:36 Go to previous messageGo to next message
Hugo Bruneliere is currently offline Hugo Bruneliere
Messages: 607
Registered: July 2009
Senior Member
Hello,

Are you sure to also have the Eclipse MDT-UML2 project installed?
This project provides the UML2 metamodel implementation that is automatically loaded into the EMF registry, and thus can be called by the ATL transformation runner.

Anyway "http://www.eclipse.org/uml2/2.1.0/UML" is not an actual URL, it is the URI used by EMF to identify the UML2 metamodel as loaded into its registry.

Best regards,

Hugo


------------------------------------------
Hugo Bruneliere - R&D Engineer
AtlanMod research team (Inria, EMN & LINA)
Ecole des Mines de Nantes
Nantes - France
------------------------------------------
Re: missing metdamodel [message #990280 is a reply to message #989494] Tue, 11 December 2012 17:12 Go to previous message
Taimo Maier is currently offline Taimo Maier
Messages: 14
Registered: October 2012
Junior Member
Thanks that helped just follow this and install the MDT:
http://wiki.eclipse.org/MDT/UML2/Getting_Started_with_UML2
Previous Topic:[ATL] Containment references cannot span across models
Next Topic:Applying Stereotypes
Goto Forum:
  


Current Time: Thu Oct 23 06:00:52 GMT 2014

Powered by FUDForum. Page generated in 0.06100 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software