Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGL Development Tools » IDE crashes with EXCEPTION_ACCESS_VIOLATION(0.8.1 IDE crashes when opening EGL Rich UI editor)
IDE crashes with EXCEPTION_ACCESS_VIOLATION [message #989047] Tue, 04 December 2012 12:40 Go to next message
Kendall Coolidge is currently offline Kendall Coolidge
Messages: 6
Registered: December 2012
Junior Member
I've just downloaded and installed the 0.8.1 release onto my XP laptop and pulled in the HelloWorld sample.

When I try to open the HelloWorldView.egl file using the EGL Rich UI editor the IDE vanishes. The EGL editor opens fine.

Attached is the log that is generated.

Thanks,
Kendall

Re: IDE crashes with EXCEPTION_ACCESS_VIOLATION [message #989092 is a reply to message #989047] Tue, 04 December 2012 15:20 Go to previous messageGo to next message
Brian Svihovec is currently offline Brian Svihovec
Messages: 55
Registered: July 2009
Member
Kendall,

Can you try an Oracle 1.6 JRE? The 1.7 JRE is 'expected to work' according to our supported platforms page (http://wiki.eclipse.org/EDT:Supported_Platforms), but I believe we have found known issues with 1.7 in the past.

-Brian
Re: IDE crashes with EXCEPTION_ACCESS_VIOLATION [message #989096 is a reply to message #989092] Tue, 04 December 2012 15:25 Go to previous messageGo to next message
Kendall Coolidge is currently offline Kendall Coolidge
Messages: 6
Registered: December 2012
Junior Member
Hi Brian,

How would I do that? Change my JAVA_HOME environment variable?

Thanks,
Kendall
Re: IDE crashes with EXCEPTION_ACCESS_VIOLATION [message #989124 is a reply to message #989096] Tue, 04 December 2012 17:28 Go to previous messageGo to next message
Brian Svihovec is currently offline Brian Svihovec
Messages: 55
Registered: July 2009
Member
Kendall,

You can specify a specific JRE for your Eclipse installation using the Eclipse.ini file - http://wiki.eclipse.org/Eclipse.ini

-Brian
Re: IDE crashes with EXCEPTION_ACCESS_VIOLATION [message #989257 is a reply to message #989124] Wed, 05 December 2012 11:33 Go to previous messageGo to next message
Kendall Coolidge is currently offline Kendall Coolidge
Messages: 6
Registered: December 2012
Junior Member
Hi Brian,

I was able to switch to Java 1.6, but still getting the same error:

#
# An unexpected error has been detected by Java Runtime Environment:
#
# EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x5992719a, pid=4240, tid=5636
#
# Java VM: Java HotSpot(TM) Client VM (10.0-b23 mixed mode windows-x86)
# Problematic frame:
# C [WebKit.dll+0x7c719a]


Kendall
Re: IDE crashes with EXCEPTION_ACCESS_VIOLATION [message #989304 is a reply to message #989257] Wed, 05 December 2012 15:05 Go to previous messageGo to next message
Brian Svihovec is currently offline Brian Svihovec
Messages: 55
Registered: July 2009
Member
Kendall,

I see that the message mentions WebKit. What version of Safari are you using?

-Brian
Re: IDE crashes with EXCEPTION_ACCESS_VIOLATION [message #989470 is a reply to message #989304] Thu, 06 December 2012 10:58 Go to previous messageGo to next message
Kendall Coolidge is currently offline Kendall Coolidge
Messages: 6
Registered: December 2012
Junior Member
Using Safari 5.1.7, iTunes 11.0.0.163 and QuickTime 7.7.3
Re: IDE crashes with EXCEPTION_ACCESS_VIOLATION [message #989750 is a reply to message #989470] Fri, 07 December 2012 14:47 Go to previous messageGo to next message
Matt Heitz is currently offline Matt Heitz
Messages: 36
Registered: July 2009
Member
I have XP, Safari 5.1.7 and QuickTime 7.7.3 (iTunes isn't installed). The same thing happens to me with both JREs.
Re: IDE crashes with EXCEPTION_ACCESS_VIOLATION [message #989784 is a reply to message #989750] Fri, 07 December 2012 18:27 Go to previous messageGo to next message
Matt Heitz is currently offline Matt Heitz
Messages: 36
Registered: July 2009
Member
I've been unable to find a solution so far. I uninstalled Safari and the problem didn't go away. I installed an older version of Safari. That didn't help either.

On my machine, WebKit.dll is in C:\Program Files\Common Files\Apple\Apple Application Support\, and it was not removed or updated when I uninstalled and reinstalled Safari.
Re: IDE crashes with EXCEPTION_ACCESS_VIOLATION [message #989786 is a reply to message #989784] Fri, 07 December 2012 18:47 Go to previous messageGo to next message
Kendall Coolidge is currently offline Kendall Coolidge
Messages: 6
Registered: December 2012
Junior Member
Thanks guys for working so hard on this. FWIW, on my Win7 64-bit machine everything works fine - no Apple products installed.

Kendall
Re: IDE crashes with EXCEPTION_ACCESS_VIOLATION [message #989912 is a reply to message #989786] Mon, 10 December 2012 00:03 Go to previous messageGo to next message
Daniel Beauregard is currently offline Daniel Beauregard
Messages: 1
Registered: December 2012
Junior Member
I'm having the same problem as Kendall. I was running iTunes 10, now I have iTunes 11 installed which didn't change my problem. I've set Eclipse.ini to load JRE 1.6 and added "C:\Program Files\Safari\Apple Application Support\" to the front of the system path and Eclipse still loads the webkit.dll from the iTunes installation page instead of Safari's.

I found this bug and it seems like the problem we're having.
https://bugs.eclipse.org/bugs/show_bug.cgi?id=388469

At the end of the posts, Kelly Wilkerson says to, "Make sure you are using the latest SWT jars..." Any idea how I would verify I'm running the latest and where I would fine them?

Thanks,
Daniel
Re: IDE crashes with EXCEPTION_ACCESS_VIOLATION [message #990006 is a reply to message #989912] Mon, 10 December 2012 12:50 Go to previous messageGo to next message
Matt Heitz is currently offline Matt Heitz
Messages: 36
Registered: July 2009
Member
Daniel,

Kelly put a link to bug 375830 next to the "latest SWT jars" comment. The bug is fixed in 3.8 M7, so I think that's what Kelly meant. (I don't know if we've ever tried running EDT on 3.8.)

-Matt
Re: IDE crashes with EXCEPTION_ACCESS_VIOLATION [message #991333 is a reply to message #990006] Tue, 18 December 2012 14:43 Go to previous messageGo to next message
Matt Heitz is currently offline Matt Heitz
Messages: 36
Registered: July 2009
Member
By the way, we opened a bug for this problem: https://bugs.eclipse.org/bugs/show_bug.cgi?id=396721
Re: IDE crashes with EXCEPTION_ACCESS_VIOLATION [message #994781 is a reply to message #991333] Fri, 28 December 2012 08:49 Go to previous message
fahua jin is currently offline fahua jin
Messages: 58
Registered: July 2011
Member
It seems a different problem with bug described in https://bugs.eclipse.org/bugs/show_bug.cgi?id=396721. Anyway, you might use the the workaround described in wiki page http://wiki.eclipse.org/EDT:SettingUpForMobile - 'How to resolve the problem "Internal Error. No more handlers" - Safari must be installed to use a SWT.WEBKIT -style Browser'.
Previous Topic:Mobile Safari Problem
Next Topic:PREREQUISITE to run EGL
Goto Forum:
  


Current Time: Wed Sep 24 02:32:16 GMT 2014

Powered by FUDForum. Page generated in 0.02514 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software