Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » setconfig.bat needs JRE that supports JAXP(which jre should I be specifying in this config setup for TPTP)
setconfig.bat needs JRE that supports JAXP [message #988825] Mon, 03 December 2012 06:00 Go to next message
James Noble is currently offline James Noble
Messages: 6
Registered: December 2012
Junior Member
Hi

I am trying to connect my RPT controller to an agent. I know I need to run the setconfig.bat file on the AGENT machines first.

However when I run the file, is errors initially saying, no java in the PATH. So I give it path and then it tells me the JAVA version doesn't support JAXP.

I am using java 1.7.0_09-B05.

I am completely beaten by this now.

I have checked that ports 10002, 10003 and 10005 are open on the firwall and they are. I say this because the ultimate aim is of course to connect to the agent from the main Tool, which is how I ended up here.

Any help, very welcome.

Re: setconfig.bat needs JRE that supports JAXP [message #988867 is a reply to message #988825] Mon, 03 December 2012 08:55 Go to previous messageGo to next message
Torsten Stolpmann is currently offline Torsten Stolpmann
Messages: 37
Registered: July 2009
Member
The error message is correct, you need a JRE that is contained in a J2SE distribution, see also: http://wiki.eclipse.org/Hybrid_TPTP_scenario

Hope this helps,

Torsten
Re: setconfig.bat needs JRE that supports JAXP [message #988870 is a reply to message #988867] Mon, 03 December 2012 09:03 Go to previous messageGo to next message
James Noble is currently offline James Noble
Messages: 6
Registered: December 2012
Junior Member
HI

Thank you very much indeed for coming back to me. Need to completely understand your answer. I am not very java-savvy I am sorry to say.

So, do I need to get specifically a J2SE? Is that a package in its own right? E.g. can I search for that?
Re: setconfig.bat needs JRE that supports JAXP [message #988871 is a reply to message #988870] Mon, 03 December 2012 09:08 Go to previous messageGo to next message
Torsten Stolpmann is currently offline Torsten Stolpmann
Messages: 37
Registered: July 2009
Member
Yes you need another download as your version of the JRE does not contain the JAXP package.

Please refer to http://www.oracle.com/technetwork/java/javase/downloads/index.html for downloads.
Re: setconfig.bat needs JRE that supports JAXP [message #988872 is a reply to message #988867] Mon, 03 December 2012 09:09 Go to previous messageGo to next message
James Noble is currently offline James Noble
Messages: 6
Registered: December 2012
Junior Member
I guess my last was stupid...

I searched for J2SE and found a 1.4 version. I am going to try with this.

When I have insgtalled it, I then need to edit setconfig.bat to inlude the file path to the directory Java2E just installed (specifically the bin directory?)

Thanks so much again.
Re: setconfig.bat needs JRE that supports JAXP [message #988877 is a reply to message #988870] Mon, 03 December 2012 09:17 Go to previous messageGo to next message
James Noble is currently offline James Noble
Messages: 6
Registered: December 2012
Junior Member
I had JRE 7 on the box originally, which according to the link you gave me, should include XML JAXP - does that make any sense at all?
Re: setconfig.bat needs JRE that supports JAXP [message #988879 is a reply to message #988877] Mon, 03 December 2012 09:23 Go to previous messageGo to next message
Torsten Stolpmann is currently offline Torsten Stolpmann
Messages: 37
Registered: July 2009
Member
The windows default distribution JRE7 does not include JAXP, the one contained in the J2SDK packages does.

You probably want to use a more recent version of Java (1.6) and set your windows PATH variable to include the bin folder of your J2SE package.

Please make sure that Agent-Controller and Java Memory model matches (32 vs 64 bit).

You find detailed installation instructions here: http://dev.eclipse.org/viewcvs/viewvc.cgi/platform/org.eclipse.tptp.platform.agentcontroller/src-native-new/packaging_md/windows/getting_started.html?root=TPTP_Project&view=co
Re: setconfig.bat needs JRE that supports JAXP [message #988902 is a reply to message #988872] Mon, 03 December 2012 11:13 Go to previous messageGo to next message
Heiner Westphal is currently offline Heiner Westphal
Messages: 18
Registered: July 2009
Junior Member
Hello James,

J2SE 1.4 is too old, to run most modern java applications.

I know TPTP works well with Java 6 JDK as oracle provides it.

<http://www.oracle.com/technetwork/java/javase/downloads/jdk6u37-downloads-1859587.html>

I use to add the bin directory (in my case C:\Program
Files\Java\jdk1.6.0_37\bin) to the Path environment variable.

Be sure to use the 64 bit Java if using the 64 bit AgentController
or use the 32bit-Version of both.
Mixing them up gives problems, which are difficult to track down.

Hope this helps,

Heiner


Am 03.12.2012 15:09, schrieb James Noble:
> I guess my last was stupid...
> I searched for J2SE and found a 1.4 version. I am going to try with this.
>
> When I have insgtalled it, I then need to edit setconfig.bat to inlude
> the file path to the directory Java2E just installed (specifically the
> bin directory?)
>
> Thanks so much again.
Re: setconfig.bat needs JRE that supports JAXP [message #988911 is a reply to message #988871] Mon, 03 December 2012 11:34 Go to previous message
James Noble is currently offline James Noble
Messages: 6
Registered: December 2012
Junior Member
HI

I have finally been able to get the config.bat file to run. It prompts me with a few questions about secruity and the javaw location which I answer.

Does however the main RPT tool still cannot connect to the agent machine and reports back to check the agent.

On the agent machine, I hvae the IBM Integration Agent running in the services list but nothing called ACServer. Is that as it should be?

Sorry to be a pain but I failing here.

Thanks
Previous Topic:Could not find agent library on the library path or in the local directory: JPIBootLoader
Next Topic:Reg: Static Analysis plugin
Goto Forum:
  


Current Time: Thu Jul 31 15:48:57 EDT 2014

Powered by FUDForum. Page generated in 0.05374 seconds