Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » Texo - orm annotation model has invalid default values (@Column annotation has invalid default values)
Texo - orm annotation model has invalid default values [message #988771] Sun, 02 December 2012 23:56 Go to next message
Pradeep Badiger is currently offline Pradeep Badiger
Messages: 53
Registered: November 2012
Member
Hi,

I tried to add @Column to a field and i saw that the default values for nullable,insertable,updatable are set to false. Whereas these values have to be true by default as per the @Column documentation.

http://www.oracle.com/technetwork/middleware/ias/toplink-jpa-annotations-096251.html#Column

orm-annotation @Column properties in ide
index.php/fa/12576/0/

thanks,
Pradeep V.B.
Re: Texo - orm annotation model has invalid default values [message #988807 is a reply to message #988771] Mon, 03 December 2012 04:55 Go to previous messageGo to next message
Martin Taal is currently offline Martin Taal
Messages: 5329
Registered: July 2009
Senior Member
Hi Pradeep,
Thanks for noting, it was an error in the orm.xsd from eclipselink. I solved this and published a new build with the fix.

gr. Martin

On 12/03/2012 05:56 AM, Pradeep Badiger wrote:
> Hi,
>
> I tried to add @Column to a field and i saw that the default values for nullable,insertable,updatable are set to false. Whereas these values have to be true by default as per the @Column documentation.
>
> http://www.oracle.com/technetwork/middleware/ias/toplink-jpa-annotations-096251.html#Column
>
> orm-annotation @Column properties in ide
>
>
> thanks,
> Pradeep V.B.
>


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Cell: +31 (0)6 288 48 943
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@xxxxxxxx - mtaal@xxxxxxxx
Web: www.springsite.com - www.elver.org
Re: Texo - orm annotation model has invalid default values [message #988985 is a reply to message #988807] Tue, 04 December 2012 02:28 Go to previous messageGo to next message
Pradeep Badiger is currently offline Pradeep Badiger
Messages: 53
Registered: November 2012
Member
Martin,

There are problems with Fetch type as well. Can you please check? Or Let me know if I can change and give a try.

thanks,
Pradeep V.B.
Re: Texo - orm annotation model has invalid default values [message #988990 is a reply to message #988985] Tue, 04 December 2012 02:55 Go to previous messageGo to next message
Martin Taal is currently offline Martin Taal
Messages: 5329
Registered: July 2009
Senior Member
Hi Pradeep,
Can you give me some details (what problems?), then I can probably solve it easily. The Texo orm model is generated
directly from the orm.xsd from EclipseLink. But maybe there are more issues/incompatibilities with it.

gr. Martin

On 12/04/2012 08:28 AM, Pradeep Badiger wrote:
> Martin,
>
> There are problems with Fetch type as well. Can you please check? Or Let me know if I can change and give a try.
>
> thanks,
> Pradeep V.B.


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Cell: +31 (0)6 288 48 943
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@xxxxxxxx - mtaal@xxxxxxxx
Web: www.springsite.com - www.elver.org
Re: Texo - orm annotation model has invalid default values [message #989208 is a reply to message #988990] Wed, 05 December 2012 03:54 Go to previous message
Pradeep Badiger is currently offline Pradeep Badiger
Messages: 53
Registered: November 2012
Member
Hi Martin, sorry for being abstract. FetchType is LAZY by default for all of the relationships in the editor, where as it is EAGER (as per JPA spec) for few of them like "Many to One", "One to One".

Thanks,
Pradeep V.B.
Previous Topic:[EEF] Custom table representation
Next Topic:[EMF Facet] TreeViewer with EObject from different resource sets
Goto Forum:
  


Current Time: Thu Aug 28 19:14:56 EDT 2014

Powered by FUDForum. Page generated in 0.02086 seconds