Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Mylyn » errors importing and building mylyn
errors importing and building mylyn [message #988603] Fri, 30 November 2012 16:41 Go to next message
Stephen Lujan is currently offline Stephen LujanFriend
Messages: 3
Registered: November 2012
Junior Member
All I really have to go on at the moment is this http://wiki.eclipse.org/index.php/Mylyn/Contributor_Reference#Setup

I hit problems rather quickly though. One of the first steps is setting the target platform which requires according to the wiki requires the Mylyn Releng project. So I have tried importing them as existing maven projects with a few errors:
Quote:
marketplace entries found to handle jacoco-maven-plugin:0.5.6.201201232323:prepare-agent in Eclipse. Please see Help for more information.
Quote:
No marketplace entries found to handle tycho-source-plugin:0.15.0:plugin-source in Eclipse. Please see Help for more information.


I can ignore these and continue and installs the needed tycho software and import the maven projects in Mylyn Releng, but the problems then cite 233 errors. It still allows me to set a target platform at this point though. mylyn-dev-base as suggested in the wiki though. Its taking forever to switch target platforms at the moment, but I'll update after I get further.

I'm using eclipse 4.3 by the way.
Re: errors importing and building mylyn [message #988626 is a reply to message #988603] Fri, 30 November 2012 17:55 Go to previous messageGo to next message
Stephen Lujan is currently offline Stephen LujanFriend
Messages: 3
Registered: November 2012
Junior Member
During an import of all existing maven projects in all of the mylyn repositories into my workspace, I get 355 errors. All of them stem from "No marketplace entries found to handle" errors for jacoco-maven-plugin maven-antrun-plugin and tycho-source-plugin. If I import anyways there are thousands of errors though out the projects.
Re: errors importing and building mylyn [message #988651 is a reply to message #988603] Fri, 30 November 2012 21:33 Go to previous messageGo to next message
Stephen Lujan is currently offline Stephen LujanFriend
Messages: 3
Registered: November 2012
Junior Member
Well I've confirmed the same errors occur while importing the maven projects into eclipse 3.7.2. I should have mentioned that I am using the m2e plugin. I'll see if I can do better using command line maven.
Re: errors importing and building mylyn [message #1034554 is a reply to message #988603] Fri, 05 April 2013 15:21 Go to previous message
Steffen Pingel is currently offline Steffen PingelFriend
Messages: 706
Registered: July 2009
Senior Member
Hi,

the Mylyn projects are not setup to work with Maven/m2e in Eclipse. You will
need to have PDE installed in your Eclipse environment and import the Mylyn
projects as standard Eclipse projects. We only use Maven/Tycho for CI
builds.

Steffen


Stephen Lujan wrote:

> All I really have to go on at the moment is this
> http://wiki.eclipse.org/index.php/Mylyn/Contributor_Reference#Setup
>
> I hit problems rather quickly though. One of the first steps is setting
> the target platform which requires according to the wiki requires the
> Mylyn Releng project. So I have tried importing them as existing maven
> projects with a few errors: Quote:
>> marketplace entries found to handle
>> jacoco-maven-plugin:0.5.6.201201232323:prepare-agent in Eclipse. Please
>> see Help for more information.
> Quote:
>> No marketplace entries found to handle
>> tycho-source-plugin:0.15.0:plugin-source in Eclipse. Please see Help for
>> more information.
>
>
> I can ignore these and continue and installs the needed tycho software and
> import the maven projects in Mylyn Releng, but the problems then cite 233
> errors. It still allows me to set a target platform at this point though.
> mylyn-dev-base as suggested in the wiki though. Its taking forever to
> switch target platforms at the moment, but I'll update after I get
> further.
>
> I'm using eclipse 4.3 by the way.
--
Steffen Pingel
Principal Software Engineer, Eclipse Mylyn Tasks Lead
http://tasktop.com
Previous Topic:Eclipse freezes on startup
Next Topic:Break points can't be displayed on Spring Source Tool Suite
Goto Forum:
  


Current Time: Sat Dec 20 12:20:22 GMT 2014

Powered by FUDForum. Page generated in 0.02440 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software