Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » [CDO] launch error with offline example
[CDO] launch error with offline example [message #988348] Thu, 29 November 2012 14:12 Go to next message
Angel Lopez is currently offline Angel Lopez
Messages: 5
Registered: October 2012
Junior Member
Hi people, I'm learning CDO, because I have to do my thesis about it. I was trying to use the new example that Eike posted in his blog .
To do that, I downloaded Eclipse modeling tools (Kepler) and emf-cdo baseline of the cdo download page. So I added the baseline in my eclipse, installed the last version of cdo examples but when I try to run CDOOfflineExample I get this launch error:

!SESSION 2012-11-29 15:06:46.226 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_26
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Framework arguments: -application org.eclipse.emf.cdo.examples.client.offline.application
Command-line arguments: -application org.eclipse.emf.cdo.examples.client.offline.application -data /home/angel/workspace/../CDOOfflineExample.rt -dev file:/home/angel/workspace/.metadata/.plugins/org.eclipse.pde.core/CDOOfflineExample/dev.properties -os linux -ws gtk -arch x86 -consoleLog

!ENTRY org.eclipse.osgi 2 0 2012-11-29 15:06:48.194
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-29 15:06:48.194
!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.ui.workbench_3.105.0.v20121029-205406.jar was not resolved.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.195
!MESSAGE Missing required bundle org.eclipse.e4.ui.css.core_0.9.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.195
!MESSAGE Missing imported package org.eclipse.e4.core.commands.internal_0.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.196
!MESSAGE Missing required bundle org.eclipse.e4.core.di_1.1.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.196
!MESSAGE Missing imported package javax.annotation_1.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.197
!MESSAGE Missing required bundle org.eclipse.e4.core.contexts_1.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.197
!MESSAGE Missing required bundle org.eclipse.e4.ui.di_0.9.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.198
!MESSAGE Missing imported package javax.inject_1.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.198
!MESSAGE Missing required bundle org.eclipse.e4.ui.css.swt.theme_0.9.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.199
!MESSAGE Missing imported package org.eclipse.e4.ui.internal.workbench.swt_0.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.199
!MESSAGE Missing required bundle org.eclipse.e4.ui.workbench3_0.12.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.200
!MESSAGE Missing required bundle org.eclipse.e4.ui.workbench.swt_0.9.1.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.200
!MESSAGE Missing required bundle org.eclipse.e4.ui.bindings_0.9.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.201
!MESSAGE Missing imported package org.eclipse.e4.ui.workbench.modeling_0.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.201
!MESSAGE Missing imported package org.eclipse.e4.core.commands_0.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.202
!MESSAGE Missing imported package org.eclipse.e4.ui.workbench.renderers.swt_0.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.202
!MESSAGE Missing required bundle org.eclipse.e4.core.services_1.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.203
!MESSAGE Missing imported package org.eclipse.e4.ui.internal.workbench_0.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.203
!MESSAGE Missing imported package org.osgi.service.event_1.2.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.204
!MESSAGE Missing required bundle org.eclipse.e4.ui.model.workbench_0.9.1.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.204
!MESSAGE Missing required bundle org.eclipse.e4.ui.css.swt_0.9.1.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.205
!MESSAGE Missing imported package org.w3c.dom.css_2.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.205
!MESSAGE Missing imported package org.eclipse.e4.ui.workbench_0.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.206
!MESSAGE Missing imported package org.eclipse.e4.ui.services_0.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.206
!MESSAGE Missing imported package org.eclipse.e4.ui.internal.workbench.renderers.swt_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-29 15:06:48.206
!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.ui_3.105.0.v20121024-230951.jar was not resolved.
!SUBENTRY 2 org.eclipse.ui 2 0 2012-11-29 15:06:48.207
!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=CDC/Foundation)(version=1.0))(&(osgi.ee=JavaSE)(version=1.3)))".

!ENTRY org.eclipse.osgi 2 0 2012-11-29 15:06:48.243
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-29 15:06:48.244
!MESSAGE Bundle org.eclipse.ui_3.105.0.v20121024-230951 was not resolved.
!SUBENTRY 2 org.eclipse.ui 2 0 2012-11-29 15:06:48.244
!MESSAGE Missing required bundle org.eclipse.ui.workbench_ was not resolved.
!SUBENTRY 2 org.eclipse.emf.cdo.transfer.ui 2 0 2012-11-29 15:06:48.246
!MESSAGE Missing required bundle org.eclipse.ui_[3.4.0,4.0.0).
!SUBENTRY 2 org.eclipse.emf.cdo.transfer.ui 2 0 2012-11-29 15:06:48.246
!MESSAGE Missing optionally required bundle org.eclipse.ui.navigator_[3.4.0,4.0.0).
!SUBENTRY 2 org.eclipse.emf.cdo.transfer.ui 2 0 2012-11-29 15:06:48.247
!MESSAGE Missing optionally required bundle org.eclipse.ui.navigator.resources_[3.4.0,4.0.0).
!SUBENTRY 2 org.eclipse.emf.cdo.transfer.ui 2 0 2012-11-29 15:06:48.247
!MESSAGE Missing required bundle org.eclipse.net4j.util.ui_[3.0.0,4.0.0).
!SUBENTRY 2 org.eclipse.emf.cdo.transfer.ui 2 0 2012-11-29 15:06:48.248
!MESSAGE Missing required bundle org.eclipse.net4j.ui.shared_[4.1.0,5.0.0).
!SUBENTRY 2 org.eclipse.emf.cdo.transfer.ui 2 0 2012-11-29 15:06:48.248
!MESSAGE Missing required bundle org.eclipse.emf.cdo.ui.shared_[4.1.0,5.0.0).
!SUBENTRY 2 org.eclipse.emf.cdo.transfer.ui 2 0 2012-11-29 15:06:48.249
!MESSAGE Missing optionally required bundle org.eclipse.emf.cdo.transfer.workspace_[4.2.0,5.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-29 15:06:48.249
!MESSAGE Bundle org.eclipse.net4j.util.ui_3.3.0.v20121108-1836 was not resolved.
!SUBENTRY 2 org.eclipse.net4j.util.ui 2 0 2012-11-29 15:06:48.250
!MESSAGE Missing optionally required bundle org.eclipse.ui.views_[3.4.0,4.0.0).
!SUBENTRY 2 org.eclipse.net4j.util.ui 2 0 2012-11-29 15:06:48.250
!MESSAGE Missing required bundle org.eclipse.ui_[3.4.0,4.0.0).
!SUBENTRY 2 org.eclipse.net4j.util.ui 2 0 2012-11-29 15:06:48.251
!MESSAGE Missing required bundle org.eclipse.net4j.ui.shared_[4.0.0,5.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-29 15:06:48.251
!MESSAGE Bundle org.eclipse.emf.common.ui_2.8.0.v20121109-0549 was not resolved.
!SUBENTRY 2 org.eclipse.emf.common.ui 2 0 2012-11-29 15:06:48.252
!MESSAGE Missing required bundle org.eclipse.ui_[3.5.0,4.0.0).
!SUBENTRY 2 org.eclipse.emf.common.ui 2 0 2012-11-29 15:06:48.252
!MESSAGE Missing optionally required bundle org.eclipse.core.resources_[3.5.0,4.0.0).
!SUBENTRY 2 org.eclipse.emf.common.ui 2 0 2012-11-29 15:06:48.253
!MESSAGE Missing optionally required bundle org.eclipse.ui.ide_[3.5.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-29 15:06:48.253
!MESSAGE Bundle org.eclipse.ui.workbench_3.105.0.v20121029-205406 was not resolved.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.254
!MESSAGE Missing required bundle org.eclipse.e4.core.services_1.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.254
!MESSAGE Missing required bundle org.eclipse.e4.core.contexts_1.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.255
!MESSAGE Missing required bundle org.eclipse.e4.core.di_1.1.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.255
!MESSAGE Missing required bundle org.eclipse.e4.ui.workbench.swt_0.9.1.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.256
!MESSAGE Missing required bundle org.eclipse.e4.ui.di_0.9.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.256
!MESSAGE Missing required bundle org.eclipse.e4.ui.model.workbench_0.9.1.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.257
!MESSAGE Missing required bundle org.eclipse.e4.ui.css.swt.theme_0.9.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.257
!MESSAGE Missing required bundle org.eclipse.e4.ui.bindings_0.9.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.258
!MESSAGE Missing required bundle org.eclipse.e4.ui.css.swt_0.9.1.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.258
!MESSAGE Missing required bundle org.eclipse.e4.ui.css.core_0.9.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.259
!MESSAGE Missing required bundle org.eclipse.e4.ui.workbench3_0.12.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.259
!MESSAGE Missing imported package javax.annotation_1.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.260
!MESSAGE Missing imported package javax.inject_1.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.260
!MESSAGE Missing imported package org.eclipse.e4.core.commands_0.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.261
!MESSAGE Missing imported package org.eclipse.e4.core.commands.internal_0.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.261
!MESSAGE Missing imported package org.eclipse.e4.ui.internal.workbench_0.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.262
!MESSAGE Missing imported package org.eclipse.e4.ui.internal.workbench.renderers.swt_0.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.262
!MESSAGE Missing imported package org.eclipse.e4.ui.internal.workbench.swt_0.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.263
!MESSAGE Missing imported package org.eclipse.e4.ui.services_0.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.263
!MESSAGE Missing imported package org.eclipse.e4.ui.workbench_0.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.264
!MESSAGE Missing imported package org.eclipse.e4.ui.workbench.modeling_0.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.264
!MESSAGE Missing imported package org.eclipse.e4.ui.workbench.renderers.swt_0.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.264
!MESSAGE Missing imported package org.osgi.service.event_1.2.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.265
!MESSAGE Missing imported package org.w3c.dom.css_2.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-29 15:06:48.265
!MESSAGE Bundle org.eclipse.ui.workbench.texteditor_3.8.100.v20120705-111822 was not resolved.
!SUBENTRY 2 org.eclipse.ui.workbench.texteditor 2 0 2012-11-29 15:06:48.266
!MESSAGE Missing required bundle org.eclipse.ui_[3.5.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-29 15:06:48.266
!MESSAGE Bundle org.eclipse.ui.views_3.6.100.v20120705-114010 was not resolved.
!SUBENTRY 2 org.eclipse.ui.views 2 0 2012-11-29 15:06:48.267
!MESSAGE Missing required bundle org.eclipse.ui_[3.5.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-29 15:06:48.267
!MESSAGE Bundle org.eclipse.net4j.ui.shared_4.2.0.v20120917-1349 was not resolved.
!SUBENTRY 2 org.eclipse.net4j.ui.shared 2 0 2012-11-29 15:06:48.268
!MESSAGE Missing required bundle org.eclipse.ui_[3.6.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-29 15:06:48.268
!MESSAGE Bundle org.eclipse.emf.cdo.ui.shared_4.1.0.v20121005-1734 was not resolved.
!SUBENTRY 2 org.eclipse.emf.cdo.ui.shared 2 0 2012-11-29 15:06:48.269
!MESSAGE Missing required bundle org.eclipse.ui_[3.4.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-29 15:06:48.269
!MESSAGE Bundle org.eclipse.emf.edit.ui_2.9.0.v20121109-0549 was not resolved.
!SUBENTRY 2 org.eclipse.emf.edit.ui 2 0 2012-11-29 15:06:48.270
!MESSAGE Missing required bundle org.eclipse.ui.views_[3.4.0,4.0.0).
!SUBENTRY 2 org.eclipse.emf.edit.ui 2 0 2012-11-29 15:06:48.270
!MESSAGE Missing required bundle org.eclipse.ui.workbench_[3.5.0,4.0.0).
!SUBENTRY 2 org.eclipse.emf.edit.ui 2 0 2012-11-29 15:06:48.271
!MESSAGE Missing required bundle org.eclipse.emf.common.ui_[2.8.0,3.0.0).
!SUBENTRY 2 org.eclipse.emf.edit.ui 2 0 2012-11-29 15:06:48.271
!MESSAGE Missing optionally required bundle org.eclipse.core.resources_[3.5.0,4.0.0).
!SUBENTRY 2 org.eclipse.emf.edit.ui 2 0 2012-11-29 15:06:48.272
!MESSAGE Missing optionally required bundle org.eclipse.ui.ide_[3.5.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-29 15:06:48.272
!MESSAGE Bundle org.eclipse.emf.cdo.examples.client.offline_4.2.0.qualifier was not resolved.
!SUBENTRY 2 org.eclipse.emf.cdo.examples.client.offline 2 0 2012-11-29 15:06:48.273
!MESSAGE Missing required bundle org.eclipse.ui_[3.4.0,4.0.0).
!SUBENTRY 2 org.eclipse.emf.cdo.examples.client.offline 2 0 2012-11-29 15:06:48.273
!MESSAGE Missing required bundle org.eclipse.emf.cdo.ui_[4.0.0,5.0.0).
!SUBENTRY 2 org.eclipse.emf.cdo.examples.client.offline 2 0 2012-11-29 15:06:48.274
!MESSAGE Missing required bundle org.eclipse.net4j.util.ui_[3.0.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-29 15:06:48.274
!MESSAGE Bundle org.eclipse.emf.cdo.ui_4.2.0.v20121110-0758 was not resolved.
!SUBENTRY 2 org.eclipse.emf.cdo.ui 2 0 2012-11-29 15:06:48.275
!MESSAGE Missing optionally required bundle org.eclipse.core.resources_ was not resolved.
!SUBENTRY 2 org.eclipse.ui 2 0 2012-11-29 15:06:48.443
!MESSAGE Missing required bundle org.eclipse.ui.workbench_ was not resolved.
!SUBENTRY 2 org.eclipse.emf.cdo.transfer.ui 2 0 2012-11-29 15:06:48.444
!MESSAGE Missing required bundle org.eclipse.ui_[3.4.0,4.0.0).
!SUBENTRY 2 org.eclipse.emf.cdo.transfer.ui 2 0 2012-11-29 15:06:48.444
!MESSAGE Missing optionally required bundle org.eclipse.ui.navigator_[3.4.0,4.0.0).
!SUBENTRY 2 org.eclipse.emf.cdo.transfer.ui 2 0 2012-11-29 15:06:48.445
!MESSAGE Missing optionally required bundle org.eclipse.ui.navigator.resources_[3.4.0,4.0.0).
!SUBENTRY 2 org.eclipse.emf.cdo.transfer.ui 2 0 2012-11-29 15:06:48.447
!MESSAGE Missing required bundle org.eclipse.net4j.util.ui_[3.0.0,4.0.0).
!SUBENTRY 2 org.eclipse.emf.cdo.transfer.ui 2 0 2012-11-29 15:06:48.447
!MESSAGE Missing required bundle org.eclipse.net4j.ui.shared_[4.1.0,5.0.0).
!SUBENTRY 2 org.eclipse.emf.cdo.transfer.ui 2 0 2012-11-29 15:06:48.448
!MESSAGE Missing required bundle org.eclipse.emf.cdo.ui.shared_[4.1.0,5.0.0).
!SUBENTRY 2 org.eclipse.emf.cdo.transfer.ui 2 0 2012-11-29 15:06:48.448
!MESSAGE Missing optionally required bundle org.eclipse.emf.cdo.transfer.workspace_[4.2.0,5.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-29 15:06:48.448
!MESSAGE Bundle org.eclipse.net4j.util.ui_3.3.0.v20121108-1836 was not resolved.
!SUBENTRY 2 org.eclipse.net4j.util.ui 2 0 2012-11-29 15:06:48.449
!MESSAGE Missing optionally required bundle org.eclipse.ui.views_[3.4.0,4.0.0).
!SUBENTRY 2 org.eclipse.net4j.util.ui 2 0 2012-11-29 15:06:48.449
!MESSAGE Missing required bundle org.eclipse.ui_[3.4.0,4.0.0).
!SUBENTRY 2 org.eclipse.net4j.util.ui 2 0 2012-11-29 15:06:48.452
!MESSAGE Missing required bundle org.eclipse.net4j.ui.shared_[4.0.0,5.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-29 15:06:48.453
!MESSAGE Bundle org.eclipse.emf.common.ui_2.8.0.v20121109-0549 was not resolved.
!SUBENTRY 2 org.eclipse.emf.common.ui 2 0 2012-11-29 15:06:48.453
!MESSAGE Missing required bundle org.eclipse.ui_[3.5.0,4.0.0).
!SUBENTRY 2 org.eclipse.emf.common.ui 2 0 2012-11-29 15:06:48.454
!MESSAGE Missing optionally required bundle org.eclipse.core.resources_[3.5.0,4.0.0).
!SUBENTRY 2 org.eclipse.emf.common.ui 2 0 2012-11-29 15:06:48.454
!MESSAGE Missing optionally required bundle org.eclipse.ui.ide_[3.5.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-29 15:06:48.454
!MESSAGE Bundle org.eclipse.ui.workbench_3.105.0.v20121029-205406 was not resolved.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.457
!MESSAGE Missing required bundle org.eclipse.e4.core.services_1.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.457
!MESSAGE Missing required bundle org.eclipse.e4.core.contexts_1.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.458
!MESSAGE Missing required bundle org.eclipse.e4.core.di_1.1.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.458
!MESSAGE Missing required bundle org.eclipse.e4.ui.workbench.swt_0.9.1.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.459
!MESSAGE Missing required bundle org.eclipse.e4.ui.di_0.9.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.459
!MESSAGE Missing required bundle org.eclipse.e4.ui.model.workbench_0.9.1.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.459
!MESSAGE Missing required bundle org.eclipse.e4.ui.css.swt.theme_0.9.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.463
!MESSAGE Missing required bundle org.eclipse.e4.ui.bindings_0.9.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.463
!MESSAGE Missing required bundle org.eclipse.e4.ui.css.swt_0.9.1.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.464
!MESSAGE Missing required bundle org.eclipse.e4.ui.css.core_0.9.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.464
!MESSAGE Missing required bundle org.eclipse.e4.ui.workbench3_0.12.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.464
!MESSAGE Missing imported package javax.annotation_1.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.465
!MESSAGE Missing imported package javax.inject_1.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.465
!MESSAGE Missing imported package org.eclipse.e4.core.commands_0.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.466
!MESSAGE Missing imported package org.eclipse.e4.core.commands.internal_0.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.466
!MESSAGE Missing imported package org.eclipse.e4.ui.internal.workbench_0.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.471
!MESSAGE Missing imported package org.eclipse.e4.ui.internal.workbench.renderers.swt_0.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.472
!MESSAGE Missing imported package org.eclipse.e4.ui.internal.workbench.swt_0.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.472
!MESSAGE Missing imported package org.eclipse.e4.ui.services_0.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.472
!MESSAGE Missing imported package org.eclipse.e4.ui.workbench_0.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.473
!MESSAGE Missing imported package org.eclipse.e4.ui.workbench.modeling_0.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.473
!MESSAGE Missing imported package org.eclipse.e4.ui.workbench.renderers.swt_0.0.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.475
!MESSAGE Missing imported package org.osgi.service.event_1.2.0.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2012-11-29 15:06:48.475
!MESSAGE Missing imported package org.w3c.dom.css_2.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-29 15:06:48.476
!MESSAGE Bundle org.eclipse.ui.workbench.texteditor_3.8.100.v20120705-111822 was not resolved.
!SUBENTRY 2 org.eclipse.ui.workbench.texteditor 2 0 2012-11-29 15:06:48.476
!MESSAGE Missing required bundle org.eclipse.ui_[3.5.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-29 15:06:48.480
!MESSAGE Bundle org.eclipse.ui.views_3.6.100.v20120705-114010 was not resolved.
!SUBENTRY 2 org.eclipse.ui.views 2 0 2012-11-29 15:06:48.481
!MESSAGE Missing required bundle org.eclipse.ui_[3.5.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-29 15:06:48.481
!MESSAGE Bundle org.eclipse.net4j.ui.shared_4.2.0.v20120917-1349 was not resolved.
!SUBENTRY 2 org.eclipse.net4j.ui.shared 2 0 2012-11-29 15:06:48.482
!MESSAGE Missing required bundle org.eclipse.ui_[3.6.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-29 15:06:48.482
!MESSAGE Bundle org.eclipse.emf.cdo.ui.shared_4.1.0.v20121005-1734 was not resolved.
!SUBENTRY 2 org.eclipse.emf.cdo.ui.shared 2 0 2012-11-29 15:06:48.488
!MESSAGE Missing required bundle org.eclipse.ui_[3.4.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-29 15:06:48.489
!MESSAGE Bundle org.eclipse.emf.edit.ui_2.9.0.v20121109-0549 was not resolved.
!SUBENTRY 2 org.eclipse.emf.edit.ui 2 0 2012-11-29 15:06:48.489
!MESSAGE Missing required bundle org.eclipse.ui.views_[3.4.0,4.0.0).
!SUBENTRY 2 org.eclipse.emf.edit.ui 2 0 2012-11-29 15:06:48.492
!MESSAGE Missing required bundle org.eclipse.ui.workbench_[3.5.0,4.0.0).
!SUBENTRY 2 org.eclipse.emf.edit.ui 2 0 2012-11-29 15:06:48.495
!MESSAGE Missing required bundle org.eclipse.emf.common.ui_[2.8.0,3.0.0).
!SUBENTRY 2 org.eclipse.emf.edit.ui 2 0 2012-11-29 15:06:48.496
!MESSAGE Missing optionally required bundle org.eclipse.core.resources_[3.5.0,4.0.0).
!SUBENTRY 2 org.eclipse.emf.edit.ui 2 0 2012-11-29 15:06:48.500
!MESSAGE Missing optionally required bundle org.eclipse.ui.ide_[3.5.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-29 15:06:48.501
!MESSAGE Bundle org.eclipse.emf.cdo.examples.client.offline_4.2.0.qualifier was not resolved.
!SUBENTRY 2 org.eclipse.emf.cdo.examples.client.offline 2 0 2012-11-29 15:06:48.501
!MESSAGE Missing required bundle org.eclipse.ui_[3.4.0,4.0.0).
!SUBENTRY 2 org.eclipse.emf.cdo.examples.client.offline 2 0 2012-11-29 15:06:48.502
!MESSAGE Missing required bundle org.eclipse.emf.cdo.ui_[4.0.0,5.0.0).
!SUBENTRY 2 org.eclipse.emf.cdo.examples.client.offline 2 0 2012-11-29 15:06:48.502
!MESSAGE Missing required bundle org.eclipse.net4j.util.ui_[3.0.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-29 15:06:48.503
!MESSAGE Bundle org.eclipse.emf.cdo.ui_4.2.0.v20121110-0758 [53] was not resolved.
!SUBENTRY 2 org.eclipse.emf.cdo.ui 2 0 2012-11-29 15:06:48.504
!MESSAGE Missing optionally required bundle org.eclipse.core.resources_[3.4.0,4.0.0).
!SUBENTRY 2 org.eclipse.emf.cdo.ui 2 0 2012-11-29 15:06:48.504
!MESSAGE Missing required bundle org.eclipse.ui_[3.4.0,4.0.0).
!SUBENTRY 2 org.eclipse.emf.cdo.ui 2 0 2012-11-29 15:06:48.505
!MESSAGE Missing required bundle org.eclipse.ui.workbench.texteditor_[3.4.0,4.0.0).
!SUBENTRY 2 org.eclipse.emf.cdo.ui 2 0 2012-11-29 15:06:48.505
!MESSAGE Missing required bundle org.eclipse.emf.edit.ui_[2.4.0,3.0.0).
!SUBENTRY 2 org.eclipse.emf.cdo.ui 2 0 2012-11-29 15:06:48.506
!MESSAGE Missing required bundle org.eclipse.net4j.util.ui_[3.0.0,4.0.0).
!SUBENTRY 2 org.eclipse.emf.cdo.ui 2 0 2012-11-29 15:06:48.506
!MESSAGE Missing required bundle org.eclipse.emf.cdo.transfer.ui_[4.2.0,5.0.0).
!SUBENTRY 2 org.eclipse.emf.cdo.ui 2 0 2012-11-29 15:06:48.507
!MESSAGE Missing required bundle org.eclipse.emf.cdo.ui.shared_[4.0.0,5.0.0).

!ENTRY org.eclipse.osgi 4 0 2012-11-29 15:06:48.507
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: Application "org.eclipse.emf.cdo.examples.client.offline.application" could not be found in the registry. The applications available are: org.eclipse.equinox.app.error, org.eclipse.emf.cdo.server.app.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:248)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:353)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:180)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:629)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
at org.eclipse.equinox.launcher.Main.main(Main.java:1414)




I also have this 3 warnings when I add the examples in my workspace:

Build path specifies execution environment J2SE-1.5. There are no JREs installed in the workspace that are strictly compatible with this environment.


Thank you in advance Smile
Re: [CDO] launch error with offline example [message #988360 is a reply to message #988348] Thu, 29 November 2012 15:18 Go to previous messageGo to next message
Angel Lopez is currently offline Angel Lopez
Messages: 5
Registered: October 2012
Junior Member
I have been all day with that, trying different ways, and just now after post in the forum I have solved the problem. I just have to do click in "Add required plug-ins" in the run configuration...
I'm sorry to be a nuisance.
Re: [CDO] launch error with offline example [message #988394 is a reply to message #988360] Thu, 29 November 2012 17:30 Go to previous messageGo to next message
Eike Stepper is currently offline Eike Stepper
Messages: 5522
Registered: July 2009
Senior Member
Am 29.11.2012 16:18, schrieb Angel Lopez:
> I have been all day with that, trying different ways, and just now after post in the forum I have solved the problem.
> I just have to do click in "Add required plug-ins" in the run configuration...
> I'm sorry to be a nuisance.
No worries! It strikes me, though, that you're not having the latest version. I thought I changed it to "Run with all
plugins".

Cheers
/Eike

----
http://www.esc-net.de
http://thegordian.blogspot.com
http://twitter.com/eikestepper
Re: [CDO] launch error with offline example [message #988533 is a reply to message #988394] Fri, 30 November 2012 11:41 Go to previous messageGo to next message
Angel Lopez is currently offline Angel Lopez
Messages: 5
Registered: October 2012
Junior Member
I don't understand you, what do you mean with "you're not having the latest version"?

I have tried to do same steps that in the video but when I launch the client, it's like some features are not loaded...


I have attached a screenshot of the client's window
Re: [CDO] launch error with offline example [message #988611 is a reply to message #988533] Fri, 30 November 2012 17:09 Go to previous messageGo to next message
Eike Stepper is currently offline Eike Stepper
Messages: 5522
Registered: July 2009
Senior Member
Am 30.11.2012 12:41, schrieb Angel Lopez:
> I don't understand you, what do you mean with "you're not having the latest version"?
I meant "If you have the newest version of the example installer you shouldn't have this problem". But I said "I think".
I can double check over the weekend...

> I have tried to do same steps that in the video but when I launch the client, it's like some features are not loaded...
>
>
> I have attached a screenshot of the client's window
That also looks to me as if you haven't got the latest code, e.g. the newer "Connected to network" checkbox is missing.

Cheers
/Eike

----
http://www.esc-net.de
http://thegordian.blogspot.com
http://twitter.com/eikestepper
Re: [CDO] launch error with offline example [message #988843 is a reply to message #988611] Mon, 03 December 2012 12:43 Go to previous messageGo to next message
Angel Lopez is currently offline Angel Lopez
Messages: 5
Registered: October 2012
Junior Member
Ok, now I have used this weekly build (I20121119-0355 ) and I still have the problem with the client interface. But this time I haven't had to use "Add required plug-ins" option. Maybe that version is not the latest one?

[Updated on: Mon, 03 December 2012 12:43]

Report message to a moderator

Re: [CDO] launch error with offline example [message #989030 is a reply to message #988843] Tue, 04 December 2012 10:57 Go to previous messageGo to next message
Angel Lopez is currently offline Angel Lopez
Messages: 5
Registered: October 2012
Junior Member
I have seen that the previous weekly build include the new offline example... I'm running Eclipse in Linux, but I don't think this is the problem...
Re: [CDO] launch error with offline example [message #989128 is a reply to message #989030] Tue, 04 December 2012 17:46 Go to previous message
Eike Stepper is currently offline Eike Stepper
Messages: 5522
Registered: July 2009
Senior Member
Am 04.12.2012 11:57, schrieb Angel Lopez:
> I have seen that the previous weekly build include the new offline example... I'm running Eclipse in Linux, but I
> don't think this is the problem...
Something in the build is broken. I can currently not publish drops ;-(

Cheers
/Eike

----
http://www.esc-net.de
http://thegordian.blogspot.com
http://twitter.com/eikestepper
Previous Topic:[CDO] ClassCastException when removing one entry from the model
Next Topic:[Compare] Showing differences in a Comparison object?
Goto Forum:
  


Current Time: Wed Sep 17 21:48:30 GMT 2014

Powered by FUDForum. Page generated in 0.02310 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software