Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » BIRT Runtime on Solaris Sparc(Slow Performance)
BIRT Runtime on Solaris Sparc [message #988346] Thu, 29 November 2012 13:47 Go to next message
Eric W is currently offline Eric W
Messages: 29
Registered: November 2009
Junior Member
Hello,

I am running the birt runtime 3_7_0 on a solaris sparc server and I get really slow performance.

Steps to repeat this. I unzip birt-runtime-3_7_0, cd to ReportEngine folder and run

./genReport.sh -f PDF -o outputfile.pdf -F samples/hello_world.rptdesign


First and foremost I always get a
SEVERE: file: /home/birt/birt-runtime-3_7_0/ReportEngine not exists!

but the report always runs.

This hello_world.rptdesign takes 35-40 seconds to generate everytime. This slowness only occurs on Solaris Sparc. I move this same runtime folder and run the genReport.bat on a windows box or a solaris box(non sparc) and it works in 3->4 seconds.

A chart of my speeds and setup

30-40 sec hello_world report setup
Solaris 10 on a sparc cpu only. testing using java -versions 1.5, 1.6, and 1.7

3-4 sec hello_world report generations
Windows 7, Solaris 11 (i586,x64) java -versions 1.5 and 1.7

I dont know if I am missing something, but I ran this on my production server as well and its still 30-40 seconds to generate the hello world. My production server is a solaris sparc server, but it is a beast. So I dunno if I am supposed to configure something on a sparc server?

Any help or tips would be greatly appriciated.

[Updated on: Thu, 29 November 2012 17:59]

Report message to a moderator

Re: BIRT Runtime on Solaris Sparc [message #988440 is a reply to message #988346] Thu, 29 November 2012 21:50 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Any chance you could try 3.7.2? Also are you using the pojo runtime package(default) or the OSGi runtime?

Jason
Re: BIRT Runtime on Solaris Sparc [message #988582 is a reply to message #988440] Fri, 30 November 2012 15:28 Go to previous messageGo to next message
Eric W is currently offline Eric W
Messages: 29
Registered: November 2009
Junior Member
I will try birt 3_7_2 shortly. There is server patching going on where i am at so I need to wait to test

However, I would like to state something real quick. I did this test because i have a report that in the web viewer takes about 10 sec to generate, this is fine as its a huge report. However, when I deploy it to any webserver on a solaris sparc server it takes 3min. I have tried OC4J with java 1.5, weblogic with java 1.6 and 1.7. The only difference in speed comes from solaris sparc vs anything else.

With this in mind I wanted to eliminate as much as possible so I just unzip the 3_7_0 runtime then run the hello_world.rptdesign from the command line. I think this is a fair test and should generate close to the same on any machine. The numbers I posted above are repeatable and lead me to blieve there is an underlying problem with solaris sparc.

I see your comment about the OSGi framework and I dont understand what you are asking. I am just unzipping the birt_runtime_3_7_0 download, setting BIRT_HOME then running the genReport.sh or .bat. I think my numbers show a problem just from running this test as they are repeatable.

If you think I should start the OSGi framework I will give it a try, is there a way to do this command line? I would like to run and test from the command line as this will eliminate any chance I have a bad OC4J or weblogic setup.
Re: BIRT Runtime on Solaris Sparc [message #988906 is a reply to message #988582] Mon, 03 December 2012 16:29 Go to previous messageGo to next message
Eric W is currently offline Eric W
Messages: 29
Registered: November 2009
Junior Member
Ok, I downloaded birt-runtime-3_7_2 and birt-runtime-4_2_1, I unziped and set BIRT_HOME for each accordingly. It still takes 30+ seconds just to run the hello_world.rptdesign from commandline. I use the command I posted above. I find this troubling as this only takes so long on Solaris Sparc. I know it cant be the server as its very powerfull and the zone i am testing in has plenty of room to run.
Re: BIRT Runtime on Solaris Sparc [message #989088 is a reply to message #988906] Tue, 04 December 2012 15:18 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Eric

Can you open a bugzilla entry for this?

Jason
Re: BIRT Runtime on Solaris Sparc [message #989140 is a reply to message #989088] Tue, 04 December 2012 19:03 Go to previous message
Eric W is currently offline Eric W
Messages: 29
Registered: November 2009
Junior Member
Bug submitted

https://bugs.eclipse.org/bugs/show_bug.cgi?id=395753

Also, I am opening a ticket with Oracle Support. I will update this post and the bugzilla entry as needed.

I am really hoping this is just a server tuning issue as I need these reports to run in a timely manner.
Previous Topic:BIRT + web application
Next Topic:How to SetUp
Goto Forum:
  


Current Time: Thu Oct 23 06:04:37 GMT 2014

Powered by FUDForum. Page generated in 0.02398 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software