Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Default Button problems on a Composite in Juno
Default Button problems on a Composite in Juno [message #987717] Tue, 27 November 2012 17:36 Go to next message
Brian Fitzpatrick is currently offline Brian FitzpatrickFriend
Messages: 495
Registered: July 2009
Senior Member
Wise and powerful Eclipse folks, I have a strange situation that didn't show up in Indigo but seems to in Juno.

We have a tabbed property page with two parts. On one side we have a list with a Remove button and on the other we have a composite that changes based on what's selected in the list. Each composite has a collection of fields - Text, Combo, Button, etc.

The problem is that if I hit Enter on one of the fields on the child composite, the button further up the hierarchy on the other side is getting a selection event triggered. The user didn't click the button and this is causing no end of problems.

Is there a way to disable that default key handler in particular contexts? On a separate property sheet with no child composite we have two buttons and a list and no matter where you are on the sheet if you hit Enter, it triggers the first button. So I suspect there's a default at work here I'm not seeing.

I tried setting the shell's default to null (shell.setDefaultButton(null)) but that doesn't seem to do the trick.

Any suggestions? I know it's sort of like a needle in a haystack without code, but this seems to be a problem across the board with all of our tabbed property pages regardless of how complex they are.

Thanks in advance oh wise and powerful Eclipse gurus...
--Fitz
Re: Default Button problems on a Composite in Juno [message #987723 is a reply to message #987717] Tue, 27 November 2012 18:25 Go to previous messageGo to next message
Brian Fitzpatrick is currently offline Brian FitzpatrickFriend
Messages: 495
Registered: July 2009
Senior Member
If it helps at all, this is a stack trace. I've tried circumventing the key event, but nothing I've tried has worked so far. There has to be some listener working above me in the framework intercepting key events regardless of the context.

Obviously if the user clicks the button or hits Enter, I want the event to fire. But the event in this case has nothing to do with the button.

Thread [main] (Suspended (breakpoint at line 315 in SwitchyardSCAPropertiesBindingsSection$5))	
	SwitchyardSCAPropertiesBindingsSection$5.widgetSelected(SelectionEvent) line: 315	
	TypedListener.handleEvent(Event) line: 248	
	EventTable.sendEvent(Event) line: 84	
	Button(Widget).sendEvent(Event) line: 1053	
	Display.runDeferredEvents() line: 4169	
	Display.readAndDispatch() line: 3758	
	PartRenderingEngine$9.run() line: 1029	
	Realm.runWithDefault(Realm, Runnable) line: 332	
	PartRenderingEngine.run(MApplicationElement, IEclipseContext) line: 923	
	E4Workbench.createAndRunUI(MApplicationElement) line: 86	
	Workbench$5.run() line: 588	
	Realm.runWithDefault(Realm, Runnable) line: 332	
	Workbench.createAndRunWorkbench(Display, WorkbenchAdvisor) line: 543	
	PlatformUI.createAndRunWorkbench(Display, WorkbenchAdvisor) line: 149	
	IDEApplication.start(IApplicationContext) line: 124	
	EclipseAppHandle.run(Object) line: 196	
	EclipseAppLauncher.runApplication(Object) line: 110	
	EclipseAppLauncher.start(Object) line: 79	
	EclipseStarter.run(Object) line: 353	
	EclipseStarter.run(String[], Runnable) line: 180	
	NativeMethodAccessorImpl.invoke0(Method, Object, Object[]) line: not available [native method]	
	NativeMethodAccessorImpl.invoke(Object, Object[]) line: 39	
	DelegatingMethodAccessorImpl.invoke(Object, Object[]) line: 25	
	Method.invoke(Object, Object...) line: 597	
	Main.invokeFramework(String[], URL[]) line: 629	
	Main.basicRun(String[]) line: 584	
	Main.run(String[]) line: 1438	
	Main.main(String[]) line: 1414	

[Updated on: Tue, 27 November 2012 18:28]

Report message to a moderator

Re: Default Button problems on a Composite in Juno [message #987739 is a reply to message #987723] Tue, 27 November 2012 20:44 Go to previous message
Brian Fitzpatrick is currently offline Brian FitzpatrickFriend
Messages: 495
Registered: July 2009
Senior Member
It may be something similar to this issue found with RAP:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=329926
Previous Topic:Newline Character not treated as a whitespace in file compare
Next Topic:SimpleDB plugin not working right
Goto Forum:
  


Current Time: Sat Dec 20 18:38:33 GMT 2014

Powered by FUDForum. Page generated in 0.01876 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software